Floppy disk drive advice

By stuq24 ยท 7 replies
Mar 1, 2008
  1. I understand this is rather old hat now but I am currently looking at a dos 6.2 machine with a floppy disk drive that refuses to work. when i select the A: drive the system trys to read the disk (light comes on etc) but comes up with a seek error.

    when I try to abort this it won't allow me to exit and i have to rebbot the system.
    On the reboot with the disk in the drive again it tries to read the A: drive but doesn't register anything.

    I have also tried a format a: command from the c: drive and on attempting this a "formatting 360K parameters not supported message appears". i have checked the set-up in the BIOS (set for 3.5 inch 1.44mb) and everything else i can think of has anyone any ideas?

    I have also tried replacing the drive itself.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    It's the disk not the drive
  3. stuq24

    stuq24 TS Rookie Topic Starter

    Thanks for the quick reply but i have tried several disks now some brand new some that contain data relevant to the system and they all work on other floppy drives.
  4. raybay

    raybay TS Evangelist Posts: 7,241   +10

    The most common problem we see with the floppy drive, is that the floppy disks become hard and brittle with age, and can no longer be read by the drive. The problem is usually with the disk, not the drive.
    If yu want to use the information on that disk, you might try it in another floppy drive... as some are better than others.
    If you are just trying to evaluate your current floppy drive, use a new store-bought floppy disk... still available cheaply at some stores.
    However, lots of floppy disk drives also go bad from age.
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Formatted disks?

    And CMOS ok (set for 3.5 inch 1.44mb)

    Disks work ok in other computer


    Strange, I agree

    Either the system has a corrupted bios, or maybe the data cable (but I have NEVER seen a data cable do this)

    I wonder if the MB has two spots for FDD.

    Nah, must be faulty BIOS, please update with a bootable CD
  6. stuq24

    stuq24 TS Rookie Topic Starter

    I wish I could to be honest but it isn't an option the bios has an option for a second drive B i have also tried switching to this in which i get the same results. I think someone may have been playing before i got to this pc. i think i may have to try changing the mother board. is there any other way i can test the bios as it still seems strange that it is trying but not seeing anything
  7. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Check your BIOS to be sure that the floppy drive (under various names) is enabled. If it is, and still not working, the simple thing to buy an external floppy drive at Wal-Mart for $19.95.
    Or buy a used floppy drive from any repair shop of Salvation Army or White Elephant for $5.00 or less. Easy to put in. All OS will normally recognize any floppy drive, if enabled in the BIOS.
  8. smurfy2k

    smurfy2k TS Rookie

    follow raybay advice
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...