freezing & blue screens

By scottj ยท 67 replies
Aug 13, 2006
  1. View attachment Mini081306-06.dmp

    View attachment Mini081306-05.dmp

    View attachment Mini081306-04.dmp

    View attachment 7833

    View attachment Mini081306-02.dmp

    Hello, I ran Everest but the cpu temperature gave wildly different results. My PC is relatively new running XP SP2.

    It freezes a lot and gives a lot of blue screens, this generally happens when I get involved with media/films/itunes, well it is more prone then, I can usually browse quite happily and check email but when I use media it freezes/bsod.

    I ran memchecker and found errors, so I replaced it with new memory which I ran memchecker all night with and now shows no errors but my freezing/blue screen problems continues.

    I would be very grateful if someone could have a look at the minidumps and point me in the right direction? The messages on the blue screen often change, sometimes usbohci.sys, serial.sys & others. minidumps are attached, I have got like loads of these!!

    I have went to copntrol panel>display>settings>advanced>troubleshooter and put the slider at zero and disabled "enable write combining" it didn't stop the computer freezing.

    I have :
    AMD Athlon64 x2 4800+ dual core
    ATI socket 939 motherboard
    2048 corsair memory
    ati radeon x1600pro 512mb pci express
    600gb seagate SATA HD

    Running triple monitors.
  2. fastco

    fastco TS Booster Posts: 1,123

    All of your minidumps point to faulty RAM. If you have more than one memory module, try one at a time and see if the computer still crashes. If you only have one get some new memory from wherever you purchased the computer if it's still under warranty.
  3. scottj

    scottj TS Rookie Topic Starter Posts: 47

    I have 2x 1gb sticks of corsair, they were faulty and I bought replacements and have an NDA to send the originals back, so it has 2 new sticks in the machine, they pass memcheck.

    Could these new sticks be faulty as well and pass memcheck, that would be make me one unlucky guy.
  4. fastco

    fastco TS Booster Posts: 1,123

    That does sound very strange but that's what the memory dumps show. Could also be the video card memory,
  5. scottj

    scottj TS Rookie Topic Starter Posts: 47

    so could I remove my video card and run the pc with the onboard vga to see if that solved the problem maybe?

    View attachment 7844

    View attachment 7845

    Attached are a couple of dumps from when the problem started when it had the old memory, could you please see if they show the same symptoms?

    Thanks for your help.
  6. fastco

    fastco TS Booster Posts: 1,123

  7. scottj

    scottj TS Rookie Topic Starter Posts: 47

    Thanks for the help Fastco, I used driverclean and removed all ATI drivers and then downloaded the latest one's from the website, all went well yesterday however had another blue screen today.

    View attachment Mini081506-01.dmp

    Could someone have a look and see if this still looks like a memory problem?
  8. fastco

    fastco TS Booster Posts: 1,123

  9. scottj

    scottj TS Rookie Topic Starter Posts: 47

    View attachment 8637

    Could someone please check my minidumps, especially the latest one.
    I have updated video drivers but no joy I did use drivercleaner and installed fresh ATI drivers, I also managed to get another set of 2gb corsair memory and tried that in the system but no improvement, I have also put in another ATI graphics card of similar spec yesterday and no improvement, I updated the graphics drivers on the new card as well.
  10. scottj

    scottj TS Rookie Topic Starter Posts: 47

    I downloaded the debugger and there seems to be a few usbohci errors:

    An attempt was made to access a pageable (or completely invalid) address at an
    interrupt request level (IRQL) that is too high. This is usually
    caused by drivers using improper addresses.
    If kernel debugger is available get stack backtrace.
    Arg1: bb83e0f4, memory referenced
    Arg2: 00000002, IRQL
    Arg3: 00000000, value 0 = read operation, 1 = write operation
    Arg4: b9ac4883, address which referenced memory

    Debugging Details:

    READ_ADDRESS: bb83e0f4


    b9ac4883 83b818f7ffff00 cmp dword ptr [eax-8E8h],0





    LAST_CONTROL_TRANSFER: from bab917ca to b9ac4883

    bacd766c bab917ca 8983e9dc 10000001 5f697461 USBPORT!USBPORTSVC_LogEntry+0x11
    bacd7698 bab92e51 8983e9dc 00000000 88d6058c usbohci!OHCI_BulkOrInterruptTransfer+0xc0
    bacd76bc b9ab0e52 8983e9dc 895f1180 88d6058c usbohci!OHCI_SubmitTransfer+0x45
    bacd7704 b9ab155a 8983e028 895f1008 80545aac USBPORT!USBPORT_DmaEndpointActive+0x1f0
    bacd7730 b9ab398c 8983e028 00000000 80545aac USBPORT!USBPORT_DmaEndpointWorker+0x140
    bacd7758 b9ab52d3 8983e028 00000003 00000001 USBPORT!USBPORT_CoreEndpointWorker+0x6d2
    bacd77cc 806e76ec 8983e028 00000000 413e504d USBPORT!USBPORT_MapTransfer+0x76f
    bacd77f8 804eec04 897cfaa0 8983e05c 00000001 hal!HalAllocateAdapterChannel+0x126
    bacd7810 b9ab54ef 897cfaa0 8983e028 00000001 nt!IoAllocateAdapterChannel+0x2a
    bacd7854 b9ab630e 8983e028 8998e008 895f1008 USBPORT!USBPORT_FlushMapTransferList+0x1b1
    bacd78ac b9ab71f6 025f1008 ffffffff 80545aac USBPORT!USBPORT_FlushPendingList+0x5d6
    bacd78dc b9abe198 895de6b0 bacd7914 b9abdd5c USBPORT!USBPORT_QueueTransferUrb+0x248
    bacd78e8 b9abdd5c 8983e028 8998e008 85856b58 USBPORT!USBPORT_AsyncTransfer+0x30
    bacd7914 b9ac2dfe 893ff030 8983e028 00000090 USBPORT!USBPORT_ProcessURB+0x3f4
    bacd7934 b9aac1e2 893ff030 8998e008 8998e008 USBPORT!USBPORT_PdoInternalDeviceControlIrp+0x7e
    bacd7958 804eeeb1 8998e0e4 893ff188 85856b58 USBPORT!USBPORT_Dispatch+0x148
    bacd7968 a93fb50a bacd7990 a93ff2d9 8998e008 nt!IopfCallDriver+0x31
    bacd7970 a93ff2d9 8998e008 893ff030 8998e008 usbhub!USBH_PassIrp+0x18
    bacd7990 a93ffafa 8946cd50 8998e008 898fbc20 usbhub!USBH_PdoUrbFilter+0xbd
    bacd79ac a93fd1d8 85856b58 8998e008 bacd79e8 usbhub!USBH_PdoDispatch+0x202
    bacd79bc 804eeeb1 898e04f8 8998e008 899d2238 usbhub!USBH_HubDispatch+0x48
    bacd79cc babe14db 00220003 8998e0e4 80000000 nt!IopfCallDriver+0x31
    bacd79e8 babe076b 898c98c0 8998e008 b96fefd9 usbccgp!ParentInternalDeviceControl+0xbb
    bacd7a0c babe05d3 898c98b8 8998e008 0000000f usbccgp!USBC_InternalDeviceControl+0x3b
    bacd7a48 804eeeb1 898c9800 8998e008 899d2238 usbccgp!USBC_Dispatch+0x183
    bacd7a58 babe2231 80000000 00000009 00220003 nt!IopfCallDriver+0x31
    bacd7a88 babe0786 8978c0f0 8998e008 8978c0f0 usbccgp!FunctionInternalDeviceControl+0x1c1
    bacd7aac babe05d3 8978c0e8 8998e008 0000000f usbccgp!USBC_InternalDeviceControl+0x56
    bacd7ae8 804eeeb1 8978c030 8998e008 85856b58 usbccgp!USBC_Dispatch+0x183
    bacd7af8 bad98e91 8998e008 89647c38 8957f090 nt!IopfCallDriver+0x31
    bacd7b1c bad98567 898fbc20 8995bc00 bacd7b3b hidusb!HumReadReport+0xed
    bacd7b3c a9296e91 898fbc20 8998e008 8998e008 hidusb!HumInternalIoctl+0x69
    bacd7b50 a9298234 898fbc20 8998e008 8998e008 HIDCLASS!HidpCallDriver+0x3f
    bacd7b6c a929809c 898fbcec 8957f090 bacd7bb7 HIDCLASS!HidpSubmitInterruptRead+0x84
    bacd7ba4 804f13e2 00000000 8998e008 008fbcec HIDCLASS!HidpInterruptReadComplete+0x1d2
    bacd7bd4 b9ab3ee5 8998e008 85947008 8983e028 nt!IopfCompleteRequest+0xa2
    bacd7c3c b9ab4b57 85856b58 00000000 8983e7d8 USBPORT!USBPORT_CompleteTransfer+0x373
    bacd7c6c b9ab5754 026e6f44 8983e0e0 8983e0e0 USBPORT!USBPORT_DoneTransfer+0x137
    bacd7ca4 b9ab6f6a 8983e028 80545aac 8983e230 USBPORT!USBPORT_FlushDoneTransferList+0x16c
    bacd7cd0 b9ac4fb0 8983e028 80545aac 8983e028 USBPORT!USBPORT_DpcWorker+0x224
    bacd7d0c b9ac5128 8983e028 00000001 8055b0a0 USBPORT!USBPORT_IsrDpcWorker+0x37e
    bacd7d28 80544e5f 8983e64c 6b755044 00000000 USBPORT!USBPORT_IsrDpc+0x166
    bacd7d50 80544d44 00000000 0000000e 00000000 nt!KiRetireDpcList+0x61
    bacd7d54 00000000 0000000e 00000000 00000000 nt!KiIdleLoop+0x28


    bab917ca 8b4514 mov eax,dword ptr [ebp+14h]


    SYMBOL_NAME: usbohci!OHCI_BulkOrInterruptTransfer+c0

    FOLLOWUP_NAME: MachineOwner

    MODULE_NAME: usbohci

    IMAGE_NAME: usbohci.sys


    FAILURE_BUCKET_ID: 0xD1_usbohci!OHCI_BulkOrInterruptTransfer+c0

    BUCKET_ID: 0xD1_usbohci!OHCI_BulkOrInterruptTransfer+c0

    Followup: MachineOwner
  11. fastco

    fastco TS Booster Posts: 1,123

  12. scottj

    scottj TS Rookie Topic Starter Posts: 47

    Many thanks Fastco, I appreciate any ideas to try/test further.

    Motherboard Chipset ATI Radeon Xpress 200, AMD Hammer

    I have a microsoft wireless keyboard/mouse running off the usb port and an ipod cradle, I had previously disconnected the ipod cradle but it didnt help, I guess I should really get a normal keyboard/mouse first and then uninstall the usb controllers .

    Should I just right click on all the usn things shown here View attachment 8685 and click uninstall and then run the system testing it to see if I get a blue screen.
  13. scottj

    scottj TS Rookie Topic Starter Posts: 47

    So, I know it's good to update these threads in case someone else has the same problem.

    I got a normal keyboard/mouse and went into control panel and disabled all the USB gubbins

    View attachment 8750

    Then I went and did the usualy tests that more often than not ended up crashing the PC, running media/films/music.

    No more blue screens, but I am still getting freezing.

    Perhaps the USB is the cause of my BSOD, so I think there are 2 USB pci cards, maybe I should enable one at a time and see how that goes? Ultimately I'll need my USB functinality back at some point.

    If the BSOD is sorted then that still leave the fact that the PC still freezes mainly when using media/music etc, no mouse movement, no clock change, nothing just a complete lock.

    From googling freezing it is often attributed to overheating?
    I downloaded speedfan 4.29 and ran it, Im not sure how to analyse the results

    Looks like the main temp is fine around 25
    Both fans are working but the temp2 is way high, I don't know how accurate these things are or if this is the problem? Any suggestions as to a way forward from here would be great.
  14. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

    Get a second opinion. I've found that Everest closely matches the temps of the program that came with my motherboard. Open Computer then Sensor.
  15. scottj

    scottj TS Rookie Topic Starter Posts: 47

    I have tried Everest as well

    It shows roughly the same.
  16. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

    There's no way your motherboard's at 81C, temp1 in Speedfan is most likely it, and it's showing around where it should be. Check what the temps are in the BIOS.
  17. scottj

    scottj TS Rookie Topic Starter Posts: 47

    Thanks for helping Peter, when I hit Del to go into the BIOS it asks for a password, I never set a password and hitting return doesnt work so I dont know if there is a default pass, so I am awaiting an email from the company I bought the box from to see how to get past that to check the bios.
  18. scottj

    scottj TS Rookie Topic Starter Posts: 47

    Hmm that's a false alarm about the bsod stopping, now had 2 tonight :((

    View attachment 8766
    Could not read faulting driver name
    Probably caused by : ntkrpamp.exe ( nt!ObpCaptureObjectCreateInformation+135 )

    View attachment 8767
    Could not read faulting driver name
    Probably caused by : win32k.sys ( win32k!IsRestricted+43 )

    Wonders if I should have just bought a 2nd hand setup...........
  19. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

    Nothing new. I had a look at the dumps in your first post and one of them references AmdK8.sys - the CPU driver. You only need this if you use Cool 'n' Quiet, so you can safely uninstall it and Windows will use it's own driver, you can always reinstall it if it isn't the problem.
  20. scottj

    scottj TS Rookie Topic Starter Posts: 47

    How do you uninstall a system driver like that?
    I can find it and delete it from windows/system32/drivers and right click delete it manually?
  21. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

    It should be in the add or remove program list.

    EDIT: I've now had time to look at the dumps from post #9. They point to the SATA controller (Silicon Image). What's the make and model number of your motherboard, as most come with two SATA controllers. If it's got two you can swap the HDD over.
  22. scottj

    scottj TS Rookie Topic Starter Posts: 47

    Thanks, I found the AMD K8 driver in the add/remove so I have removed it and restarted.

    All USB devices are still diabled.

    My receipt says: ATI Socket 939 motherboard

    I have two hard drives, receipt says 600GB Seagate SATA hard disk, there are 2 seagates that make the 600 though I think. Actually having a look inside, the red cables that come from the 2 HD's attach to 2 of four SATA's on the motherboard.
    It says SATA 4,3,2,1,
    My HD's are connected to 4,3
    So do you mean try the other 2 SATA's for the hard drives?
  23. scottj

    scottj TS Rookie Topic Starter Posts: 47

    OK I do seem to have a sata problem, haven't touch anything inside but I went to windows update and chose 'custom' rather than express and there it advises a SATA driver
    ATI 437A Serial ATA controller

    I say ok and it installs and asks for reboot, done.
    Restart and Windows recognises new hardware ATI 437A and say it's installed but won't work until I reboot, so I do.

    Now update shows that the driver failed to install
    View attachment 8779

    So I check my system and it's not properly installed the driver
    I right click on the ATI 437A and choose update driver but that fails

    The name is already in use as either a name or a service?

    EDIT: I went back, right clicked on it > Update driver and chose the original one Version instead of the Windows update one and that worked so I havent actually moved forward any, just undid the optional update from windows.
  24. scottj

    scottj TS Rookie Topic Starter Posts: 47

    New minidump
    View attachment 8790

    Make reference to amdk8.sys perhaps I should look to install it again?
    If I go into Device Manager and check the processor's driver it says AMDk8.sys

    Use !analyze -v to get detailed debugging information.

    BugCheck 100000D1, {47833, 9, 0, ba003d8f}

    Unable to load image AmdK8.sys, Win32 error 2
    *** WARNING: Unable to verify timestamp for AmdK8.sys
    *** ERROR: Module load completed but symbols could not be loaded for AmdK8.sys
    Probably caused by : i8042prt.sys ( i8042prt!I8042MouseInterruptService+f )

    Followup: MachineOwner
  25. scottj

    scottj TS Rookie Topic Starter Posts: 47

    Decided to try and move my 2x HD cables from the existing 2 sata's into the mobo into the 2 spare sata's and the comp went str8 to a bsod "unmountable_boot_volume" so I guess thats not good, put the cables back.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...