GeForce 3 Ti 200 - Drivers don't work...

By Craneskin · 5 replies
Dec 17, 2003
  1. My system:- Lex nForce 2 board; Athlon 2800+; 64MB GeForce 3 Ti 200; 256MB DDR; 160GB Seagate HDD (40 + 120); SoundBlaster PCI 128.

    Just wondering if any of you folks out there are having as much trouble with your GeForce 3 Ti 200 as I am... OK here's the story..

    I've had the card since late 2001, and it ran well with nVidia's Detonator Drivers under Win ME (although the drivers caused it to take about 4 minutes for the system to boot, for some reason, and I had to install the driver manually from the unzipped folder using Device Maganer, 'cos the installer kept returning syntax errors whenever I ran it... nVidia drivers still do this, by the way, even though I'm now using a totally different system with XP Pro)... The trouble started when nVidia changed to the Forceware Driver.

    With the card still in my old system, I upgraded to Win XP Pro, and started getting serious system crashes. After logging onto Windows after a re-boot, the PC got as far as drawing about half the icons on my desktop, then froze for a couple of seconds before switching itself off and re-booting. Upon re-start, the system reported that "Windows has recovered from a serious error. This error was caused by a device driver.", and named the nVidia Driver as the culprit (I've subequently discovered that the driver was sending the card into an infinite loop). Laterally, this was happening 3-4 times a day, so, in utter exasperation, I bought £300-worth of gear, a new ATX case, and completely re-built my PC.

    If anything, it's now even worse..

    Now, whenever I try to update the driver (using the Device Manager method, 'cos it's the only one that I can get to work..), the screen goes black right at the end of the installation, and just sits there with a DOS cursor flashing in the top-left corner 'til I press the reset button. Upon re-booting, the system only has a partial install of the driver, and reports missing .dlls all over the place. All I can do at that point is uninstall the lot in Safe Mode and revert to the old 45.23 Detonator (the most recent nVidia set that I can get to install properly..).

    Anyway, the upshot of all this is that I'm about to rip the damned thing out of my PC and dance on it before heading for PC World to buy a Raedon, unless anyone else out there has any ideas for fixing it... All suggestions welcome!
  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    I've seen a Radeon 7500 do the same thing.

    Manually installing the new driver, in safe mode was the only solution to it.

    Your situation may be worse though. :)

    Lower your AGP speed settings in the BIOS (Use AGP 2x for example) and disable the fancy stuff, like fastwrites. This may help aid you in your quest.

    You may also want to toggle Plug N Play OS off in your BIOS. I've heard of this causing problems with Geforce cards.
  3. iss

    iss TechSpot Chancellor Posts: 1,994

    I would offer three suggestions.

    1. download driver cleaner and use to to completely remove previous drivers you have installed. you can get it here.

    2. go to your card manufacturer's web site and download the driver they recommend for your card. typically this will probably be a 28.40 sries driver or one slightly higher. ( Later drivers do nothing for the performance of the geforce Ti 3 series of cards.)

    3. Disable fastwrite either in the bio or through your cards utility in advanced features. fastwrite offers little performance increase, if any at all but it does definitely lead to system instability on many systems.
  4. Steg

    Steg TS Rookie Posts: 269

    My (creative) Ge3Ti does EXACTLY the same with any driver revision newer than 44.03. However, my fathers Ge3Ti (leadtek i think) installs and runs the 52.16s fine - i think its just a case of manufacture customisation
    if you do roll back ur drivers to an earlier version go with the 4x.xx's - the promisied 25% performance boost is closer 15% but its still there - even on a old ge3ti200 - and 3dmark 01/03 can do nothing about it - i is a REAL compiler optermisation - not a cheat

  5. tripleione

    tripleione TS Rookie Posts: 154

    Have you installed the latest drivers for your motherboard? Many times problems like this one can be caused by the motherboard and other device drivers not communicating properly through the operating system.

    For nForce2 boards, you'll want the
    nVIDIA Unified Motherboard drivers, which contain AGP, IDE, memory controller and ethernet drivers. It also fixes bugs found in the previous drivers and improves overall compatibility.

    If after installing these drivers your problem persists, you should try more hardware-direct problem solving methods. As aforementioned, try turning your AGP to 4X (or 2X if you only have a 4X motherboard) and turn off Side Band Addressing and Fast Writes. Also, try relaxing your memory timings a bit if they are very tight (fast) as some memory cannot handle higher latencies as others can.

    Finally, check to make sure your video card's fan (or any fan for that matter) is being blocked by cables in your case, and make sure your fan is actually spinning. Even simple things like this can be overlooked at times.

    I hope that helps a bit. Please come back and tell us whether you resolved the problem or not.
  6. Craneskin

    Craneskin TS Rookie Topic Starter

    Many thanks, guys, for taking the time to read my post... Now at least I know I'm not the only one gibbering at my monitor over this problem..! :eek:)

    Rick's idea for switching off all the advanced AGP features on my board seems to have helped a bit.. I'm not getting as many "Serious Error" re-boots since I changed the BIOS settings.. Good call, man!

    I haven't bothered to muck about with the Detonator driver, since it seems to be relatively stable at the moment and is running everything well (except Deus Ex 2, but that's another story...), and if it ain't broke, as they say, don't fix it. As iss says, there's no actual improvement in the performance of the GeForce 3 Ti with the new driver anyway, so the hell with it.

    Tripleione made a good point about the nForce driver, though, and Iss's suggestion for using the driver cleaner got me thinking about solving another little (related) problem I've been having with an nForce driver. I don't know whether all nVidia's driver packages have a generic structure which is, somehow, incompatible with my OS, but the installer for the nForce driver returns exactly the same "Syntax Error - A file, extension or folder name is invalid" error message as the Detonators when I'm trying to install them. I tried completely un-installing the nForce driver and re-installing, but the install froze half-way through, and I had to patch all the holes in the installation manually from the unzipped folder using Device Manager.. So it's currently running on two half-sets of drivers from different releases - not too good, I should imagine...

    Anyway, does anyone happen to know if there's a tool, similar to the GeForce Driver cleaner that Iss mentioned, for cleaning old nForce drivers from your OS..? Dunno if that'll help, but it's worth a try.

    Once again, thanks for being human beings and helping a guy out.. An exasperated Scotsman thanks you from the bottom of his sporran!

    Oh, and Merry Christmas, incidentally! :eek:)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...