Geforce 5500 Blank Screen After XP Logo

By moondok ยท 11 replies
Nov 19, 2005
  1. I am trying to upgrade from an ATI card to a new NVIDIA Geforce FX 5500 OC AGP 8x/4x/2x 256mb card. The computer has an AMD Sempron processor, 1gig ram, 450watt PS, and the motherboard is setup for AGP/PCI Express/PCI Express 16. It does NOT have onboard or integrated video.

    The geforce info comes on the screen just after the power button is depressed. I get to the XP Professional loading screen (where the little percent bar has a box running back and forth). It sits there for what seems longer than usual, then the screen goes blank. The monitor acts like it gets no signal and goes into powersaving mode. I can reboot and go into safemode without any problem. In fact, I am running this way right now. Any ideas?

    I have removed all ATI software. I am about to clean the registry with Registry Mechanic just to make sure everything is out of there. I originally used add/remove programs to remove the drivers/software/control center. I have checked the BIOS and found nothing to do with AGP or Video settings besides the palette snoop which is disabled like the geforce manual says. Someone please help me before I go insane! lol
  2. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    Download the latest video driver from nVidia. Then boot into Safe Mode and uninstall the nVidia driver thats there now. Then reboot and install the new driver.
  3. moondok

    moondok TS Rookie Topic Starter

    Update-Still need help

    Tried your suggestion with now luck.

    I have called tech support at BFG Tech 3 times. The second time, the tech told me to take the card back. I did that and still have problems. The third tech said it was probably a hardware conflict between the MB and video card, but there was nothing else he could do.

    Here is my current problem:

    I can boot into XP if no driver is installed. When I install a driver, everything is fine until the driver itself becomes active. Right before it asks to restart the machine, the monitor blinks a couple times then shows all commas. That is using the latest drivers and the ones from the CD that came with the card. I also tried older drivers per the tech's suggestion. Instead of getting a screen of commas, the screen eventually comes back saying that the driver stopped responding and I need to restart the computer at which time I can send an error report to Windows. That seemed odd having to wait until after a reboot to send the error log, but it obviously has nothing to do with the problem. At this point the screen has all kinds of colors on it but is legible enough to uninstall the drivers and restart.

    I am uninstalling with add/remove programs, registry mechanic, and driver cleaner pro.

    My motherboard is a Jetway 754GT-G with PCI Express/PCI Express 16 and AGPC slots. There is no jumper, bios, or software setting to choose which of these three is active. It is supposed to be "automatic". As I said before, I can get into XP Pro without the drivers installed.

    Has anyone figured out why this is happening?
  4. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    Its not uncommon for something like this to happen when you switch video card. Its usually easier to to a clean install of Windows than to chase down a cure. Also I read a review of that board that said to use older drivers when using the AGP slot.
  5. moondok

    moondok TS Rookie Topic Starter

    Solution Found

    After coming up short with web searches and calling the video card's tech support, I finally called the motherboard's tech support. It turns out that there was a bios update not available on the web. It is specific to my board (754GT the bios update being 754GP). Also, there was some confusion about MB model. Mine is not the GT-G. It's GT-P. It is listed as one or the other depending on where you look. The update addresses a CPU load problem when an AGP card is used but only after a driver is installed. Thanks for the help, but it was one of those fluke things that no one but the manufacturer could answer. I hope this helps someone else out there. JetWay MBs are getting very popular and seem to be of high quality.
  6. scozzb

    scozzb TS Rookie

    same prob

    iv had the same problem with my geforce fx5500 except i cant even boot in safe mode. I read a post on one site sayin that its the onboard sound card but even if I disable that it still doesnt work, the com boots fine its just wen it's finished the screen goes blank but the com is still working, ill put in my password and the windows loading sound plays but 6the screen is still blank....
  7. MDew

    MDew TS Rookie

    POS video card

    I'm having the same problem with my fx5500. It gets to the WinXP boot screen and either freezes on the screen or on a black screen. I also erased any traces of my old video card, an ATI - both in the add/remove programs and Device Manager. I put the old video card back in and installed the newest GeForce drivers from the website, still no luck. Tried to install the drivers from the included cd, and it locks up the computer when I try to open it. Driving me mad!!!

    1.5 GHZ AMD Athlon Processor
    64MB ATI Radeon 7200 video card (Changing to GeForce fx5500 256MB)
    512 MB RAM
    DirectX 9
    Windows XP Home
  8. jpdsurf

    jpdsurf TS Rookie

    Really? My Dell D-3000 works fine....

    I only have a problem with the Beta drivers, so I use the CD drivers or the updated one which, by the way, just came out and it works fine for me.

    When I put in my FX 5500, I did a clean install of XP first, unplugged the power and then I put in the FX 5500 card. Next, I switched VGA plug from my onboard card to the NVIDIA card and *POOF* COD was off and running. What a game and my FX 5500 card runs like a dream. This NVIDIA card is the last hope for us saps with PCI slots. I think it's a good card.

  9. scozzb

    scozzb TS Rookie

    driver prob

    i would try and install the drivers from the cd but when i put my graphics card in (and boot from onboard graphics) the com isnt recongising its there i've looked on the device manager but the card doesn't show up. and when i try to install the drivers it says that there is hardware/software missing, i've even tried getting the drivers from the website but that doesn't work either. but ill try a clean boot at the weekend and see if that helps.
  10. jpdsurf

    jpdsurf TS Rookie

    Well? Did it work?
  11. rockhead rumple

    rockhead rumple TS Rookie

    if your fx5500 is working now what do you think of it
  12. jpdsurf

    jpdsurf TS Rookie

    It's great.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...