GPU buzzing / whining at very high fps

Filip B

Posts: 46   +9
Hey guys I've got a problem. My GPU GTX780 GHz is making a buzzing / whining sound at very high fps and I mean 300+. I tried to google it but most buzzing seems to be made by PSU however PSU has nothing to do with fps. And I assume that the power consumption is roughly the same when playing Crysis 3 120 fps or Dead Space 2 400+ fps.
Yes I know I could use v-sync but sometime it causes noticeable input lag.

Is it normal? Safe for the GPU? Does it go away?

Thanks for info
 

Spykezxp

Posts: 296   +73
What is you PSU make and model? When was the last time you cleaned your system out (physically powering down, opening the case and removing all the dust - especially on all the fans)? Do you monitor your internal temps when you game - if so what are they when you game? Have you overclocked anything?
 

Filip B

Posts: 46   +9
What is you PSU make and model? When was the last time you cleaned your system out (physically powering down, opening the case and removing all the dust - especially on all the fans)? Do you monitor your internal temps when you game - if so what are they when you game? Have you overclocked anything?

My PSU is Seasonic SPP-750RT 750W. It's a fairly new rig and I do clean it very often plus my Noctua fans keep almost all dust outside. Temps are fine. Crysis 3 ultra between 60-70C and I also mentioned Dead Space 2 so with vsync roughly around 50C without vsync hitting almost 70C. ATM nothing is OC'ed.

I don't suppose that it has anything to do with PSU or high load it must be something with the frame rate.