Great Site Thanks, printer is the problem now.

By JohnH · 10 replies
Jan 31, 2005
  1. Firstly a big thankyou to all the contributors on this great site. By searching the old posts I have managed to identify, download and install a graphic display adaptor driver and an onboard audio device driver for my PC. (A special thanks to Howard)

    I now have everything running except my printer and I have really hit a brickwall with this one.

    When I reloaded Win 2000 (That’s when I lost sound and the display pixilated, now fixed) the printer installed as per normal printed the test page and everything looked sweet. On restarting the system I lost the printer function.
    Now when I go to control panel / printers my (BJC – 2100SP) icon is gone just leaving the add printer icon.
    When I click add printer I get an out of resources message, the print sub system is unavailable.
    In the device manager on the printer there is a ?
    Also on start up I get a SPOOLSV. EXE error message. (Not sure if this is related)

    Now I have tried unplugging the printer deleting all the drivers and starting from sctatch with the printer disk. I have let windows detect it and install its own driver all to now avail. What puzzles me is it worked fine until the fist time I shut down.

    Any direction greatly appreciated

    Regards John

    OS Win 2000 prof
    Intel Pentium 3
  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Welcome to TechSpot

    It is. Spoolsv is the printer spooler service. What's the error message?
  3. JohnH

    JohnH TS Rookie Topic Starter

    The error Message goes

    Spoolsv.exe has generated errors and will be closed by windows.
    You will need to restart the program.
    An error log is being created.

    This happens each time at start up.

    Thanks for your prompt response.
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    go to the Run box on the Start Menu and type in:

    sfc /scannow

    This command will immediately initiate the Windows File Protection service to scan all protected files and verify their integrity, replacing any files with which it finds a problem.

  5. JohnH

    JohnH TS Rookie Topic Starter

    G,Day , thanks for the scan now info, I ran it thru but did not seem to detect anything wrong, I noticed another fault while playing around, RPC server is unavailable, I think the spooler is dependant on this ????

    Anyway I did a RPC search on this site and followed the following advice below to no avail, anybody feel like a challenge because I am way out of my depth now but my patience is still hanging in.
    Would a clean sweep reinstall of win 2000 be the next step as the printer did work up until the first power down?

    Regards, John

    I am not really sure about this, but I would try the following:

    Under Control Panel, go to Administrative Tools, and Services.

    Browse down till you see two items "Remote Procedure Call (RPC)" and "Remote Procedure Call (locator)". Start both of these services by clicking the > or by right clicking on each one and click Start.

    Then see if that makes a difference. Again, I'm not really sure if it will, and I don't know what RPC would have to do with playing music or installing programs but it is worth a try.

    Also check Administrative Tools, Event Viewer for any errors related to RPC that occured when you had the problem.

    try clearing tmp files. You might also try deleting installshield. Installshield will sometimes give and RPC related error. This has something to do with the version on the machine being too old and it uses that rather than the newer one the app is packaged with or something(I'm not exactly sure, just know that I've seen it referenced as a fix for RPC errors related to installing certain apps)
  6. JohnH

    JohnH TS Rookie Topic Starter

    Did a Spoolsv search on the microsoft knowledge base and would you believe it the first entry was how bitware causes this exact fault with win 2000

    Remedy remove bitware.

    Now that explains why the printer worked first off and then I loaded bitware.

    I hope this info helps someone else out.

  7. kati

    kati TS Rookie

    No hair left! My printers have disappeared!

    Using Windows 2000 OS. No problems until yesterday when Bright House swapped out a new modem. System no longer recognizes the existence of any printers or printer software, nor am I able to attempt a re-installation without getting a "Severe error" message before Install-Wizard aborts install.

    I have followed the suggestions of the previous posts on subject, to no avail. Everything seems o.k. Each time I double click on 'Printer', 'out of resources' error message pops up and simultaneously, print spooler shuts off. Does anyone have any idea what is going on or what the remedy is? I don't want to spend $700 to take this into the shop!

    Thanks for any and all experienced-based suggestions!

  8. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    Your printers may have changed IP addresses when installing new equipment. You may want to check and correct it.
  9. IronDuke

    IronDuke TS Rookie Posts: 856

    Check in Device Manager for conflicts. Also try re-installing the printer driver from here.
  10. kati

    kati TS Rookie

    Printer/installation problems

    Appreciate the quick reply, guys. I had a revelation as I pulled on my last precious hairs... my failing high-speed Internet modem was just swapped out 3 days ago for a new one. The technician used a USB connection instead of a "card". Apparently, the use of that USB port is disrupting at least two critical pathways required for the printer to function, as well as any downloading or CD installation of software. My provider had not received any complaints about same malfunction. However, we conducted several tests and determined that once the modem cable is removed from the USB port (when computer is OFF, FYI) and the computer is then restarted, the system then recognizes all loaded printers. When the modem cable is reinserted and print function initiated, sytem indicates there are no printers once again and the headache returns. No one can explain to me WHY this is occurring, but for other Windows 2000 users also receiving "Out of resources..." error messages with similar results, this may be useful information.

    Anybody else have USB port interference expertise relevant to this problem??
  11. IronDuke

    IronDuke TS Rookie Posts: 856

    Kati glad you've got a solution if not an answer.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...