Half Life 2 fails to load

By cookiemoose · 122 replies
Nov 18, 2004
  1. Hi,

    I finished installing HL2 about 4 hours ago and still haven't managed to get it working correctly. When I click on Half-Life 2 in Steam I get the "Preparing the play Half-Life 2" dialog which disappears after around 20 secs and the cd drive makes a noise like it has begun playing the disk.. and then, nothing. I get no errors, nothing - it just doesn't load. However, it has managed to load once before and I managed to play, but have not been able to do it again for the last few hours. My specs are as follows.

    AMD Athlon 64 3400+
    512MB RAM
    Radeon Mobility 9700 128MB

    I have tried updating drivers and such for the radeon without any luck.

    Right now, I'm out of ideas.

    Any suggestions?
  2. Jam_sponge

    Jam_sponge TS Rookie


    Yeah, i spent 40 quid using my bluetooth mobile to download all the annoying steam stuff, cos i can't connect to the net from uni properly, and i'm having the exact same problem.

    it says- loading half life 2, then nothing.
    no errors, doesn't even spin the cd.

    We seriously need some help here.

    AMD athlon xp 2400+
    Connect 3D Radeon 9600 Series 128m
    1 Gig Of Ram

    could be the Radeons... hmmm
  3. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    Have you searched on Google? I get alot of answers there.
  4. Jam_sponge

    Jam_sponge TS Rookie

    Yeah, tried looking on google for hours, unfortunately it's kinda hard to find any information when there's not even an error message or any kind of identifiable problem. :(

    Even worse, all i can find on google is pages and pages of people telling me how good HL2 is, haha.

    This MUST be a reasonably common problem, surely?
  5. cookiemoose

    cookiemoose TS Rookie Topic Starter

    It doesn't appear to be common at all -- and even if it is using google seems futile right now for an error with no error message.

    Jam_sponge, could you give me some more detailed specifications of your machine perhaps we can identify a common piece of hardware which may be causing the problem.
  6. Jam_sponge

    Jam_sponge TS Rookie

    Not entirely sure what else to list.
    Obviously it's not a very common problem, i'm just assuming more than 2 people in the world have experienced this, hehe.

    well, it's a 2,00mhz processor,
    using windows XP, all updates
    Nvidia N-force2 onboard sound and the rest
    A347SCSI SCSI Controller

    anything else you want listed, let me know.
    I'm using steam in offline mode btw, so i didn't think net conn. was valid.
    although online mode won't work either. :(
  7. cookiemoose

    cookiemoose TS Rookie Topic Starter

    Would you know what chipset you are using?
  8. BrentB929

    BrentB929 TS Rookie

    I had/have the same problem( I havent seen if it's entirely fixed) but I found one solution that might work:

    1. Update the firmware for your cd-rom's company's site

    2. uninstall and reinstall the drivers for your graphics card and then update them

    3. go to windowsupdate.microsoft.com and update windows from there

    hopefully this will help you out b/c so far the game has started up with no problems BUT before i knew about this solution the game would work once and after I exited it, turned off and booted my computer back up it wouldnt work and right now since it is working i'm too scared to turn my comp off(thats why I don't know if this works fully)

    couldn't hurt to try though

    If you're wondering my specs are:
    AMD 64 3000+
    ATI Radeon 9800 Pro
    Asus K8V mobo
    Lite-On DVD/CDRW combo CDrom
    no sound card
    160GB Maxtor HD
    1 GB of RAM
  9. BrentB929

    BrentB929 TS Rookie

    Nevermind...I turned off my comp, turned it back on, tried to play and got the "Preparing to play Half life 2..." and nothing happened

    back to square one :(
  10. Jam_sponge

    Jam_sponge TS Rookie

    Did you guys all install and update half life 2 from your own pc with a direct internet conn?

    Cos i did a kinda funny technique of copying steam across and then updating via my mobile phone. i don't THINK the copying steam across caused a problem, but it might have done.

    I did delete the registry.blog file thing, just to check if that was the case, and then it sorted itself out again for my pc, but still no avail.
    i can't even get it to run first time! haha
    I've even tried closing down all other background programs, nothing.

    it's all rather random.
  11. Jam_sponge

    Jam_sponge TS Rookie

    OS Name Microsoft Windows XP Home Edition
    Version 5.1.2600 Service Pack 1 Build 2600
    OS Manufacturer Microsoft Corporation
    System Manufacturer eveshamvale
    System Model AWRDACPI
    System Type X86-based PC
    Processor x86 Family 6 Model 8 Stepping 1 AuthenticAMD ~2004 Mhz
    BIOS Version/Date Phoenix Technologies, LTD 6.00 PG, 03/10/2003
    SMBIOS Version 2.3
    Windows Directory C:\WINDOWS
    System Directory C:\WINDOWS\System32
    Boot Device \Device\HarddiskVolume1
    Locale United Kingdom
    Hardware Abstraction Layer Version = "5.1.2600.1106 (xpsp1.020828-1920)"
    Time Zone GMT Standard Time
    Total Physical Memory 1,024.00 MB
    Available Physical Memory 609.23 MB
    Total Virtual Memory 3.40 GB
    Available Virtual Memory 2.69 GB
    Page File Space 2.40 GB
    Page File C:\pagefile.sys

    Right, there's all the system info on one page.

    Mine doesn't even seem to check the CD drive when it says it's starting HL2,
    but i'm assuming it's nothing to do with the CD drive, as otherwise it would just ask for the disc, i guess... :confused:
  12. cookiemoose

    cookiemoose TS Rookie Topic Starter

    I installed it with a direct internet connection. Apart from us all having an AMD processor and a Radeon 9X00 card, I can't see any other connection.

    I've been uninstalling/reinstalling cdrom drives/updating drivers/reinstalling original drivers for almost everything. Apart from formatting now, I'm really stuck for options.
  13. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Has anyone looked in the event viewer under applications to see if there are any errors there?

    Regards Howard :grinthumb
  14. cookiemoose

    cookiemoose TS Rookie Topic Starter

    Nothing there.
  15. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    I`ve just found this info don`t know if it will help or not.

    November 19, 2004, 11:03 pm · valve
    A small number of Half-Life 2 customers have been experiencing problems while playing the game, and we have traced these issues to corrupt Steam cache files. We've released a Steam update to help resolve these issues. If you have been experiencing problems such as crashing during gameplay or startup of Half-Life 2, please restart Steam and then click on one of the links below. Steam will then automatically verify your cache files. The verification process will take roughly five minutes to complete.


    Regards Howard

  16. cookiemoose

    cookiemoose TS Rookie Topic Starter

    No luck with that either. Thanks for suggesting anyways.

    It bothers me that I've had it running once before also, else I probably would have been formatting/given up at this point.
  17. cookiemoose

    cookiemoose TS Rookie Topic Starter

    Does anyone with this problem have McAfee firewall installed?
  18. Jam_sponge

    Jam_sponge TS Rookie

    nope, i do have some virus scanning software, but i've tried switching it all off, and it's no different.
  19. Jam_sponge

    Jam_sponge TS Rookie

    ok, seems like this problem has been put to the side, so to speak.
    is it just that everyone has given up? or have you all fixed it and gone off to play HL2, haha. (i notice the first guy to post hasn't been back, so maybe he's sorted it, hehe)
  20. kaos

    kaos TS Rookie

    Just to add to the confusion.

    I'm running:
    P4 2.8GHz
    Intel 875 M/B
    1GB Ram
    Geforce FX 5600
    Benq DVD Re-writer

    And have exactly the same problem as you all, HL2 fails to load, comes up with the preparing to load HL2, spins up the DVD, then nothing!!

    I've updated to XP SP2 no other critical updates are available, DX 9.0c, the latest Nvidia drivers, I've flashed my DVD burner, and it still doesn't load.

    I tried checking the cache files as well that Howard suggested, and still nothing!

    I've now uninstalled HL2 and Steam, and will try and reinstall it later.
  21. Wasted

    Wasted TS Rookie

    I´ve got an:
    xp64 3200+
    1GB Geil Ram
    Geforce FX ti-4200
    160 GB Hiatchi harddisk

    And have exactly the same problem, HL2 fails to load, comes up with the preparing to load HL2, spins up the DVD, then nothing!!

    Nothings running in the background and no resources used by windows.

    Installed on my laptop at first. No problem there other than it could'nt handle the game. Startet up just fine and were looking forward getting it installed on my new system at home.
  22. AcemanOne

    AcemanOne TS Rookie

    Same problem here too...trying to get support from Valve but they haven't responded in 3 days. Have yet to get anything other than steam to work...not too happy about paying $60 for just a steam client.

    AMD XP 3000+
    1GB PC2700
    ATI Radeon 9800 Pro 128MB
    200GB Maxtor 7200RPM 8MB cache
    WinXP Pro

    VERAULT TS Rookie


    I know I am STILL! having this problem. I can only get hl2 to run on my amd 1400 with geforce 3. ITs running windows 2000 also. IT runs on that machine but crashes regularly.
    I cant get it to run on my newer dell machines. they are Dimension 8300's with nvidia 5200 FX cards.

    Are all of us who have this problem using the DVD (NOT 5 disk cd set)? That might be something we could look into, whether or not its a dvd specific issue. This thread is the only place on the net I found relating to my problem, excuse me, our problem.

    I too am running all the newest updates with direct x9c. I am going to try a much older version of driver for my video card and see what happens. You guys out there keep posting, we have to figure this out!
  24. AcemanOne

    AcemanOne TS Rookie

    I installed from the 5 CD set...twice now.
  25. jmiddler

    jmiddler TS Rookie

    Can't get it to work either

    Glad to have finally found a thread where people have the same problem. Have heard nothing back from Valve for 4 days. Can't get it to laod either. Have tried updating XP and drivers. I'm using the DVD version and my spec. is

    Ferrari 3000

    AMD XP 2500+
    Radeon Mobility 9200
    Window XP Home
    60 Gigs

    Getting very fed up with this now. Has anybody tried bringing it back and getting another copy. Maybe it's our individual DVDs that have a problem.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...