Half Life 2 fails to load

By cookiemoose · 122 replies
Nov 18, 2004
  1. AdamRG

    AdamRG TS Rookie


    Same deal. I have installed both a different DVD drive and installed that "HiJack." Nothing works for me.. Not HL2, or the online games. Do I have to reinstall with this new drive!?

    I dont suppose any of you installed a ripped version of the game? I had and decided to buy. Could this be a common trait that no one is willing to bring up? Now Im considering going back.. To think, Steam was designed to prvent this kind of thing.
  2. kosei

    kosei TS Rookie


    Okay, so I've been playing hl2 for about 5 days now. I stopped earlier today, and there was an update. As soon as I got done downloading, I went to play the game. I got this same problem - just a simple crash as soon as the program loaded. I checked the task manager only to find that hl2 actually loads then closes. I downloaded hl2 instead of purchasing it, so it's not a cd problem, and I've tried both in online and offline modes. I'm thinking that it's an update problem since I've been playing for a long time before this, but I don't understand what it could be and this is really teh only place I've found that even mentions it.

    Does anyone have any ideas? Steam forums are down and there's nowhere else for me to go!
  3. AdamRG

    AdamRG TS Rookie

    Perhaps, apparently there are a lot of problems with the newest update. Hence the forums at steampowered being down. But the first post on this thread was from 2 weeks ago.
  4. TeranteK

    TeranteK TS Rookie

    I have the same problem as Kosei, I've been playing since it was released (I've started successfully about 50 times) but then just after i got the latest update a couple of hours ago i get this problem.

    Athlon xp2400+
    Asus a7n8x deluxe (nforce2 chipset)
    80gig HDD
    Sony DVD-+RW
    512MB RAM
    128 MB Geforce 4 ti4200 8x

    I have the DVD but i dont have access to another dvd drive and its been working for so long. Any ideas, i'm dying to try DM.
  5. KageX

    KageX TS Rookie

    I just got the same problem 2day after dloading the updates. I do have the original dvd of the game but couple of days before i dloaded a ripped version on the net. I would be suprised if this is an answer to ppl like me whom cant wait to buy the game to try it out, but it really sucks that i cant play cs now...Im soooo freaking pissed. I think it's steams update that messed it up, or perhaps the cd/dvd rom devices! We need to fix this or else alot of ppl r gonna b pissed, waited long for this game to come out and now look what happens! ...and i just got my 7.1 system...barely tried it once yesterday....

    p4 3,0 g
    ati radeon 9X00
  6. TeranteK

    TeranteK TS Rookie

    OK so theres lots of people with the problem, but is there anyone without the problem with the latest HL2 update, it might help us work out what's wrong with the ones which dont work.
  7. stargazer

    stargazer TS Rookie

    Behold the ULTIMATE SOLUTION my friends (well, it worked for me) for the "no error message error"... it's the same error as the one that says that the drive is trying to read the disk too fast, so I downloaded an app called Nero DriveSpeed and reduced the Speed to 8X... needless to say it finally worked, otherwise I woundn't be posting here... for those with the DVD Retail version, there is a Nero DVDSpeed or something like that, I'm not sure what the name is, but if you search for the DriveSpeed on google, finding the equivalent to DVD is not that hard... now that I can run this crap, time to solve the ever-popular stuttering problem...
  8. markdinosaur

    markdinosaur TS Rookie

    behold, no solution

    I'm another muppet that downloaded this and get 'preparing to play half-life 2' and then nothing. I want my money back.

  9. Malt

    Malt TS Rookie

    Worked fine until update dated 30/11/04

    when i first bought hl2 my 2 yr old LG DVD drive couldn't read the disc, so i bought a new Sony one which worked fine. installed it the game, registered it using steam and must have played it about 10 times now. until this morning... steam downloaded an update - something about buffers, dated 30/11/04, and since then i haven't been able to run it. Just like everyone else i get the "Preparing to play Half Life 2..." dialog, which then disappears, my DVD drive is accessed and that's it. nothing. I have posted a question to the official support site regarding this but not heard back yet (has only been a few hours!) but hopefully valve will issue a new update to fix this problem which it seems alot of people are having. such a shame as it's an amazing game :(
  10. rollen

    rollen TS Rookie

    Preparing to play Half-Life 2: Possible Solution.

    I've encountered this problem last night (after steam installed some patches) and I've read some of the posts on this forum indicating that they have problems with their CD/DVD drives, etc. Then I realized that I had daemon tools running, so I removed it off startup and tried and bingo! It worked! I guess steam detects any fake/ISO utility programs and it thinks that its running HL2/CSS/any steam app.

    Let me know how it turns out for you guys.


  11. AcemanOne

    AcemanOne TS Rookie

    Working now after new steam update

    I had this problem since I bought the game 1-2 weeks back (CD version), but when I launched steam today HL2 was no longer at 100% acquired, just 99% and needed an update. Apparently the new update fixed the problem for me, but it sounds like it may have caused problems for some of you. Well, I'm able to play now, but if Valve decides to reply (after more than a week) with a specific solution to the problem I'll post it here for you guys. All I know is the HL2 executable wasn't being launched from steam as it should have been until today's update. If it's a drive problem then the steam update configured itself to work with my Asus DVD. Good luck all...don't know if the game is worth this much trouble, but it looks good so far...

  12. SoDSpawn

    SoDSpawn TS Rookie

    Alright, this is weird, but to help all you out im going to post what i did to get the game to run.

    I left steam running over night and this morning i hopped on my pc and first checked the forums. I read a post that the process was actually running and then disappeared. So I looked in my task manager and i decided to terminate the steam process. After i did that i went to my desktop and opened HL2. Steam logged me in then i got the "Preparing to play Half Life 2" screen. And behold, to my suprise the game actually loaded. I dont know what else i could have done but terminate the steam process.
    I hope this can help.
  13. KageX

    KageX TS Rookie

    maybe the answer

    daemon tool messed it up....i did the same thing last night and it worked! Or just wait for it to work. But it worked for me....i removed daemon tools and then closed steam. after i started a cs game wich rebooted steam and BINGO ! worked like a charm! Hope you guys have luck to make it work...and even my friend had the same problem whit his hl2 after the update. So now i think it mught simply be the update getting processed by steam servers....cuz they had problems last night! anyways....let's hope for everything to work out for everyone!
  14. Plonka

    Plonka TS Rookie

    I've been having the exact same problem! Glad to have found this forum.

    I'm not sure if this has anything to do with the problem, but while in the 'loading' screen, windows sounds two alerts back to back (that "critical stop" sound) however once i manage to get the screen closed, there are no alerts to be found.

    I also tried starting up Deathmatch and the same thing happened, although this time i got to see one of the error messages. It was titled "Hl2.exe - Application Error" and it read as follows:

    The instruction at "0x2406dd69" referenced memory at "0x01befacc". The memory could not be "read".

    As I said, not sure if any of that will help someone track down the problem, but hopefully it gets sorted soon! Otherwise I'll be returning this game.

    - Plonka.
  15. Malt

    Malt TS Rookie

    It's working again :S

    - When i got home from work last night i decided to try again. started up Steam first of all and had a look at some of the settings. i right clicked on 'Half Life 2' under 'My Games' and in the properties dialog i turned off the 'automatically update this game' option, closed the dialog, re-opened it and then turned it back on again. I then tried to run HL2 and it worked!

    Although this is a suggested 'fix' on Steampowered, i can't be 100% certain that this is what got it working :S

    From Steampowered:
    "There are several steps that can fix this error if flushing the cache via the [OK] button doesn't work:

    Automatic Update needs to be enabled
    The first thing to try is to go through all the installed games and make sure automatic update is enabled, a number of players have reported that this option was disabled and when they enabled it the game finished updating and the problem was solved.

    You can check this via Steam > Games <right-click on your game>
    then click on "properties" and there is the option.

    You can also try disabling the automatic update and then re-enabling automatic update which seems to fix this for another another group of players."
  16. BrentB92987

    BrentB92987 TS Rookie

    I might have the solution...

    I might have found a solution that will solve this problem for some people. (solution is in the last paragraph if you don't want to waste your time)

    I had the same problem of course and I spent almost my whole weekend trying to fix it. Then I noticed that Warcraft III wouldnt read the disk(sorta like half-life 2) so I searched for a solution- no luck, but I did find out that both programs are opened by this other program( I forgot what it's called but it starts with an S )
    I know that Warcraft III worked with no flaws before I installed Half Life 2 and steam and figured that maybe I somehow got a virus while steam unlocked/downloaded the files. This also might be the reasom why some people couldn't play the game after they downloaded the updates.

    So I went to housecall/trendmicro/com (replace the slashes with periods because techspot won't let me put URLs in posts) and scanned my comp and sure enough I had a trojan and a virus on my brand new computer that I built about a few weeks earlier and found one named ppi.exe and dirote.exe - both were also on the startup for windows ( go to start, run, type in MSCONFIG, and go to the Startup tab). I deleted them, dirote was still on the startup thing so I unchecked it and restarted my computer, reinstalled half life 2/steam and now the game works with no problems!!! So look on Taskmanager to see if dirote.exe or ppi.exe is running. I think dirote.exe was the one causing the problem.
  17. CaptMardini

    CaptMardini TS Rookie

    fix... at least for me with hl2 game

    Ok, guys and gals, I was having same issue and I was trying everything ... I then went to microsoft and downloaded direct x 9.0c and now i can play.... my only problem is that after I quit the game my computer crashes no mater if its css or hls..... so try that ... try the update to 9.0c and that might fix your issues.

    Hope it helps .. now to figure out why my computer crashes after i quit the game.....

  18. sk33t3rz

    sk33t3rz TS Rookie

    Hard Drive Space?

    First, I'm glad this thread is here - though too bad there's a need for it at all. I ran into this problem (HL2 failing to load) a couple of nights ago. I tried the things suggested throughout this thread, but nothing helped. (I had high hopes for the Steam cache checking tool, but got nada.) Eventually I gave up for the night - not happy. But then last night it worked fine! The only changes that happend were 1) Steam did an auto-update last night when I went to load HL2, and 2) I freed up a lot of space on the drive where Steam/HL2 is installed (from 300MB to 1.5GB free). Don't know what fixed it, but there are a couple of other things you can try. BTW - I got HL2 via Steam; I'm not using retail CD/DVDs.

    Good luck, everyone. I truly hope that all of you can get it working, because this game is utterly incredible! Thank you, Valve!
  19. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    I haven't had problems running any version of HL2, just the occasional sound stuttering persists.

  20. Groundhog

    Groundhog TS Rookie

    Add me to the list of no luck yet in loading it !!

    Well in case Steam, Sierra or Valve do happen to decide to read this forum I'm another one who after many attempts including numerous reinstalls of this product still haven't managed to get past the preparing to load phase. The disc (dvd) spins up, the preparing to play message appears then disappears then nothing. Waste of £30 in my eyes on a product a shop will not take back becuase you cant prove it is faulty !!

    My pc's spec if it helps is as follows :-

    p4 2.8ghz
    512 ddr ram
    gigebyte x600 pro pci express graphics card
    MSI dvd writer

    All drivers updated and all suggestions so far tried without any luck. Have no spare dvd drive to try that one out though.
  21. Ph30nIX

    Ph30nIX TS Rookie Posts: 243

    HL2 Probs


    Like all of you guys i am also having problems with loading HL2.
    My friend bought the game and it works fine on his com.
    He gave me his account details and we installed it on my computer.
    When i try to boot it it say "Preparing to play HL2" etc.
    THen the message disappears and about 5 mins later it say "This game is not availible right now. Please try again later" or seomthing like that.
    This problem also occurs with CS:S.
    I have tried reinstaling but ontihng will work.

    Im Running :

    P4 2.8 Ghz 800 FSB
    Windows XP HOME wiht SP2
    2x256Mb Hyundai RAM
    FX 5700 256Mb RAM video card, with latest drivers
    52x DVD/CD Combo drive
    80Gb Maxtor HDD
    On board sound

    Hope someone can help with this strange problem


    Ph30nIX :giddy:
  22. saku

    saku TS Rookie

    Im having the exact same problem as you guys....it gets to the loading stage then just hangs. have any of you guys found a fix yet?
    this is really frustrating.
  23. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Have you checked from Steam error logs?

    They're in 'errorlogs' subdirectory in Steam directory.
  24. saku

    saku TS Rookie

    ya i just checked...nothing in the folder.
  25. Ph30nIX

    Ph30nIX TS Rookie Posts: 243

    Hl2 fails to load

    as i said b4 im using a friends account.
    the problem as i see it is that steam is not creating an account folder in the directory for the account? why is this?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...