Having new motherboard detect GPU

By Jasio-
Dec 3, 2011
Post New Reply
  1. Alright, so after three hours of trial and error, I couldn't get my new setup working. Everything would turn on, spin, etc, but I couldn't get a signal on the monitor. Today I took another stab, reset the CMOS and removed the battery, and out of no where it worked with one stick of ram, CPU, and PSU of course. I added the next stick of RAM, still works. I then added the GPU, and sure enough back to the same problem.

    My guess is that the motherboard can't detect or use the GPU. I can reset the CMOS again, and everything will work fine, my question is how do I make the motherboard compatible with the GPU once I've installed Windows. Is it as simple as updating the motherboard driver? or do I have to flash the BIOS and upgrade that. I'm hoping for the former solution.

    Motherboard: ECS A885GM-A2
    GPU: GeForce GTS 450
  2. odriscoll27

    odriscoll27 TS Rookie Posts: 66

    just wondering if its a compatibility issues maybe??? though i do seriosuly doubt this.

    um long shot here:
    what is your PSU Wattage? and (only because i did this myself once) have you plugged in the power connector to the Card???

    hope this helps
  3. Jawshh

    Jawshh TS Enthusiast Posts: 392

    Did you plug in the PCI-E connectors in the card? Your card might not be getting the power it needs, what kind of PSU do you have?
  4. earth8ound8

    earth8ound8 TS Rookie


    I don't know if jasio has solved his issue but I figured I would post anyway for people having similar issues.

    The first things to point out are that the GTS 450 needs a 6pin power connector with a minimum of 400watt PSU according to Nvidia. This seems rather low for a card requiring over 100 watts.
    This card also uses Dual link DVI. You must be using the proper connections, an adapter often times isn't enough for these situations. You need a dual link DVI-I cable. DVI-D may be enough to work, however your card does specify DVI-I.

    Also, be sure you try both slots. Some cards will have a master - slave setup by default rather than cable select. I was unable to locate that specific info on this card.

    I must also point out there are certain parameters this card operates under, like refresh rates. It is possible your bios is attempting to operate outside these parameters. See if your bios has video setting and attempt to set them to auto.

    It is also possible the integrated on board is conflicting and may need to be disabled.

    Hope this helps someone! =)

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...