1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Help! my PC crashed and it wont reboot, the error message is i8042 is corrupted

By shaunholmes · 62 replies
Oct 15, 2009
  1. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Hi WinXPert

    I think you you might have missed the goal here....

    The goal isn't to provide a Linux-like OS for someone to use.. rather, the goal is simply providing an easy UI for them to boot into in order to backup their files/folders when Windows won't boot into normal or safe mode. Knoppix only purpose here is providing an easy and convenient "rescue CD" type environment....

    see this post See How to recover your folders/files when Windows won’t boot
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    HI Shaun

    Forgot to mention before re: your question about Seagate / Knoppix

    The Seagate will be an external USB hard drive, right? As a USB drive, to my knowledge there should not be any issue connecting to Knoppix (no special drivers for USB support on Knoppix).

    1) If you still want to be "super-cautious" buy it from a local retailer? you can always return it then, yes?
    2) You can provide me the link where you thought you read it's a problem. I can take a look at what was said
  3. WinXPert

    WinXPert TS Guru Posts: 445

    Ok but I don't know any bootable Win CD iso you an download that has a free partitioning program. DiskInternals has but on demo only.
  4. shaunholmes

    shaunholmes TS Rookie Topic Starter Posts: 28

    Hi LookinAround

    Well again your help has moved me on a pace, i managed to download and install Knoppix on my broken pc, wow i like this operating system really cool !!

    ok my first problem is that Knoppix can see my faulty hard drive but i can not mount it!! i have gone back through your instructions on recovering files and i didn't see any advise on mounting the drive ( if in fact you can actually mount the drive at all)

    There are no problems with the seagate drive, knoppix recognises it, which is great.

    Knoppix can see the size of my ailing hard drive but when i click to explore i get this error message

    Error org.freedesktop.Hal.Device.Volume.UnknownFailure

    would you be so kind as to give me some advice as to where i go from here.

    Thanks one again

  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Hmm.... normally, if chkdsk runs OK to fix the filesystem, the hard drive should be mounted automatically... seems to imply there might still be an issue with your hard drive.

    I'll have to look further at your specific problem/error message... Maybe WinXPert might also have an idea.... So will have to get back to you later

    In the meantime, it couldn't hurt if you tried running chkdsk /r one more time just to see if it completes/reports anything
  6. shaunholmes

    shaunholmes TS Rookie Topic Starter Posts: 28

    just running the chkdsk /r and i noticed that the drive was at 75% completed and then went back to 50% is this normal?
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    chkdsk /r runs in 5 passes.. I'd guess you noticed % complete in 2 different passes

    Phase 1: Checking files
    During its first pass, Chkdsk examines each file record segment in the volume's master file table (MFT) and examines it for internal consistency. At the end of this phase, Chkdsk has identified the space that is in use and the space that is available, both within the MFT and on the volume as a whole.
    Phase 2: Checking indexes (directories)
    During this pass, Chkdsk examines each directory that is on the volume, checking for internal consistency and verifying that every file and directory that is represented by a file record segment in the MFT is referenced by at least one directory. Chkdsk confirms that every file or subdirectory that is referenced in a directory actually exists as a valid file record segment in the MFT and also checks for circular directory references. Finally, Chkdsk confirms that the time stamps and file size information for the files are up-to-date in the directory listings for those files.
    Phase 3: Checking security descriptors
    During this phase, Chkdsk examines each security descriptor that is associated with files or directories on the volume. Security descriptors contain information about ownership of a file or directory, about NTFS permissions for the file or directory, and about auditing for the file or directory.
    Phases 4 and 5: Checking sectors (optional)
    If the /R switch is in effect, Chkdsk runs two more passes to look for bad sectors. During stage 4, Chkdsk verifies all clusters in use; during stage 5, Chkdsk verifies unused clusters. Note that this process can be quite lengthy. taking many hours. 
  8. shaunholmes

    shaunholmes TS Rookie Topic Starter Posts: 28

    TY LookinAround

    right the chkdsk /r has finished and it declared that it had "found and fixed one or more errors on the volume" ?

    Do you think i should boot up knoppix again and see if the hard drive can get mounted?


  9. shaunholmes

    shaunholmes TS Rookie Topic Starter Posts: 28

    Hi LookinForward

    i have been able to get my hard drive mounted in knoppix, so thanks to you retrieval of some of my files does at last seem possible, thankyou, thankyou very much.

    I still have a few problems though, when i tried to copy some files to my new external hard drive i get an input output error, having perused the knoppix tech sites i figure it might be because i didn't download the corect md5 file ( sorry) i used the link that you supplied in your tutorial but the hash codes didn't match. would you please send me a link so that i could download the correct one.

    Typical ludite that i am i thought it didn't appear to matter, (again sorry)

    i will try tonight to get the correct one, to be honest Linux script scares me a little ! I go on to these linux tech sites and i'm more confused !

    could you tell me what i need to do with the MD5 file, in your tutorial you mention burning the ISO file should i have included the MD5 file with it ?

    I'm not sure what the file does, if i try to open it windows asks me what programe to use to open it, i'm afraid i don't have a clue !

    Anyway you have helped me out loads and i would have no way got this ar if it wasn't for you :) i really appreciate you giving your time and expertise, there are not enough people in the world doing that.


  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Well done! :grinthumb
    What did you do to get your drive mounted? (now i'm curious to know myself as well as to tell others should they have the same problem)

    You mean you have been able to copy some file but not others??? What is the error message you get when copying the files??

    As for MD5, a brief explanation:
    > Checksums (sometimes called hash values) were invented to help guarantee data file integrity.
    > A numerical calculation is applied to a block of data to produce the checksum.
    > Anytime one downloads the same data file it should calculate to the same checksum (giving assurance the file is complete and OK).
    > MD5 is the name of a method of calculation
    > The MD5 file should have opened upon download (don't know why it didn't). It contains the checksum value and the filename of the download it belongs to
    [B]d642d524dd2187834a418710001bbf82[/B] *KNOPPIX_V6.0.1CD-2009-02-08-EN.iso
    > Use the HashTab tool to verify the MD5 value of the .iso downloaded file = d642d524dd2187834a418710001bbf82
    > Note you can simply select the calculated MD5 value in HashTab, copy/paste the expected (and cryptic looking!) value into the tool and click the Compare a File button to let HashTab do the compare for you

    and btw (by the way..)
    1. yes, knoppix is pretty cool! :) (and usually pretty easy to use!) and
    2. curious if the power management changes helped you complete the download?
    I also ask as your input will also help me modify the instructions to help others in the future.. so thanks for the feedback as well!
  11. raybay

    raybay TS Evangelist Posts: 7,241   +10

    But a new drive to install... then use your current drive in an external USB encloser where there is less chance of error.
    But really, for anything you do, you should create a backup of all your important files and data.
  12. shaunholmes

    shaunholmes TS Rookie Topic Starter Posts: 28

    Hiya LookinAround

    Thanks for the lesson on MD5 files, from what I can work out, is the file then just for making sure that you have downloaded correctly and that all the file has downloaded?

    I took your advise yesterday and ran chkdsk /r again on the hard drive and it came back with errors found and errors fixed, I then rebooted Knoppix and it mounted the drive right away! i can only assume that there must have been some errors on the disk and once they had been fixed everything was ok!

    The Power management controls you told me to change worked perfectly (your'e good:approve:) the file downloaded non stop the first time !

    The input/output errors that i have been getting do not give me any other information then that, it says input/output error and i have a little OK button to press then it stops and does not load any more files. As i said at the start of this thread, I compressed and then deleted some files in error ( i was trying to make more room on my hard drive ) when i realised what i had done i tried to retrieve them via an application to restore them ( i cant remember the name of the app but i'm sure i will find it on my recovered data ) it did retrieve lots of files but some of them appeared to be smaller and the file names had changed to very long numbers! maybe this might be the problem?
    I have since started to transfer the files in smaller batches and it appears to be ok, i have had a couple of input/output errors but i cant see any connection, ie: duplicate files etc!
    I dont know what else i can say as i dont really understand what has been going on !

    well i am now ready to format the hard drive and re-install XP, I have seen alot of information about this on the web and it looks straight forward but i would love to hear your advise on this :)

    Well i thought i would never retrieve my data but thanks to you i have, i don't very often use this word but LookinAround , AWSOME work !!!!

    Note : i have not restored the windows files as a presume that when i re-install XP all that i need wil be there, is this right?


    Shaun :)
  13. shaunholmes

    shaunholmes TS Rookie Topic Starter Posts: 28

    Hiya LookinAround

    I decided that i would try and format the hard drive earlier this afternoon and true to form it didn't work :( I followed the instructions from the dell website using the recovery disk.

    The problem is that when i reach the very final screen where the "set up is formatting ... " box is, the % does not move, there are no lights from the front of the PC and the hard drive appears dead, with out any sound! i left it for 2 hours and still the % hadn't changed it was still on zero ... this is the part where i'm a bit scared ... i turned the PC off by holding in the power button, i then repeated the process,

    Load recovery disk, at set up press enter to install XP, then choose a partition ( there was only one on my PC) delete it, then create a new partition, this time i used the quick NFTS option and the disk started .... and then stopped on 20% for another hour !!!

    This is pretty much where i am, if i start the PC now there is no operating system, obviously! i also reset the bios configuration to the default settings and use F12 to access the boot schedule and choose to boot from CD ROM.

    at the moment the screen reads .......

    Please wait while setup formats the partition
    C: partition1 [new (raw)] 76285 MB ( 76285 MB free)
    on 76294 MB Disk 0 at Id 0 on Bus 0 on atapi [MBR]

    Setup is formatting ........ 0%

    this is another attempt on the un-quick format, as i said on my earler post, this seemed a straight forward process but again it appears that nothing to do with trying to fix your own PC is EVER straight forward.

    what have i done wrong LookinAround ? i hope i havent ruined the hard drive with my ineptitude!!!




  14. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Either a failed hard drive, or a failed power supply, or a failed motherboard... Assuming you have verified your memory is good...
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Hi Shaun

    Seems your computer is putting you through the paces with some crash training courses!!! ;)

    Not sure just why the current problem... But might first click here to download a diagnostic tool from Dell (its another iso so just burn it and boot from it) I don't know how extensive their diagnostics are but you can try it before or after steps below, is up to you

    So some next steps for now...
    1) First check if Dell might have put Recovery software on your computer. Look at this link and and jump to Step 2.
    2) If above fails, still be sure to remove all non-essentials devices (USB drive, printers, etc.) before trying to reformat/ reinstall so you basically just have your screen, mouse, keyboard.
    3) You can also try each of the following commands in the Code boxes below (while in the Recovery Console)
    [B]chkdsk /r[/B]
    > Does chkdsk still run and still report it found and fixed errors?
    4) Then these commands in this order
    [B]format c: /fs:ntfs[/B] 
    > map will indicate the partions found (if any)
    > fixmbr and fixboot should simply return (they fix a couple things that might need repair)
    > format will invoke the full disk format again. Note the blank before and after c:

    We might just find real evidence of a hard drive problem. Maybe not. But will cross that bridge when we get there

    and btw.. re: MD5, yes, the MD5 is only needed to help one verify that big long Knoppix download before burning and using it
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Oh. And to quote someone else "Why have a hobby when you have a PC?!" :haha:
  17. shaunholmes

    shaunholmes TS Rookie Topic Starter Posts: 28

    Hello Again

    Thanks for the commands, yes i am on a crash course, thanks to you LookinAround my knowledge on PC's as increased 1000% !!
    right i have entered all the commands, chkdsk /r came back with :
    This drive has one or more unrecoverable problems
    i then input the sequence of comands,

    map : went in fine got the message that it was succesful

    fixmbr : asked if i was sure and i said yes.. new MBR was created

    fixboot : new boot sector was succesfully written

    Format : AUTOFMT.EXE could not be located in either the startup directory or the CDROM drive !
    type the full path (including drive letter) for the location of AUTOFMT.EXE

    thats where i am at the moment, thanks once again LookinAround, you must be sick to death of me !!

    i will try and run the dell diagnostic and see what it says, speak to you later


  18. shaunholmes

    shaunholmes TS Rookie Topic Starter Posts: 28

    haha LookinAround

    I used to have a hobby, i used to have a family!! haven't seen them for a while :) mind you I dont think they can see me, sat in the corner of the room covered in cobwebs and dust

    only joking !

    thanks again for all your help i really appreciate it


  19. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Hi Shaun

    just a quick note....

    Your mention of "autofmt.exe" may be the clue. just fyi.. i did a quick look about and found others reporting same problem and symptoms as you... And someone reporting the fix. Don't have the time just now to go through it all now but just the "heads up" i'll be getting back to you (with hopefully some good news and next steps) to get past your computer's current road block! :)

    talk later
  20. shaunholmes

    shaunholmes TS Rookie Topic Starter Posts: 28

    Thanks LookinAround

    really appreciate it, just to let you know I ran the diagnostics from dell and i pretty much did every test, RAM, HARD DRIVE, PROCESSOR, all of it came back as passed!

    While i was waiting for the tests to complete i thought i would plug the external hard drive into my laptop to check everything was still ok, all the folders are there and all but one had the data i had saved, the one folder that was empty was documents and settings !! typical.

    When i copied the files over yesterday i checked and double checked that the folders and data were all there, i even highlighted every folder and did properties to make sure that the data added up to the same amount of memory, it did !

    i restarted Knoppix fearing the worst after my attempted Format and low and behold the hard disk is still there with all the information! i quickly restarted with the external hard d rive plugged in to rescue the missing folder and Knoppix will not mount the external hard drive.

    I have tried a couple of things suggested by JarrordGodard.com, this is what i tried

    df ( to locate the external drive) it shows as

    /dev/sda1/ 78116028, 32566256, 45549772 42% /media/sda1

    mkdir /mnt/usbdrive
    mount /dev/sda1 /mnt/usbdrive

    the drive would not mount, because of the script above i even tried


    no luck!!

    if you know of anyone that can furnish me with any explosives to blow this bloody thing up please let me know, i'll video it and post on Utube :)

    only joking, but bloody hell, someone up there give me a break!!


  21. shaunholmes

    shaunholmes TS Rookie Topic Starter Posts: 28

    OK i think i'm being stupid .... no change there then .... i think sda1 refers to my hard drive in the PC and not to the external USB hard drive !!! doh

    but the knoppix desktop is still showing the USB drive as "expansion drive "

    Just thought i would clear that up!!

  22. shaunholmes

    shaunholmes TS Rookie Topic Starter Posts: 28

    OK for all you non-techy people who are reading this thread and trying to fix your pc, the 2 bits of advise i would give you would be 1: find someone on this site to help you, the people i have had help from have been paitient and very helpful ( many thanks in my case to LookinAround ) and number 2: let your pc finish it's processes, let it shut down properly and never pull your peripherals out while the pc is running!!
    simple things but very important!!

    LookinAround, it appears that i AM a complete *****, the reason that external hard drive was not showing on Knoppix was because i disconnected it before my laptop had shut down! as soon as i returned it to the laptop and shut down properley, Knoppix found it!!

    As far as the missing files, they appeared on the drive at the same time! so i'm really sorry that iv'e made you read another 2 posts regarding my utter lack of understanding regarding anything computer! :)

    So as we stand all the files are ok but i still need a hand with the formatting issue.


  23. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    You're making progress! (and we all learn from our errors along the way.. so no worries!)

    Instead of screwing around with Windows let’s use a Partition Management tool to reformat your drive
    > Click here to download Gparted Partition Manager .iso file and burn it to CD (more freeware!)
    > Disconnect your USB drive. Boot from Gparted CD. Whenever it prompts while loading, simply hit Enter

    Example of first Gparted display below (your drive will probably only have one or two entries vs. the example below. Click on thumbnail image for full view)
    • Note each hard drive partition line item is named /dev/hdax where x is an ordinal number
    • The entry for your "C drive" partition will be NTFS
    • Label may appear is the (optional) user friendly label for the partition
    I’m guessing you’ll have either one entry (for your C drive) or two entries (if a C drive plus if Dell included a recovery partition as well)

    We want to delete the old partition (and NOT the recovery partition if we think it exists) and then create a new C partition.
    (Note: As you add partition operations, the display is updated. However, none of the operations are actually executed until after you click the Apply button (likewise you can discard the last command clicking Undo)
    • If you’re not certain what partition is what based on what you see, you can stop here and post back to tell me the entries you see
    • Rt click the C partition then click Delete. The partition will now display as “unallocated”
    • Rt click on the unallocated space then click New to create a new partition. Make sure the new partition options indicate
      > Primary Partition
      > NTFS Filesystem
      > C (or string of your choice) for the Label
      > New Size should be 20000 or larger (i.e. at least 20GB for the partition size)
    • Click the Add button

    Now the Gparted display should look something like below (where you can review the info and the commands to be executed)
    > Where New Partition #1 is in upper pane and the two commands to Delete and Create New Primary are in the lower pane
    > Now click the Apply button to execute the commands
    > Gparted will probably want to reboot. Then just let it complete and do it's thing
    > When it's done you can try to boot using the Windows CD again. Your C partition should already exist and be formated so you can proceed to install (hopefully! - fingers crossed!)
  24. shaunholmes

    shaunholmes TS Rookie Topic Starter Posts: 28

    Hi LookinAround

    I think the disk was formatted ok, i followed all the instructions and rebooted with the XP recovery disk, when i reached the set up screen i changed the disk to my Dell OEM disk and pressed enter...

    It takes me to the end user license agreement, I pressed F8, what i see is

    C: partition 1 (c) [NFTS] 76293MB (76226 MB free)

    as i assume that the drive has been formatted i press enter to set up windows on this partition.

    It then tells me that XP will be installed on C: partition 1 (c) [NFTS]

    it does give me options

    format the partition using the NFTS file system [quick]
    format the partition using the NFTS file system
    leave the current file system intact (no changes)

    i choose to leave the current file system

    The screen changes and it says

    Please wait while setup examines your disks. This may take several minutes depending on the size of your disks ( this is a new screen )

    there is a double box with 0% in the inside box.

    checking drive C: ......

    This is as far as it goes, the pc stops and nothing happens!

    I will leave it running overnight to see what happens but the screen has been like it for over 30mins, so close and yet ...........................

    let me know your thoughts


  25. shaunholmes

    shaunholmes TS Rookie Topic Starter Posts: 28

    Quick update

    Nothing happened, the box was still sat at 0% this morning so i have re-done GParted and tried to install again, same outcome, it gets to the install screen and stalls ...

    couple of questions :

    How long does the format usually take, GParted does it in around 5 secs, is this right?

    could it be my original XP disk, i tried to boot with this disk after formatting and it gave me the same error message that i started this thread with, i8042.sys file is corrupted !!

    i'm baffled, i have ran all the tests on the pc, everything passed, HDD, RAM, BIOS, USB, CDROM, CARDREADER, LEADS...... the lot !

    Hmmmmmmmm :confused:


Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...