Help with RAM/MB issue

By elazarus ยท 24 replies
Dec 14, 2010
Post New Reply
  1. Hello,

    I have a new build that has 8 gigs of DDR3 1333 Ram (4gb x 2) and Windows 7 64 bit only sees 4 gigs. I looked in the system Bios at startup and see Dimm slot #1 4096 and Dimm Slot #3 4096. Enabled #2 4096. Total Memory Size 4096.

    How do I get to use all 8 gigs of Ram on this motherboard? Is it a Gigabyte MB setting or is it a windows 7 setting?

    There are 4 slots for RAM....Yellow/Blue and #2 Yellow/Blue. The Memory is in the yellow slots 1 / 3 and # 2 & 4 are empty.

    Thank you


    Motherboard Model Name : Gigabyte GA-P55-UD5(rev. 1.0)
    M/B Rev : 1.0
    BIOS Ver : F3
    Serial No. : 093600017050
    Purchase Dealer : AVA Direct
    VGA Brand : Nvidia Model : GTX 460
    CPU Brand : Intel Model : i5 Speed : 760
    Operation System : Win 7 64-bit SP : 1
    Memory Brand : Crucial Type :
    Memory Size : DDR3 Speed : 1333
    Power Supply : 750 W
  2. brucethetech

    brucethetech TS Enthusiast Posts: 229

    are these memory sticks the same? they should be.
  3. elazarus

    elazarus TS Member Topic Starter


    Thanks for responding.

    Yes, the are both exactly the same and brand new (3 weeks old as a new build machine).

  4. gwailo247

    gwailo247 TechSpot Chancellor Posts: 2,010   +18

    Does the manual specify to put the RAM into slots 1 and 3, or can you try them in 2 and 4?

    Why would it say that your slot #2 is enabled and there is no RAM in there?

    Have you tried resetting the BIOS to default settings?
  5. elazarus

    elazarus TS Member Topic Starter


    Thanks for the input. I have a file into Tech Support.

    Correct, there is nothing in the #2 slot....I have not touched the BIOS....although I think it was set at AVA to OC as it said maximum.

  6. gwailo247

    gwailo247 TechSpot Chancellor Posts: 2,010   +18

    Try resetting the BIOS anyway, shouldn't do any harm.
  7. elazarus

    elazarus TS Member Topic Starter



    Just pull the battery? Or do I need to move the jumpers also?

  8. gwailo247

    gwailo247 TechSpot Chancellor Posts: 2,010   +18

    No, you can do it within the BIOS. According to the manual for your board, there is an option to load fail-safe defaults. Looks like pressing F6 should do it while in BIOS.

    Those are usually the most conservative settings for your board, so anything wacky that somehow got enabled should be put back to a usable state, providing your problem is not with the hardware itself.
  9. elazarus

    elazarus TS Member Topic Starter

    It worked....

    Great call.......thank you.

    Went into BIOS and reset F6. I saw that it was OC'd to about 3.1 from Intel's 2.8

    Booted it up and hit Windows key + Pause and saw 8gb RAM...4 least it sees it.

    Now I will look to see if some of my Win 7 hiccups may subside and I can just get a "normal" work flow.

    Thanks again.

  10. gwailo247

    gwailo247 TechSpot Chancellor Posts: 2,010   +18

    Grrr. How can it see the other 4 and not use them?

    I did a bit of looking around the internet, might be a problem with your motherboard BIOS.

    You state you have F3 BIOS, the page for your mobo shows that they're up to F11

    Looking at the progression, the BIOS on your board must be almost 2 years old, so maybe you need to update the BIOS to a newer version, as that may be why your system cannot use the memory.
  11. elazarus

    elazarus TS Member Topic Starter


    You sound like a man on a mission and that is great.

    Resetting the BIOS was easy......I have never updated a BIOS file before....what is the easiest way once I have downloaded the file?

    Thank you

  12. gwailo247

    gwailo247 TechSpot Chancellor Posts: 2,010   +18

    LOL, its a little puzzle.

    Updating BIOS is a bit trickier, but should be ok as long as the power doesn't go out or something.

    Again, I've never used Gigabyte boards or software before, just mainly ASUS, but the principle is the same. You use the built in utility from within Windows, select which BIOS you wish to update to, and the run it.

    This is a link which should give you the instructions.

    If you didn't install it with the motherboard disk, you'll need the @BIOS program it looks like.
    I've done it several times with ASUS boards, and it was always a smooth process with no problems.

    I probably would stick with the F10, and not the Beta BIOS. Sounds like F7 is the update which may fix your problem as it deals with memory, but I've always gone with the latest version, and I've been ok.

    Just a disclaimer though, if you bought a pre-built machine and have a warranty, etc, then you may want to follow their instructions. You *should* be ok with flashing the BIOS, but wait to see what the tech support people suggest and follow their instructions, as I'm sure flashing the BIOS would void it.
  13. elazarus

    elazarus TS Member Topic Starter

    Bios was easier than I thought...Gigabyte has you download an @BIOS file and they do all the work. Yes, they did download Rev 10 instead of the beta 11.

    It still shows 8gb installed and 4gb being used.

    This machine was built for me by a Custom gaming house (even though I have never played a game on a computer) with the parts that I chose...but the warranty aspect doesn't worry me because either the machine is going to work properly or else we toss the OS and start fresh. I have businesses online and so I need the computer working all the time and not just when it feels like it.

    When it rebooted it went into a Repair start but found nothing. The USB's were a little touchy. But I think that Windows 7 is a bit weak as far as stability goes.

    Gigabyte never answered my Tech Support request in 48 hours, so I can hardly refer anyone to use their products....

    Now we will see if the machine can run without some kind of error for at least 2 hours.

    Thanks again for your help.....

  14. gwailo247

    gwailo247 TechSpot Chancellor Posts: 2,010   +18

    What does it say in the BIOS when you load up. Does it still say that 8 installed, 4 usable?

    My original thought was that the place installed 32 bit windows instead of 64 bit windows by mistake, that would have been a really good reason for your windows not to recognize 8 gb.

    but if your bios continues to detect 8 GB and still says 4 GB usable on BIOS level, then my guess is that there is some physical problem with your motherboard.

    I'd e-mail the place that built the computer and have them troubleshoot it, or return it. If the BIOS continues to show 4 usable, then its got to be some kind of hardware problem, if the BIOS won't use 8, I wouldn't expect any OS to use 8.
  15. elazarus

    elazarus TS Member Topic Starter


    Here is the info from shows 64 bit windows

    OS Name Microsoft Windows 7 Professional
    Version 6.1.7600 Build 7600
    Other OS Description Not Available
    OS Manufacturer Microsoft Corporation
    System Name ELLIOT
    System Manufacturer Gigabyte Technology Co., Ltd.
    System Model P55-UD5
    System Type x64-based PC
    Processor Intel(R) Core(TM) i5 CPU 760 @ 2.80GHz, 2794 Mhz, 4 Core(s), 4 Logical Processor(s)
    BIOS Version/Date Award Software International, Inc. F10, 6/30/2010
    SMBIOS Version 2.4
    Windows Directory C:\Windows
    System Directory C:\Windows\system32
    Boot Device \Device\HarddiskVolume1
    Locale United States
    Hardware Abstraction Layer Version = "6.1.7600.16385"
    Installed Physical Memory (RAM) 8.00 GB
    Total Physical Memory 3.99 GB
    Available Physical Memory 1.75 GB
    Total Virtual Memory 7.98 GB
    Available Virtual Memory 6.34 GB
    Page File Space 3.99 GB
    Page File C:\pagefile.sys

    Thank you

  16. elazarus

    elazarus TS Member Topic Starter


    I posted a reply but I guess it had to be approved. MSinfo32....definitely says 8gb Ram 4gb usable....and Windows 7 64 bit.

    I need to go into the BIOS and see if it has a setting for 4gb. Isn't there a setting in Windows that keeps ram at 4096??

    Thank you

  17. gwailo247

    gwailo247 TechSpot Chancellor Posts: 2,010   +18

    Yeah, there was something about it, but I'm not sure which version. Although not scientific, I'm going off the fact that when I installed Windows 7 several times I never had a problem with it recognizing my 6 GB of memory, so I'm operating under the assumption that it does not default with 4 GB max enabled. Which version of Windows 7 do you have BTW?

    Try this

    1. Run MSCONFIG (hit start, type msconfig into the box)
    2. Go the boot tab.
    3. Click on Advanced Options
    4. Uncheck the Maximum Memory box

    Now if that box is already unchecked, then this solution won't work, lol.

    I looked around the manual, I didn't see anything. The board supports 16 GB of RAM, having more than 4 on there isn't exactly pushing it to the bleeding edge.

    One more thing you can try is load up Optimized defaults. That *might* work, unless that was the setting you had it on before. I'm wondering if that is going to bring the speed back up to 3.1. Since your computer was overclocked when you got it, I'm curious is 3.1 speed is achieved through this, or if the guys who made your computer overclocked it.
  18. elazarus

    elazarus TS Member Topic Starter

    First of all, let me say thank you very much for taking so much time to work through this.

    I went into the BIOS and did an F7 (maximized) and booted up. It took forever and none of the settings changed. So, I went back and did an F6 for a "Safe Setting". It booted up faster but I can never bootup without some kind of message usually a USB problem.

    Machine is not up and it says 8gb (3.XX enabled) is an i5 760.

    I'll call tech support at AVA Direct tomorrow to see what we can do to get this fixed.

  19. gwailo247

    gwailo247 TechSpot Chancellor Posts: 2,010   +18

    No problem at all.

    Sounds like a lot of problems for a new computer, hopefully they can help.
  20. seanc

    seanc TS Rookie Posts: 88

    It's strange that you're having all of these issues.
    My suggestion would be to swap the RAM for Kingston and see what happens.

    I always build with Gigabyte boards for business & home use, the most recent ones I've built with P55 chipsets and i5/i7 CPUs haven't encountered this issue with 8GB RAM.
  21. gwailo247

    gwailo247 TechSpot Chancellor Posts: 2,010   +18

    Did you try unchecking the maximum memory?
  22. elazarus

    elazarus TS Member Topic Starter


    I spoke with the Computer Gaming builder and told them I was sending the machine back. We weren't sure if it was Win 7 causing the problems or the motherboard. So we made a deal and I told them that since I was at 28 days I could get a credit and pay a 15% re-stocking fee and we move on...or no re-stocking fee and I would go up a notch with an SSD HD and some upgraded parts.

    My thinking was just to send it to them for repair and then get it back and we guessed wrong on the problem would not be a good thing.

    So I hooked up, again, my Core 2 Duo 2.8 machine and while installing Spamfighter (I get 300 spams a day) it froze...and now I can't get past the Asus P5B board for it to boot up. And, no I don't have a Recovery disc...I am typing this on a trust Lenovo/IBM Thinkpad that has always been bullettproof.

    Any thoughts on how to boot up my 4 year old workhorse?

    Thank you

  23. gwailo247

    gwailo247 TechSpot Chancellor Posts: 2,010   +18

    It doesn't matter what the real cause is, you bought 8 GB of RAM, and can only use 4. If they put the system together, installed Windows and shipped it to you, then its their responsibility to make it work. I'm not a computer repairman, and nothing I suggested you do was irreversible, so I don't see that there should be any problems with them fixing your computer, regardless of cause.

    As far as your old system, are you that particular about keeping the stuff on there, or are you willing to format and start over?
  24. elazarus

    elazarus TS Member Topic Starter

    Booted up

    New computer is on the way back to builder and I ordered another one with a SSD, GTX 470, i7 etc.....

    You are not going to believe the reason I had trouble getting either of the older builds booted. Both would not get past the MB screen....For lack of any better idea, we disconnected the power going to the NEC 241 as I was using the USB ports for my mouse and keyboard.

    Moved the mouse and keyboard to the USB posts in back of the MB and powered up the display.....and Bingo computer booted up. Took the other "old" computer and it booted up immediately as well.

    We learn something new everyday. Of course, NEC said they never heard of this problem before.

  25. gwailo247

    gwailo247 TechSpot Chancellor Posts: 2,010   +18

    LOL, glad that worked out.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...