Host of boot issues, some coming, some going

By Gottee ยท 6 replies
Mar 22, 2009
  1. I apologize for, but do appreciate anyone that reads this Wall of Text to help me out.

    Let me preface this by saying I have not had any odd issues with my computer over the last few months.

    Also, I do not have access to my Win XP CD as my CD ROM decided to 'wobble' when I tried to do a recovery and it basically ate the outter edge of the CD. Also, I just tossed my Win 98 CDs about 3 weeks ago.

    The other day, I closed out of TF2 and went to load outlook and it locked up. Ctrl-Alt-Del'ed and closed it, tried again....locked up., but this time, it locked my computer. I did a cold boot and this is where the twists and turns begin.

    Disk Failure, insert system disk and press enter....
    After some digging around, I found that my 2 HDs were swapped in the BIOS boot priority. So I changed them, saved and tried to boot....same thing. It wouldn't save the boot priority of my drives and in fact, after doing this 3 times, it didn't find the drive with my MBR/Windows Partition on it.

    I pulled the plug on my second drive and ....for some reason, now it found my 'main' boot drive.

    I ran Wester Digitals Diagnostics and nothing came up faulty with my drive.
    I ran memtest86+, also no errors.
    Ran a few CPU stress tests....everything seems ok on the hardware side.

    Missing NTLDR....
    So now with my BIOS seemingly ok, this error started to appear when I tried booting up. I dug arond a bit and decided to load up Ubuntu Live CD, found a way to load the ms-sys package and tried to fix the MBR that way. No dice.

    I downloaded a bootable prog called FIX NTLDR and pretty much got the same errors. In fact, upon using the second of the 10 options it has you go through, I got a missing HAL.DLL error...

    So now I am thinking it is my boot.ini along with my MBR.

    I was able to load up Ubuntu Live CD however I could not mount the parition with windows on it. Unfortunately, I have a ton of family pics that aren't backed up [I know, I know....] on the inaccessible partition or I would just full out wipe the drive and make the jump to Linux.

    Upon checking the drive in Linux, the boot partition came up with a ton of errors.

    Now I tried to use SuperGrub to resolve the boot issues to no avail [but to be honest, I didn't really dig into the prog too much since it seems more geared for those that are dual booting win/linux rather than just windows].

    Lastly, I downloaded and ran The Ultimate Boot CD and ran TestDrive from it. Funny thing.........NO ERRORS! The partition tables come up fine, show the boot partition, show my boot.ini, NTLDR and HAL.DLL when I browse the drive. So I did a write on the partition table to save it and used the write new MBR function from TestDrive....

    Rebooted and now I get no errors, but it just cycle reboots. Loads the Win XP splash screen, then reboots....a few times I can catch a BSOD for a millisecond but can't read the error [not that it would be helpfuly anyway].

    That is where I am at right now.

    Hardware seems fine, can't access the partition through Linux, can access it through TestDrive [however can't really do much but just look at the file structure] and can't boot to recovery anything.

    So, aside from getting another Win XP there any hope?
  2. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    You gave up a lot of text, but we can find more information by doing this- then hopefully a resolution:

    You need to find the Errors in the Event Viewer that correspond to the error messages you are getting:

    Start> Run> type in eventvwr
    Please note: Ignore Warnings. Ignore Information Events. Look for Errors only.
    Do not paste the entire log.
    You do not need to include the lines of code-if any-in the box below the description.
  3. Gottee

    Gottee TS Rookie Topic Starter

    Thank you for the reply and reading all that text...I know it is enormous.

    I'd post an error log, however, I can't load into Windows. I finally got access to my boot partition through Knoppix and was able to get off some important family pics and docs. However during some of the transfers, the disk just unmounted and disappeared....upon reboot, it would be accessible again. This happened a few times.

    Considering all the errors just coming and seemingly resolving themselves only to leave to other errors, being able to access some partitions under ubuntu but not under knoppix and vice versa and all the still will not load I am just going to look into RMAing the drive and upgrading to 64bit XP.
  4. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    Have you tried to boot into Safe Mode?
  5. Gottee

    Gottee TS Rookie Topic Starter

    Yes sir. It goes through the screen of loading all the system files and then just reboots. There is no way I can get into windows as of right now. There is no diag program that is showing anything wrong my my hardware. The only way I can access my boot drive is through linux; knoppix can access the actual boot partition but not my second partition on the same drive, Ubuntu can't access the boot partition but can access the second partition on the drive.

    It's just a myriad of issues that is a riddle....there is just no real answer. So for now, I have my Win CD on order and we shall see if that will fix things or if it really is my drive.
  6. EXCellR8

    EXCellR8 The Conservative Posts: 1,835

    In the mean time, you could burn yourself a TestDisk CD, if you have another computer, in order to run further diagnostics. The program runs from DOS and you will be able to explore and, I think, you can even copy the contents of the hard drive to another device.
  7. Gottee

    Gottee TS Rookie Topic Starter

    Thank you EXC...burning a copy now and will see what turns up.

    Seems that I got my terminology messed up. I used TestDisk, not TestDrive from the ultimate bood CD compilation. It didn't work as far as restoring my MBR. It picked up my partition table fine and reported no errors, but didn't help one bit. So just have to wait now on my CD
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...