HP Laptop constant crash and corrupt display?

By mke ยท 7 replies
Jun 11, 2008
  1. Hi, my laptop just seem to got "fried". Its a HP Pavilion DV9500t which guarantie just run over (1year) . It was running fine till last week it crashed for the first time. I haven't installed any software that i know off, and i have scanned system with antivirus soft (found one i think irelevant entry for shopper something, deleted now) and also memtest (8 passes), and microscope test.
    The system when it first crashed it was playing some audio or video. Afterwards when i booted up system was fine. the odd thing it seemed like that audio or video froze for a second.
    Now after about a week the laptop decived today to stop working. I have XP SP2 and all 99+ updates (not sp3, since a few drivers i use are not yet supported) . The first blue screen and last i saw today contained the error message about NMI Parity Check , but didnt manage to catch it all (although i have seen a gazilion posts with different resolutions) , so i ask myself if by proving the most info, to get maybe a pinpoint to what is wrong.

    The laptop now doesnt boot nothing, i have mandriva/xp sp2, dual boot and nothing works. The system passes post screen and mem check, no errors, besides some corruption on the display, like on black screen with with letters , there are lines in between and over, that corrupt somehow the text. after a bit mandriva will freeze, while windows will show a black screen with some vertical bars slighly moving, kinda like a visual equalizer bar thingie.. dunno really how to describe that.
    Another note on that is that both o/s had almost loaded before they froze, eg windows would / should, show next the login promt, same as mandrtiva.

    Now i thought that this could be done to the gfx card, or its cooler, since the laptops is getting quite hot when playing gothic 3 or some other boring game ;p but i rule the cooling 50% out, since even when cold it corrupts.

    Now when i run the memtest, kinda probably irrelevant (or not) the chipset doesnt seem to get recognised. Same with the l2 cache. dunno what that is about.

    I have unplugged both modules and re-inserted them and also tried individual slots. also checked that they are of the same colour (pins , eg any chemical reaction due to heat and stuff).

    also unplugged both hard disks and used an older one of 30gb with mandriva on it. no works.

    I am starting to thing that am freakin out as that is my work laptop . i do all my work on that piece of &*&%$YT^(.

    any advice or comment much welcomed.

    also forgive my bizare detail . am stressed as i need that thing.

    Btw, its a HP Pavilion DV9543cl, Core2Duo 7300, 2Gb DDR2 , 2x160 hitachi ata, 8600M GS 256Mb.

    I dont want to resort in disassempling the laptop as of yet, since its only 1 year old and i dont want to miss any screw as i usually do...
    Also will be testing now if by unpluging the internal modem / wireless would make any difference.

    anyways, will report back and hope someone comes up with an idea . bye
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    So this working other HardDrive, gave the same fault?
    If so then it must be Ram (even though tested) or CPU, you can re-paste even laptop CPUs.

    Also detach anything connected externally to the laptop
    And run CMOS setup defaults

    If it's not software, it must be hardware.
  3. lamo

    lamo TS Rookie

    this is videochip(or video memory) faulty. you can repair laptop MB by replacing videochip(or do reballing of video memory), or you can replace whole MB :)
  4. mke

    mke TS Rookie Topic Starter Posts: 90

    Hello all, back from a long day and longer testings...
    Using another new hard disk with windows or linux on doesnt work. have same results. Ram did pass a 8+ memtest,(set to test all memory), though i noticed that if i make a test with the option set at BIOS ALL instead of BIOS std, gets me about 1606 errors on the second attemp at the "test 0" and 1505 on the first attempt, again at test 0.system did freeze afterwards on both occasions.
    So more testing there, altough i dont think that BIOS All option test 0 is related to ram. Don't know though and am not sure this is accurate. more testing tonight with a newer version of memtest, since this is 3.2 i think..

    Another note on that is that the some of the tests performed and error occured i think where pointing to a "system device" that has some memory (BIOS ALL - reported devices from that bios parameter post thing) of a disk of 4098 i think megabytes. Now to my knowledge the laptop has some cache for/from cpu (not relevant as much less that almost 4gb...) , some bios mem that should(think) is few megabyte at most 2 / 4 / 6? / 12? dunno. and some 256 mb on the nvidia gfx card.
    The 2 hd's are 160gb each, the special restore partition that hp puts on the laptop on the 2nd disk to restore systems, has been long gond been deleted, since this thing came with vista, where i wanted xp and mandriva :) so slipstreamed xp with required drivers and worked flawlesly ever since ... well to be concluded.
    The detected 4gb of disk space could be probably e.g. the test 0 in memtest? to check the bios (original newest bios from hp for phoenix), which incorrectly reports now "hard coded" that it is,
    Could the actual 4gb be just a false alarm? (e.g. bios is newest ver from hp site for my "crippled by hp" phoenix chip, and is coded to read from the second hd where the restore partition should be???,if so again am confused).

    Moving a bit forward, today i got it to boot up and tested it by playing assasin creed. game worked fine and for 1-2 hours. when i decided i had enough of the game, and was exiting, just before the game would release the screen and unload from memory, the screen flashed once with purple dotted, some 14 from the16millions of colours, and started working again for the next 10 sec. screen afterwards flickered to a point of i restarted system since it had crashed with a new way..

    Now system loads up again , and forgot to mention that i unpluged all devices attached to the laptops board, (that is devices accessible without dissasempling the case, just covers), e.g. hd's, mem, board battery, wireless/modem oddly small internal card. nothing seems to make any difference, plugged or unplugged. i use no external devices at the moment.

    this happens, on either o/s, even when i just access the bios menu. the screen can containt lines and slightly distorted letters / dots.

    could that nvidia card could need reballing? i am not quite sure what that is yet, but
    it seems like expanded from moisture nanonano air trapped in the BGA - Ball Grid Array on the chip thingie doddle..) Quite some technical nightware.

    Is there any other diagnosis or cost that one can think off?

    anyway. thanks for your replies. will be posting when i get some more tests attempts under, and hopefully some good clean! positive results ...


    ps: sorry for the long essay again :) next one will be proper .

    are you 100% sure? is it the videochip. how much cost am i looking at? doing the reballing procedure on my own is not something i would wanna risk. i still hope it is some simple fault by incorrect bios hidden settings? (though there seem to be none after an extensive search all over).

    kimsland i have checked mem to some extent, cpu will have to try repastin, if it comes to this ,which kina looks like it...
    also there are no other external devices attached, nore big battery/hd's/mem/wireless/cmos battery. also reset numerous times to cmos defaults, which basically is 1 shown option in my crippled hp phoenix bios. i am almost positive that the fault is hardware now, but i still have hope it might be some odd setting in some hidden secret bios menu, or some firmware of some chip is wiped, or something easy to fix.
    dunno really. any other advise appreaciated
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Lamo is much more experienced at this level
    But I have had the LCD data cable (behind the screen) cause similar issue
    I would say remove the front screen bezel, then screen, then replug the "flat" data cable (or replace)
  6. lamo

    lamo TS Rookie

    mke, download the demo version of Passmark Burning Test and test run the video tests(3d graphics and 2d graphics). if screen will bee corrupt - this is videochip.
  7. mke

    mke TS Rookie Topic Starter Posts: 90

    Hi there, back from a 2 day non stop mem and system tests. system will either freeze after that long full test, or pass all tests.
    I have also made a few screenshots of the error that happens when i select on memtest to test ALL memory range and select BIOS ALL.

    this shows some errors on a 3816mb part thing and the next screenshot on the 4078mb part, which i am not sure what address range that is, since i am not aware of what part of my system has that amount of memory..


    i am downloading now the passmark burnitest demo to test system. however i have tested my system with microscope 2000 and it passed all the video tests.
    anyways. any further advice / decoding of that criptic errors images much appreciated.
    will be posting later when i have some results from the passmark tests.

    thanks again for your help. btw laptop seems to work now for 2 days without any crashes or distorted lines/display, though mostly under dos/testing stuff. little use of windows .e.g now from laptop and everything seems in order. no errors no crashes.. how come the system decides to crashes when it wants to?

    anyways, byezzz


    hi lamo. i am testing now the system with Passmark and still it hasnt found any errors though it is not yet finished. screeshot following:



    ok got a passed after 15min of testing. now am testing only 2d and 3d graphics and 3d has passed 9 cycles no errors. 2d is still at cycle 1 with no errors.
    Is that normal? can i assume that there is then no problem with the video chip / memory?

    thanks again
  8. lamo

    lamo TS Rookie

    i don't see on your screenshot the Video 3d testing. this is important test. and as i see from your memory tests screenshots, there's problems with memory modules. and don't forget, that this laptop has nforce 6100go as northbridge. this chip is very hot during memory tests, and so, it can be bad and give you some memory errors. acording these data, i can only propose to unsolder the northbridge chip, and do reballing of chip. but first, it's need to be unsoldered and checked for bad contacts. and as for this forum(and for you too :)), i can only propose replace MB or take it to repair-center which has good equipment to do such work.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...