I need help regarding USB Ports

By imadeyouread
May 11, 2009
  1. I'm running on Windows XP SP2
    My USB ports are all 1.0

    When I plug in my USB, the usual F: drive doesn't appear and the only effect on the computer is a pop-up saying "This device can perform faster". My USB always worked on my computer in the past but now it doesn't and I don't know why. The USB works on every other computer I've tried.
    My two new USBs don't work on my computer either but works on others. A pop-up recommending a 2.0 port appears like the old USB. But then again, my old USB has always worked until now. Last month my computer was still reading USBs. (The recommendation pop-up says the device will still function, just at a slower speed)

    It's the same with when I use a USB cable to connect my phone. When I plug it in and press "Mount" on my phone, nothing appears on the computer at all; the only effect on the computer is the sound indicating that a device has been connected. My phone has always been able to connect to the computer last month too.
    Today was the first time since last month I've tried to connect my USBs and my phone.

    When I check the Device Manager, my phone and my USBs appear under Universal Serial Bus controllers. It always says that the device is working properly but no F: drive or G: drive appears for me to view the files.

    I need help, please. Thanks.
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...