1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

[IClosed] Uacb.dll missing

By JJM ยท 10 replies
Apr 3, 2012
  1. Can anyone help a silver surfer?
    Every time I boot up I have the box appear with a loud noise and stating uacb.dll missing. It first appeared after I tried to update Adobe Flash I think.
    I have Dell Dimension 4700 running Windows 7 Ultimate. I have tried using AVG and Spybot and CCleaner to no avail.
    Any assistance in pointing me to an answer would be appreciated.
  2. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    From what I'm finding, this is not a malware problem- look to be possibly hardware related:

    Product: Uacbdll
    Company: Micronas GmbH
    Description: uacb.dll

    As you can see, this company makes automotive and industrial products.

    You will have to give me more information, especially regarding the "loud noise."

    I would also like to comment about the Dell Dimension 4700. That model has been around for a long time. I would question how you manages to get Win 7 Ultimate on it. This is a desktop that came with Windows XP some years ago.
  3. JJM

    JJM TS Member Topic Starter Posts: 21

    Thank you,
    I am sure it appeared after I tried to install Adobe Flash Drive as req by the system. I have seen the name Micronas though and will check to see if I can find it on here. The noise is just like one bang on a drum. I bought the kit about six years ago new with W/XP but just recently installed W7 and it seems to work OK.
  4. JJM

    JJM TS Member Topic Starter Posts: 21

    I just had a look on the Control Panel installed programmes and I have installed a plugin called SmartSound Quicktracks on the 21/3 which appears to be something to do with Adobe. A quick check on the internet shows that it looks a but dubious and their site says it is not "their" plugin.
    Should I uninstall this do you think?
  5. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    I don't see anything dubious about SmartSound Quicktracks. However, if you downloaded it from a torrent/file sharing site, it could have brought malware with it.


    When you say you have seen the name Micronas before, where was that?

    Please explain use of the word "kit." You say this is a Dell Dimension 4700, but 'kit' sounds like a home build. And I still question the install of Win 7 on this old of a system.

    I don't have enough information at this point, but the drum beat sound sounds more like hardware gone bad.
  6. JJM

    JJM TS Member Topic Starter Posts: 21

    Sorry to have confused the issue by the word kit. The Dell is normal 3GHz CPU and I updated the memory to 2GB (Recently took out two 256mb faulty sticks) The W7 works perfectly.
    I found this site when I keyed in SmartSound
    They seem to be saying this plugin could cause a problem. I uninstalled it this morning and it has made no difference. The message says: mc500cpl.exe - System Error

    In the box it says "The program can't start because uacb.dll is missing. Try reinstalling the program to fix this problem". I installed Adobe Flash at about the same time (21/3) so I just feel it has something to do with this.
  7. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    My journey to help you understand:

    http://www.smartsound.com/quicktracks/>> Home site
    http://www.smartsound.com/support/updates.html>> Support on Home site
    MONKEYJOB SYSTEMS File manipulation- nothing to do with SmartSound Quicktracks.

    3rd Party Products>> In this section it says:
    Regarding the System Error message you received:
    These products don't have anything to do with each other:
    Since you have linked the problem to the recent update for Adobe Flash, the most obvious thing to do is to uninstall the update you got, then go to one or both of the following sites to find the correct update for your system:

    My guess is that there is a compatibility problem.
  8. JJM

    JJM TS Member Topic Starter Posts: 21

    OK Now I have installed the latest Adobe Flash 11.2 via your supplied link and problem still persists so I can forget Adobe. Regarding the first part of the error message "Mc500cpl.exe"
    I have a Philips Ultimate Edge Sound System which I installed when the comp was running W/XP. Maybe now I have W7 do you think I have a driver compatibility problem?
    Many thanks for your time in trying to assist.
  9. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    Yes, I think there is a good chance of a compatibility. Check MS for diagnostics for compatibility. Technically this should have been done before you loaded Win 7 over Win XP.

    Here one site: http://www.microsoft.com/windows/compatibility/windows-7/en-us/default.aspx

    A software problem may give an error sound, but if you're getting a 'drum beat' I would think hardware must be involved,
  10. JJM

    JJM TS Member Topic Starter Posts: 21

    OK I have run the compatibility check from your link and it only shows up Microsoft.Net Framework Version 1.1.4322 as not compatible & a couple I don't use anyway.
    I also ran the Microsoft Malicious Virus Scanner which showed negative.
    Tomorrow I will uninstall Philips Ultimate Edge Sound System and then reinstall with the disk.
    Many thanks for your continued assistance.
  11. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    You're welcome. I'm going to close this thread as the problem does not appear malware related.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...