Install to RAID fails halfway

By Selfdefender ยท 8 replies
Jun 3, 2008
  1. I am setting up a new PC on a GA-MA78GM-S2H motherboard, with the AMD 780G chipset. It includes SATA RAID support with lots of ports. I am using two identical 500GB drives to make a RAID0 set, and I am installing XP Pro to a partition of that set. I have successfully configured the RAID set in BIOS.

    The XP installation goes as expected to a point: Boot from CD, press F6 and wait, load drivers from the floppy*, partition the (recognized) 1TB hard drive, copy a lot of system files. Then it goes back to the floppy to copy the drivers over...

    "setup cannot copy the file ahcix86.inf". Retry no good. Only ESC to skip the file moves on. Repeat for ahcix86.sys and Then the doomed install resumes copying system files, and then reboots to do the GUI stuff but instead goes bluescreen error 7b (after the brief Windows splash screen).

    In order for the RAID set to hold the operating system, I have to deal with this first. I need to get those drivers into the right system folder, it seems. I tried F8 to get to safe mode, but I still get the bluescreen code 7b. I need a DOS prompt with RAID driver support, or I need to do surgery on the WinXPU CD to put the drivers there, perhaps.

    My best guess so far is that there are drivers by the same name already there, and they are marked read-only, and Windows install can't deal with over-writing them. I have tested both hard drives and the RAM. A trial install to a single drive was successful, other things being the same.

    TIA for all attempts to educate me.

    *Install warns that Windows already has an older driver for "AMD AHCI RAID controller x86", and I choose to use the one from the floppy. When I tried using the old one, it didn't see the RAID set.
  2. nobardin

    nobardin TS Rookie Posts: 256

    Not sure if this will apply to you. However, it's a start. Let us know if this resolves your issue.
  3. Selfdefender

    Selfdefender TS Rookie Topic Starter

    My problem is happening before that, and there's only one IDE socket anyway. I wil double-check the master/slave settings. It's a copy from the floppy to the SATA RAID pair that's problematic, even after both read and write operations worked (loading the driver from floppy, and copying from CD to RAID).
    I'll report back, but I am quite sure I need another answer. Any notions for getting the drivers on there, short of slipstreaming?
  4. nobardin

    nobardin TS Rookie Posts: 256

  5. LNCPapa

    LNCPapa TS Special Forces Posts: 4,276   +461

    I didn't get a chance to thoroughly read through this thread (I'm pretty busy here at work but I'm scanning the forums when I can) but I would certainly try to add those drivers into your WinXP CD using nLite. I'd just make sure I had the correct and most up to date drivers when I merged them in. If you have a complete install to one drive or another machine to try it on give it a shot.
  6. Selfdefender

    Selfdefender TS Rookie Topic Starter

    Yeah, and I tried it again to be sure. Just retried install to a single SATA drive configured as AHCI, same result. I can think of two things to try now as workarounds:
    1. Slipstream onto the Windows install disk
    2. Install to a single drive configured as "native IDE" in BIOS, install drivers through windows, copy partition image to the RAID set

    Obviously I'd still like an idea how to make it work as it should, not just workarounds.
  7. Selfdefender

    Selfdefender TS Rookie Topic Starter

    I can't believe how easy it was to slipstream the drivers. Download drivers, insert DVD, click two buttons, make the ISO, burn the disk. I don't think anything significant was lost in translation, because it worked right away, both for a single AHCI drive and a RAID0 pair, with no other worries.

    In retrospect, apparently it is something truly silly, like the AHCI driver files get installed read-only.

    Thanks to all who replied.
  8. Mantis447

    Mantis447 TS Rookie


    Would someone be able to help me? I thought I had succesfully slipstreamed the raid drivers into my XP install (through nlite)... but I am still getting an error when installing XP. (missing file ahcix86.sys). I am guessing that I did not do everything in nlite.

    Steps I have taken:
    1) Download drivers from Gigabyte
    2) Run the self-extractor, and save the files on my desktop
    3) Install nlite
    4) Copy XP into a folder on my desktop
    5) Run nlite, and only try to include drivers for RAID... (see step 2)
    6) Inside of nlite, I am including both AHCIX64.INF & AHCIX86.INF
    7) Create & Burn ISO...
    8) Insert CD into new PC.. (Specs are in my profile)
    9) Turn on boot new PC, and get the error of missing file, once windows setup begins..

    Thanks for your help...
  9. Mantis447

    Mantis447 TS Rookie


    I was able to slipstream the driver. It seems I should only select one driver... not both (AHCIX86)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...