Installing Linux for the first time (& dual boot)

By svtcobra ยท 340 replies
Feb 20, 2002
Post New Reply
  1. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    This is exatly the problem: RedHat can't create a new partition for Linux.

    What do you mean by PM not letting you resize the partition?
    You need PM8 or later to resize NTFS.
    Perhaps it has set your system drive to "read only"?
  2. Pogo

    Pogo TS Rookie Posts: 19


    No it hasn't, but you're right, I've got PM 6 on XP professional. And I've just recently discovered that PM 6 isn't compatible with XP, or the NTFS file format.

    I'm busy getting PM 8 Pro, so hopefully that'll help me here.
  3. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Is it a dynamic disk? PM can't resize those.
  4. Pogo

    Pogo TS Rookie Posts: 19


    I know, but don't worry about it anymore. After much work, I finally have RedHat 9 working, and it's great.
    But I want to install it in a different way, so how do you uninstall RedHat 9?
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    No need to double post.. I hope your question was answered in the thread you created.
  6. Pogo

    Pogo TS Rookie Posts: 19


    Yes it was, thanks! I've got the idea of it all now!

    I just a few more questions in a new thread I've posted titled "RedHat Questions" (sorry, I'm completely new to Linux, but I'm REALLY interested in it) :giddy:
  7. Snaps

    Snaps TS Rookie

    Dual-Boot On different Hard Drives

    After a little trouble with partitioning, I finally got linux to boot linux. However, my computer hangs everytime I try to boot windows. My set up is kind of wacky. Linux and a FAT32 partition are on my IDE3 cable while my Windows XP NTFS is on IDE1. IDE2 is for my cdrom. The bootloader is on the IDE3, but at first I put it on the MBR :dead:. I read this is very bad... any suggestions?

    EDIT: Well I got it to work after some much needed sleep, and it works with LILO ON the MBR of the hdd with winxp. I can now dual-boot :grinthumb. A new problem has arisen! When I boot into windows I can not access the other partition that is on the same HDD as Linux. Partition Magic says its an error with regards to the partition table and claims to fix the error (which is obvious it hasn't since it immediately pops up again). Linux can see the drive just fine in the mount point i set. I think LILO may have found its way onto that drive and was wondering if there was any way to fix this? Thanks.
  8. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    You will be surpised how the impossible can come you to when you take a break and relax. Remember Archimedes shouting "EUREKA!" in the bath??

    If you are having problems accessing this partition, then did you partition it with linux setup? If so, then you may have to repartition it with something else... there's not very good compatibility problems between linux partitioning and windows, but windows seems better so maybe try to create it in disk administrator if its FAT32.

    Under windows, you will not be able to access any ext2 or ext3 formatted partitions such as / without third party tools of some sort.
  9. me(who else?)

    me(who else?) TS Rookie Posts: 387

    I need some help with a Linux install. I'm trying to install Linux, but I keep getting an I/O error after the installer checks for previous installations. I have a 3 gigabyte partition and 256 mb of RAM. I set up a 512 mb swap partition and made the rest my root partition. I'm not dual booting. I'm installing this to a virtual drive from Bochs. PLease help!
  10. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    try a different linux installation - but first try a text only install. That will be one of the install options, you should be presented with that at one point.

    which linux are you trying to install?

    In Fedora Core, I think you need to enter something at the first


    prompt, along the lines of

    install text

    or something like that to install in text mode.

    if you are trying a beta or something of Fedora Core 2, I would instead try Fedora Core 1.
  11. me(who else?)

    me(who else?) TS Rookie Posts: 387

    So far I've tried Fedora Core and RH9. I kinda fixed the problem. Now I get a wierd error that I have to scroll down to see. It's a wierd error that asks me if I want to make a dump. When I say yes, it says need a floppy. Could someone please help?

    edit: Yes, I've done a textmode install too.
  12. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Can you go into your BIOS and find the setting that says:

    Plug and Play OS Installed

    And set it to "NO"

  13. me(who else?)

    me(who else?) TS Rookie Posts: 387

    I'm using Bochs...what setting would I use for plug+play OS. Has this been known to cause a problem, or is it just an idea(no offense, but Bochs settings are strange when you tamper with them, so I try to avoid messing around too much) ;) .
  14. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Basically, that setting sets certain hardware configurations in the BIOS as opposed to just turning things over completely to the OS (AFAIK). Your install may be crashing during some kind of hardware detection phase.
  15. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Linux isn't always easy to install, some unexpected things might happen & it's even worse when you add "emulation" into the matter.
  16. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    You might find that the installer kernel contains a component that has a bug on your system. A re-compile of another kernel version would be fine, but the installer fails.

    That's one opinion, anyway. Its not common but I have seen it happen.

    Have you tried another linux version?? - Some release of version 10 of mandrake is out.
  17. me(who else?)

    me(who else?) TS Rookie Posts: 387

    I'm trying to install Mandrake, but my demo of Nero wore off, so now I can't burn a bootable CD. Any suggestions for freeware to burn a bootable CD? Also, how do you install Mandrake? The installation guide says that you just have to put the CD into the drive and reboot. Of course, emulations screws everything up.
  18. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    If you want to install Mandrake on a PS emulator then just install some virtual CDROM software to mount the ISO images. No need to burn them.
  19. me(who else?)

    me(who else?) TS Rookie Posts: 387


    what kind of software do you mean? I have Daemon tools, but I don't know how to use it. How do I use it to mount software
  20. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You right click on the drive Daemon Tools created and choose to mount an image. Or you download the Explorer context menu plugin for Daemon Tools from their website so you can right click on an .iso to mount it.
  21. me(who else?)

    me(who else?) TS Rookie Posts: 387

    I do that, but Mandrake says it can't find a CD-ROM drive. Then it asks me to put in some installation floppy. What are they talking about? I have two image mounted as CD/DVD-ROM drives, but no floppy drive.
  22. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You have to tell bochs which CD drive(s) exactly to use.
    You can use floppies in Bochs too if you want. The floppy image(s) you need can be found on the Mandrake CD.
  23. me(who else?)

    me(who else?) TS Rookie Posts: 387

    I did tell bochs which drive I want to use. I mounted the Mandrake 10 disk using Daemon tools and then told Bochs to use that mounted drive as a CD-ROM drive. I didn't think I would need a floppy if I had the CD-ROM in the drive. Am I doing something wrong?
  24. melloe

    melloe TS Rookie

    Good job. I have been to a lot of sites, and that is about as good a set of instructions as I have seen for Linux install for that distro ...reminds me of a couple of folks on another forum.
  25. kevinsprague

    kevinsprague TS Rookie

    hopefully someone will see this here. i just tried to install rh9.0 to a system already using win xp. it is a dell 8300 system with a 17inch dell flat panel moniter. i tried with this moniter and a hdtv projector, and everytime i try and use the moniter to display linux, it tell me that it cannot display this video mode. i had to install linux with the text install because it would tell me the same thing if i tried to install with the window version. it would also not work in lowres version. i did get linux to install and the boot disk to work, but it still will not like my monitor or graphics card. i don't know what to do from here, so maybe you guys can help. thanks

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...