Installing Linux for the first time (& dual boot)

By svtcobra ยท 340 replies
Feb 20, 2002
Post New Reply
  1. mindspin

    mindspin TS Rookie Posts: 40

    What Graphics card do you use? We need Hardware info to help you out with your install
  2. kevinsprague

    kevinsprague TS Rookie

    i believe it is a GForce FX5200 with 128mg memory and a 17" E171FP Flat Panel Display. i know it recgonized the monitor and i am pretty sure it recgonized the graphics card initially, but it order to get something to show up, i have to tell it not to search for the monitor or card, it just uses the defaults. When i do have it search for a graphics card because it tells me i have an error with displaying X Something, i can't remember what it was, the screen goes blank then it the monitor tells me it does not accept the video mode. if something doesn't sound right about anything i say, tell me. This is my first time installing a other than microsoft operating system, and expecially the first time i tried to use a dual boot system. i got the computer from dell about a year ago and all i have done is add another 200gig hd and a wireless card, so i don't know the specs of it too much except from what i read on dells website about what they put in my series of computer. Thanks for any help.
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You can try installing the video drivers from nVidia. The generic nv driver that comes with RedHat doesn't actually shine.
  4. WaarrEagle

    WaarrEagle TS Rookie

    This is an awesome thread but I am still having problems. I tried to follow the step by step tutorial but had a couple things go wrong. First of all, my screen goes blank every time I try to install Linux (Redhat) with the GUI. I end up using text mode which is much harder to navigate. I ended up getting it installed but I do not get a screen when I start the computer asking where I want to boot to - it just goes straight to XP. I changed my boot order to the hard drive (separate from XP) that Linux is on and it just says "GRUB" (i think, can't exactly remember) and locks up. I tried to reinsall Linux using the guide posted on the first page of this thread but my Windows XP partition uses NTFS instead of FAT32 and I can't give it a mount point. So when that didn't work I gave up and decided to get help.
  5. me(who else?)

    me(who else?) TS Rookie Posts: 387

    Hello. You will probably need to fix your mbr before you reinstall ( ask around before you do). If you want to access NTFS, then you'll need to patch the kernel. However, NTFS support is experimental at best, and if you have anything very valuable on your NTFS drive I wouldn't bother. Partition your drive so that you can put any files you need to access on the FAT32
  6. WaarrEagle

    WaarrEagle TS Rookie

    What if I don't need it to dual boot. Can I install it somehow so I can just change the boot order of the hard drives to get Linux/Windows to boot. I just want to get Linux working.
  7. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Then set boot order to first disk first, boot to Red Hat CD's rescue mode, and start grub (with command 'grub').

    If the Linux installation is on the first partition of second disk, type

    root (hd1,0)

    If it was correct, it should say "Filesystem type is ext2fs (or whatever you formatted it as), partition type 0x83".

    Then type

    setup (hd0)

    to install grub into master boot record of the first disk. Finally,


    exits grub.
  8. WaarrEagle

    WaarrEagle TS Rookie

    Thanks! I get a boot menu now and XP works when I select it. When I selected Linux for the first time I went through a bunch of stuff that all said OK and then my screen went blank. My screen would also do this when I tried to install Linux using the GUI instead of text mode. Now what do I do? I feel like I am so close!
  9. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Highlight Linux in grub menu, hit e to edit the boot commands, append 'S' to kernel boot line (ie. kernel /boot/vmlinuz root=/dev/hdb1 S), enter and hit b to boot. That'll boot Linux in single-user textmode.

    Then edit /etc/inittab and change line


    to id:3:initdefault:

    If you don't know which texteditor to use, try

    vi /etc/inittab

    Hit insert to enter text (or twice to replace), esc to exit that mode, then :wq to save & quit.

    Apparently your graphics card or monitor wasn't detected correctly or you don't have proper drivers installed. Which graphics card do you have?
  10. WaarrEagle

    WaarrEagle TS Rookie

    I have a NVidea FX5200. The login screen came up but I did not create a login. I did a quick search and it said to login as root and use the PW i put in. I did this and the following came up:
    [root@localhost root]#
    Now what?
  11. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    what next?


  12. WaarrEagle

    WaarrEagle TS Rookie

    I tried that but my screen still goes black???
  13. kevinsprague

    kevinsprague TS Rookie

    no fear, i have figured out our problem. the graphics card driver for our card is not up to par with what it should be. go to and download the driver. i made it simple, and downloaded it in windows and burned it to a cd, cause it is too big for a disk. then start up linux in text mode, as described earlier( addin S tin grub after command line), mount the cd drive to the hard drive("mount -t auto /dev/cdrom /mnt/cdrom" if the directory is not already created, which is was on mine, thenyou need to make the directory with "mkdir /mnt/cdrom" in the offchance that cdrom is not your cdrom drive, you need to mount whatever then name of the drive is) , then run the install program. after you install the drivers, open up the readme for the drivers and it will describe to you what you need to do to modify the xf86config(i think that is the name. i may be off a letter or sumtin, read the manual to get exact information. i used pico to modify it cause i like using pico from when i program in windows(it is what my cs classes used)) file, and where to find it( i believe it is etc/X11/). Once you modify that file, ie change Drive "nva" or whatever to Drive "nvidia" and add Load "glx" , then delete (load "dri") and (load "glore") , then you just restart into linux. make sure grub doesn't have the s after it now, which it shouldn't, and then everything should work. i am on linux now, so it worked for me. let me know if you have any problems. The readme file is in USR/share/NVidea(can't remember this directory, just hit NV then tab and it will fill out the name for you)/then the file name is Readme . open it with a text editor or sumtin, again i used pico. If i went into to much explaination, sorry, or not enough just ask.

    ::edited 12/15/04 2:00::
  14. WaarrEagle

    WaarrEagle TS Rookie

    Thank you so much for the help Kevin. I did everything you said and got the driver installed. I tried to StartX but got an error:
    (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
    (EE) NVIDIA(0): ***Aborting***
    (EE) Screen(s) found, but none have a usable configuration.

    Fatal server error:
    no screens found

    I am getting close but what is the problem now??? Thanks!!
  15. WaarrEagle

    WaarrEagle TS Rookie

    I am posting this message from Linux. Thanks so much for everyones help! For some reason my keyboard still does not work in text mode but I went back and changed id:3.... to id:5... and it booted up. I have yet to reboot the machine but at least I am running Linux right now. What is the difference between the Linux and Linux-up on the boot screen? I think I am on Linux-up right now.
  16. Technel

    Technel TS Rookie Posts: 24


    First of all, the guide at the beginning of this post was great. I installed Feodora Core 3 with no problem. However, shortly after that I decided to reformat Windows. When I did, the boot loader went away.

    To get it back, I tried booting for CD1 again. At the install screen, I chose to upgrade the package. I selected "Create new boot loader", configured it, and applied the "upgrade". After it prompted me for Disc 3 and was complete, it said that something was not installed and that the boot loader was left untouched.

    Why is this? How do I get the boot loader back?

  17. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Did you use the GRUB bootloader originally or the Windows one?

    You have to use the Rescue mode from the Linux CD to restore GRUB or LILO.
  18. Technel

    Technel TS Rookie Posts: 24

    Yes, I was using GRUB. I have tried rescue mode, but I do not know what exactly to do there to restore GRUB. Any ideas?
  19. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Boot into rescue mode.
    It tells you that your Linux system has been mounted under /mnt/sysimage or something similar.
    Run "chroot /mnt/sysimage"
    Then "grub_install /dev/hda" to reinstall the GRUB bootloader.
  20. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    That is exactly correct.

    (well, apart from the fact that its /sbin/grub-install /dev/hda but never mind)
  21. Technel

    Technel TS Rookie Posts: 24

    I went to do this, but I got an error saying that the command grub_install was not recognized. When I came back I saw Phantasm66's post, which had the proper command. I am back in Fedora and it is working great. Thank you both!

    For future reference:

  22. Tribal-Phoenix

    Tribal-Phoenix TS Rookie Posts: 92

    hey guyz i decided to give Red Hat a try , but i got a lil question before downloading it , i found this site which gives me lotsa links for downloading Red Hat but in brackets it says Valhalla , shrike , and just 7.2 so what do u think which one should i download ,heres the link : "" , and Phantasm66 when i need your help i want to make a dual boot have 2 hard's #1-80gb-2-partitions(c;d), #2(backup harddrive i just want to leave it alone, im probably gunan disconnect it while installing so noone of my precious files would be erased by mistake) .........okay so my win xp is on c drive and i have all my software installed on d which is 70 gb partition , so what i want to do is make d drive smaller and without formating anything install linux, btw all hard's are formatted with ntfs, hmm my pc specs are

    OS Name Microsoft Windows XP Professional
    Version 5.1.2600 Service Pack 2 Build 2600
    OS Manufacturer Microsoft Corporation
    System Manufacturer Seanix
    System Model AWRDACPI
    System Type X86-based PC
    Processor x86 Family 15 Model 2 Stepping 9 GenuineIntel ~2500 Mhz
    BIOS Version/Date Award Software International, Inc. F7d, 11/17/2003
    SMBIOS Version 2.3
    Total Physical Memory 512.00 MB
    Available Physical Memory 125.99 MB
    Total Virtual Memory 2.00 GB
    Available Virtual Memory 1.96 GB
    Page File Space 738.03 MB
  23. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    The free version of RedHat stopped at RedHat 9 (codenamed shrike) & is no longer supported/outdated. Get Fedora Core 3 instead -> Fedora Core 3 mirror list
  24. Tribal-Phoenix

    Tribal-Phoenix TS Rookie Posts: 92

    Thanks for a link , so is fedora project actualy better then 7.2 or 8?
  25. thmandan22

    thmandan22 TS Rookie Posts: 59

    Yes, I would say so. IMO

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...