Installing Linux for the first time (& dual boot)

By svtcobra ยท 340 replies
Feb 20, 2002
Post New Reply
  1. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Ooops, there is a rescue....

    When presented with the lilo screen, press control + x , and then type

    linux 3

    and then enter

    I believe, to boot to command prompt only. Then edit the /etc/inittab file, and then try Xconfigurator and mouseconfig.

    You could also do "linux single" if you have forgotten the root password, as this boots you in with root rights without asking for a password.

    But you might as well reinstall just for the practice and the familiarity. There are probably other options you chose you might want to revise.
  2. svtcobra

    svtcobra TechSpot Paladin Topic Starter Posts: 761

    I can log on as root and at the prompt I type /etc/inittab and it says permission denied.

    Im going to bed and getting some rest. Maybe tomorrow I'll get this finished. Once I edit the /etc/inittab I can install the newer Nvidia drivers, thanks to Mictlantecuhtli, and hopefully have my video working correctly.

    I decided not to reinstall just yet because everything seems to be installed and my existing data is still intact. If I was to do a reinstall, whats the best way to do it? I figured I would boot up via the CD like I am doing an install and when I get to the partitioning section I would delete everything except for my WinXP partition. I did notice that there is a free space partition now that cannot be deleted, but I figured that was there becuase of the format and file system being loaded now.

    If you really think a reinstall is best just confirm the above paragraph. I really dont want to screw up my XP partition because I really have no way of reloading it. I would rather fix what I have if possible.

    Thanks again phantasm..
  3. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    You need to edit it as root.

    pico /etc/inittab

    That's probably wise. After a while your head will start to spin.

    first log on as root and run


    and see if you can find a better configurator that will give you a running X server. Try installing the latest nVidia drivers later when you have a better hang of things. The stock drivers should work, you just didn't find the right combination of settings yet.

    All you need to do to reinstall is boot from the CD again and then do everything the same, except you don't need to recreate or delete any partitions this time. Just choose assign the mount points again and / will be formatted by default.

    A reinstall is not necessary, but probably best for now whilst you are still getting the hang of all this. Remember I said familiarity breeds confidence? You'll race through the install more quickly this time, and probably notice things that you missed the first time.

    But you will also learn some by trying to fix problems with the installation that you already have. Bare that in mind too.

    Don't worry, you're not experiencing anything that I didn't experience the first time I installed linux about 4 years ago. I had all of these problems and more. When you are more familiar with the operating system, these things will seem trivial. But this is the only way to learn.

    Don't worry, me and the other Linux heads here (like Mictlantecuhtli) will get you all there!

    Good luck!!
  4. svtcobra

    svtcobra TechSpot Paladin Topic Starter Posts: 761

    Alright, after a goods night sleep Im ready to get this done. Okay, a few things. Last night I played around in pico. I figured out that you just use the arrow keys and go down to the line that I need to edit, change the 5 to a 3 and then save. Well, how do I save? I didnt see anything allow me to save.

    The other thing is that when Red Hat boots up, the monitor is unprobed. I think the monitor is the issuse not the video card. I could be wrong but Im gonna try some different monitor setups to see what I get.

    Thanks Again...:grinthumb
  5. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    You save in pico by htting CTRL + X.

    A message shall appear asking if you want to save changes, Y/N ???

    There is some info on keys at the bottom of the screen, where ^ means CTRL.

    More than likely the monitor is your problem.

    Try Xconfigurator

    It will let you experiment with different monitor and video adapter choices, resolutions and number of colours. Eventually you will hit on something that works and pleases you...

    You are progressing well, my dark apprentice...
  6. svtcobra

    svtcobra TechSpot Paladin Topic Starter Posts: 761

    Alright Ctrl-X is it...

    Okay, that worked good. Now when it boots up it doesnt run startx auto.

    My issue is the video. I have tried every combo available and there is no correct one. None of them test correctly. Everyscreen looks pretty much the same. It is this greenish color that is a bunch of bars and they are pulsating. I still think its the monitor but I dont know for sure.

    Well, let me know what you think..I have tried every conceivable display configuration and have gotten no where. Is it possible that my monitor is uncompatible?
  7. svtcobra

    svtcobra TechSpot Paladin Topic Starter Posts: 761

    phantasm, check this link out:

    This guy has basically the same notebook. His screen is a bit bigger but its all made by the same manufacturer.

    He says to install the two nvidia files with instructions by nvidia. Well, I checked out the nvidia site and download the two files but I dont know how to install them. Mictlantecuhtli, stated that I need to:

    Go to the directory where the files are, and then:
    rpm -iv NVIDIA_kernel-1.0-2313.rh72up.i686.rpm
    rpm -iv NVIDIA_GLX-1.0-2313.rh72up.i686.rpm
    Go to /etc/X11. Edit XF86Config-4:

    In section "Module", comment out (with "#")
    Load "GLcore"
    Load "dri"
    In section "Device", comment out
    Driver "nv" (in case your card was detected as such)
    Driver "nvidia"
    Now you could try if X works. If not, you can kill it (usually) with CTRL-ALT-BACKSPACE.
    Check /var/log/XFree86.0.log for errors (lines that begin with (EE)).

    I dont even know how to go into a directory. Is it something that I need to run through pico?
  8. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    In command line, cd changes the directory. Remember that Unixes use / instead of \ in directories. ls lists the directory (but dir works, too). Tab-key is always handy!
  9. svtcobra

    svtcobra TechSpot Paladin Topic Starter Posts: 761

    alright..I'll try that.
  10. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Btw, if you have problems like "package requires kernel version blah blah", you may need to download driver source files instead and compile them.
    If you still have mouse cursor problems, try adding
    Option "swcursor" "on"
    Option "hwcursor" "off"
    into XF86Config-4 file, under that Driver "nvidia" line.
  11. svtcobra

    svtcobra TechSpot Paladin Topic Starter Posts: 761

    One thing though..Should I use the 386 files or the 686 files? Your original links for the i386 files but in your instructions you reference the i686 files.

    Thanks Mic..
  12. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Typo.. 686 drivers should work with your CPU, if they don't, you have to use 386.
  13. svtcobra

    svtcobra TechSpot Paladin Topic Starter Posts: 761

    Mictlantecuhtli, I am wondering if you could tell me a little bit more in depth what I need to do to get the vid drivers installed. I am totally lost at this point. I log into root and then what. When I type CD\ I get nowwhere. My vid drivers I dload'ed to my C:\drivers. So I guess I need to get into that folder but Im not having any luck doing so.
  14. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    You've downloaded the drivers to windows partition? Then you'll need access to that partition first. Assuming the XP partition is the first on your hdd, try this:
    mkdir /dos
    // create "dos" directory to /
    mount /dev/hda1 /dos
    // mount XP partition to /dos
    cd /dos
    // go to XP partition
    // just to find out how the "Drivers" directory is named, case matters in Unix
    cd Drivers
    // go to drivers directory
    from there, rpm -iv and so on.
  15. svtcobra

    svtcobra TechSpot Paladin Topic Starter Posts: 761

    thanks...I'll give that a try
  16. svtcobra

    svtcobra TechSpot Paladin Topic Starter Posts: 761

    Alright guys, IT WORKS!

    I downloaded and installed the video drivers and made the changes to the XF86Config-4 file that Mictlantechtli suggested. I typed startx and voila!. This nice little Nvidia screen popped up and then it booted into the OS. I still have to play around with the resolutions because it looks like crap but atleast it runs! Thanks alot guys for all the help thus far.
  17. svtcobra

    svtcobra TechSpot Paladin Topic Starter Posts: 761

    Btw, Im typing this from Linux. Everything seems to be working fine except for my video resolution issue. Im going to play around with it now. Any suggestions on bumping it up to 1024x768?
  18. svtcobra

    svtcobra TechSpot Paladin Topic Starter Posts: 761

    Alright, everything is working great. I have my resoution set to 1024x768 and my color depth is set at 16 bit. I dont know how I did this but in Xconfigurator I chose a Gateway EV700 monitor with a 70hz refresh and voila!. In the XFConfig86-4 file I made some changes, saved and rebooted until I got it right. Im getting no errors and it is running very fast and smooth.

    My next question is this. At 1024x768, the text is very small at all the websites I visit. 3DS's homepage new is barely readable. Although, I am typing this and it is fine. I can read it and it is very comfortable.

    I thought it was a setting in the Appearance page of the NEtscape preferences tab no matter what character I set it at, the text stays small. Not a huge deal but it would be nice to fix this.

  19. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    This might be no help at all but...

    When I ran mandrake there was abotu 4 different web browsers you can use. I dont' remember which one it was but I had a very similar small text problem. I used a different browser and everythign was better. Although I never could make the fonts in ANYthing look good in linux, but that was probably something I could have fixed if I played around with it more.
  20. svtcobra

    svtcobra TechSpot Paladin Topic Starter Posts: 761

    Yeah, this is the same issue I had with Opera on Win Me. All my fonts look great except for the web text. I'll play around with it. Im thinking thought that it is a Netscape setting but I havent used Netscape for years so it may take me some time to find it.
  21. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Why is it not very cool?
    Maybe it's just me but I want to control my computers. Sure, /etc/fstab can be edited so that non-root users can mount filesystems, files & directories' permissions can be changed - but wouldn't that be the same as being root?
    Honestly, I've never used su command.
    Just curious, what kind of an user account do you have, other than root? What are you not allowed to do?
  22. svtcobra

    svtcobra TechSpot Paladin Topic Starter Posts: 761

    Up to this far, I have only logged in with my root account. I cant see logging in any other way.

    btw, I am dloading Ximian now. I live in Boston and I am downloading from a Boston site and Im averaging 10kb per/sec. It is taking all day. Thats alright though..Looks very cool.
  23. svtcobra

    svtcobra TechSpot Paladin Topic Starter Posts: 761

    Well, Ximian is installed and it is awesome. Great pick Phantasm...Im gonna play around with the Red Carpet.

    BTW, with Mozilla my browser is perfect. There are no text issues now. It may have been a Netscape issue.
  24. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Its 2 am in the morning, at the end of a long evening's working with Linux and the terminal. I'm typing command after command, sipping that nearly cold cup of coffee by my side.... Suddenly I spy a few old files that I want to delete in /tmp. Ok:

    rm -fr *

    Only, OH NO! What's this..? I am not in the directory I thought I was. Ooops, I have just deleted the contents of /etc recursively. With so many terminal windows open, I have typed the command into the wrong one, where /etc was my pwd, thereby utterly ruining my finely polish, patched and fixed Linux installation. Now that's not funny.

    "Ooops," is perhaps not the word I would be using. I would probably get a TOS from Uncleel for the real word I am going to use.

    What made this more likely to happen? Well, for a start, I was logging in as root all the time, habitually.

    As we both know, UNIX has some VERY powerful commands, and if you are root, the operating system will just let you do them. Not matter how silly or stupid they might be.

    In an iconic interface, I would have to be hallucinating to go into my /etc folder and drag the whole lot into the recycle bin. But on the command prompt, mistakes are more easily made of that nature, especially when you are doing something extremely complex or are tired, etc.

    Now, I make extensive backups of ALL of my data, including images of all of the operating systems I have installed. But having to wait that 30 mins whilst by Red Hat Linux image is restored byte after byte because I typed something careless is not very good when I had planned to be spending that time posting to 3DS or playing a game on the net.

    Furthermore, by running programs as root, you've disabled all the protections that make Linux less vulnerable to viruses than other operating systems. You opened the door for havok.

    Running programs as a normal user limits their damage if they have intentional or unintentional security holes, in addition. And as I am sure that many here know, there are LOTS of programs with security holes, in Linux and in all operating systems.

    I like to think of the root account as a "magic hat" that you only put on when you are ready to do some system maintenance or administration. Its different in other operating systems like Windows NT where logging on with admin rights or logging on without them is probably going to induce exactly the same level of damage in the event of something malicious.

    I like to go on IRC a lot and I've heard of some unpleasant people doing all kinds of untold damage to the machines of others who had logged in as root. In my opinion its a fundamental axiom of UNIX security that certain accounts are not allowed to do certain things; why strip myself of that protection??

    You asked what can't I do when I log in as a normal user. Well, apart from changing system configuration (installing software, editing system scripts, etc) pretty much nothing else. I had a bit of a problem writing CDs in Linux with a non-root account until I did some editing here and there.

    Actually, I believe the title of one of the chapters I read in a very good UNIX book was "Why you should not log in as root."

    But as I've said many times on the forums, different people have different ways of doing things, especially on the computer. If you are working one way and finding it good for you, then basically that's fine.

    Incidently, I am pretty sure that you are not aware of this, but I thought that the tone of your post was mildly patronising. I am very sure that this was not what you intended, however I thought it was worth pointing out. No offence taken here, of course. After all, we're all friends here. :) From a karma perspective, I find it on near enough the same level as someone accidentially bumping into me in the street and saying "sorry" and then walking on, so its completely nothing to worry about.
  25. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    :) :) :)

    P.S. I much prefer Mozilla in Linux than the Netscape that's shiped. You get Netscape 6 for Linux but I had probs using it on anything other than 2.2 kernel.

    What I like in Mozilla is that you can hit CTRL and + together and it will enlarge the fonts, and CTRL and - shrinks them again. Its useful for certain web sites.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...