Spread the love! TechSpot Tech Gift Shortlist 2017

Installing Linux for the first time (& dual boot)

By svtcobra ยท 340 replies
Feb 20, 2002
Post New Reply
  1. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Some people like to do what you describe and have LILO call the NT boot loader.... I like it the other way round. I can post how to change this if anyone likes.
  2. Ai Hate

    Ai Hate TS Rookie Posts: 302


    how should the "updatedb" command perform?
    the story's like this...
    since the official drivers for the KYROII are out (.rpm), i decided to give that Red Hat 7.2 CD under my bed another shot.
    installation is fine, but i still have the same problem configuring X windows as i've stated before. i guess it's because there's no driver for the KYROII listed, so i tried installing the drivers.
    now, i've already d/led the .rpm driver for my KYROII. since i'm not sure what the floppy drive is called (like harddisks are "hdX" - therefore i can't mount it), i copied the files on to my C drive (win2k). i mounted the drive fine. but i can't install the .rpm files. correct me if i'm wrong, but the command to do this is:
    rpm -i /mnt/win2k/kyro.rpm
    right? (i've renamed the .rpm file to sth shorter through windows) anyway, it says it can't find the .rpm file or the path is wrong. so i tried the find .rpm command (can't remember what the command was, but i have it noted down back home).
    anyway, when i used that command, it told me to run "updatedb" first. so i ran the command.
    the problem is that when i typed:
    then press [enter], nothing happens. my screen'll look sth liek this:


    where the underscore is a blinking cursor. i can type anything into it, but nothing happens. if i press [enter] again, it'll come down one line. i'm not sure if it's crashed or anything, but i could still press ctrl-alt-del to reboot.
    my question is, is this how the updatedb command should behave? i've waited for about 10 mins, but it just stays there blinking.
    or am i doing sth wrong?
  3. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    the updatedb command catalogues all files on your mounted drivers, and puts them into a locate database.

    even on a powerful machine, this can take time....

    the purpose of this is that you can say

    locate file

    where file is something you'd like to know the full path of.

    I have never renamed an .rpm and I'd do all your linux downloading, untarring, file operations in Linux if I was you.
  4. Ai Hate

    Ai Hate TS Rookie Posts: 302

    the prob is that i can't even get linux up and running :(
  5. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    did you manage to get a graphical install or was it text based??
  6. henderrob

    henderrob TS Rookie

    dual boot

    I'd be very interested in seeing this,
  7. Ai Hate

    Ai Hate TS Rookie Posts: 302

    graphical install
  8. Ai Hate

    Ai Hate TS Rookie Posts: 302

    hmmm... some how, i managed to get the GUI to run at 320x200 pixels again (AGX)... now, how can i install the rpm driver from here? or maybe i should ask, "can i install?", cause the screen's so small, it can't even show the whole search window (yes, i've resized it to 0x0)...
    and it seems like linux won't detect my floppy disk that contains the rpm file.
  9. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Ai Hate, you might want to umount all non-Linux partitions before running updatedb. It shouldn't take too long, maybe a few minutes if you have some hundreds of thousands of files. By default it doesn't tell you anything, just scans the files and returns to the command prompt. If you don't see any disk activity, it might have stopped responding. You can quit it by pressing CTRL+C, if that doesn't help, open a new terminal (for example, ALT-F2) and type killall -9 updatedb.
    If rpm command says it can't find the rpm file, there's nothing wrong with rpm command, it just can't find that file. In Red Hat 7.2, floppy drive is usually mounted with mount /dev/fd0 /mnt/floppy.
  10. Ai Hate

    Ai Hate TS Rookie Posts: 302

    yeah, i've finished updating the database, and so it says i have a mail.

    hehe. fd0? i just tried guessing with fd1, fda and nothing. and when i used fdd, it gives me some errors and stuff. freaks me out. :p
    so after i mount the floppy disk to /mnt/floppy, i use the command:
    rpm -i /mnt/floppy/powervr.rpm
    then why can't i use:
    rpm -i /mnt/win2k/powervr.rpm
    in the first place, since the rpm is in C: (root)?
    or is it that linux can't read FAT created by windows?

    one question about the floppy disk. when i managed to get my way around a linux running GUI at 320x200 pixels, linux won't read the disk i have my rpm in. it would just come up with a blank. at first i thought it's about mounting, but then it can read my linux boot disk. (i created the shortcut to the floppy disk by right clicking the desktop and blah blah blah)
    i thought the problem was that it can't read a windows fat file, so i tried to format it with gdisk (yes! i found it! under 320x200!!!), it comes up with an error message (no, i can't remember the message as it's written down back home)...

    and some wierd thing about the Xconfigurator i thought i'd mention...
    ok, in Xconfigurator, it lets you choose the display adapter, then the monitor, then ask you to probe, then lets you choose the memory, and the clock chip (or sth?), then probe again, right? here's the problem. when it asks me to probe for the last time, if i chose other than the AGX or S3 sth (the first choice when choosing the display adapter), it won't let me choose the resolution in which to probe. but if i chose, let's say, AGX, after i click probe, there'll be another screen with the resolution settings. here's the problem: if i choose a color depth at 16bit or 24 bit, the screen will flicker and says there's an error with my settings (like when i choose sth other than AGX and S3). but if i choose 8bit color, no matter at what resolution, Xconfig'll test my screen at 320x200 pixels (it told me when asking me "can you read this? yes/no). then, it'll say Xconfigurator is completed!
    of course, then if run startx, it'll load up at 320x200 pixels. at 8 colors, i think. making the GUI almost (if not completely) unusable. i mean, i can't even see some windows in full (i've resized it to 0x0)!!! hahaha :haha:

    anyway, i'll try what you said and post back.
  11. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    cat /var/spool/mail/*
    It's usually just a daemon of some sort logging things.
    Remember that Linux is case-sensitive. Try hitting "Tab" if you don't remember the filename. Can you actually see the right files & directories in /mnt/win2k?
    Unlikely, but possible. I've noticed that Linux & BeOS have no problems reading FAT partitions unknown to Windows (like some LBA32 FAT partitions).
    Did you remember to umount the old floppy first?
    Usually there's no need to probe settings. "No clockchip" is recommended, is it not? And you should know how much RAM you have in your card. Maybe you can't choose the resolution because your driver (standard VGA?) has only one.
  12. Ai Hate

    Ai Hate TS Rookie Posts: 302

    after using updatedb, i tried "locate powervr.rpm", but it doesn't do anything. it looks like this:
    [BASH]locate powervr.rpm
    where the underscore is the blinking cursor. so i really don't know if it worked or not.

    wait... i'm really confused with this mounting... must i unmount everytime i change a floppy?
    ok, here's what i did...

    when i haven't got into the GUI yet, and was trying to mount the floppy with my wild guesses, i got an error from mounting fdd.
    then i got into the GUI, and put in the floppy with the rpm file (formatted in windows), and it can't read the floppy.
    then i tried the linux boot disk, and it worked. i can see the files in the disk.

    when did i forgot to unmount?

    yes, i used "no clockchip", and chose my memory at 64mb.
  13. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    It did work and it didn't found powervr.rpm. Most Unix commands don't have verbal diarrhea :)
    Yes, otherwise the system thinks it's the same floppy in the drive as before changing.
    Hmm, if I had a floppy drive I could check if the boot disk is mounted during startup. If it is, you forgot u(n)mount it before ejecting it (you did eject it before putting a new one in the drive, I assume ;)).
    General rule: Always unmount a storage medium before changing it.
    New kernels actually lock CD-ROM trays so that you don't accidentally change the CD while it's still mounted, a feature that could be useful in floppy drives too. Macs do this, x86s don't..
  14. Ai Hate

    Ai Hate TS Rookie Posts: 302

    ok. installed the rpm, thanks to your help :)
    now, when i finished installing the rpm, it says "refer to the readme". ok, so i read the readme (in windows).
    it said that after i install the rpm, i must run a program called "sax2", found in system>configuration. now, the problem is that i can't find sax2. in sax2, i'm supposed to tell linux to use the kyro drivers and set the display setttings, blah blah blah, it's all in the readme, but i can't find sax2 on my system.
    i tried clicking on everything with "system" in linux (running in 320x200 GUI), but i really can't find it. i tried looking at the program list from "Run...", but again, there's no "sax2". so i just tried typing "sax2" at BASH, but again, no luck. in the readme, it doesn't say anything more than that. so is there an alternative program to tell linux to use the drivers?

    about sax, i read this site but am still confused about what it is (hehe. i'm no tech whiz anyway :p )
  15. ryejay98

    ryejay98 TS Rookie Posts: 41

    Quick question regarding the install as I've never done this part before ...

    Right now, due to it being a new OEM computer, my 40gb HD is installed as one big NTFS partition for WinXP. I would like to install RedHat linux onto this partition as well ... how well does Disk Druid resize parititions? Does it even work with NTFS? Whats the best way to do this?
  16. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Just in case you missed this, Phantasm66
  17. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Okay, here is what you do.

    Boot Linux.

    Uninstall lilo with this command:

    /sbin/lilo -u

    Now open /etc/lilo.conf in a text editor, it looks like this:



    Well, it will look like this if you have it installed on hda6, which is what I will use in my example.

    Now edit /etc/lilo.conf so that it looks like this:



    The important change is the boot= line, which instead of reading boot=/dev/hda now reads boot=/dev/hda6, meaning install lilo to the first sector of / rather than the MBR of the first disk.

    Now reinstall lilo like this:


    now take an image of the lilo code that's written into the bootsector of / like this:

    dd if=/dev/hda6 of=bootsect.lin bs=512 count=1

    This will create a file in your present directory called bootsect.lin

    copy this file to the root directory of c:

    Now boot to windows, and open boot.ini in notepad after removing its read only property.

    Append this line to the bottom:


    Save boot.ini and reboot, you will now find that Windows 2000's bootloader comes up first, and if you choose Linux it will start lilo and boot linux.

  18. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Disk Druid resizes partitions well but it doesn't preserve data ;). For non-destructive NTFS partition resizing, I know only one application - Powerquest's Partition Magic. FAT partitions are much easier to resize (even without destroying data), there are programs like Fips or Parted.
  19. ryejay98

    ryejay98 TS Rookie Posts: 41

    Thank god for multiple HDs :) then ...

    I gave up on Mandrake due to the dumb mouse error. Guess I'll just go with RedHat 7.2 and update the apps myself.

    Anyone ever use Sorcerer? Cool little distro to learn how to do things without the candy coating that seems to be on all the other distros. Plus you compile it with your specs, optimizing the system.
  20. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    My guess is that this sax2 is just a GUI for the same thing nVidia users do - edit /etc/X11/XF86Config-4. You should change the driver in Section "Device" to what's your driver called. Doesn't that readme say what to do if there's no sax2?
  21. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    He should just use

  22. fredericklee

    fredericklee TS Rookie Posts: 34


    My system is running on win xp on C: which is my 1st harddisk primary partition and win 98 on D: which is my 2nd harddisk primary partition.

    I wish to install Red hat 7.2 on E: which is my 1st harddisk extended partition. The problem is that when I tried to install it, I encounter a few problems and they are:

    When I choose to "Manually partition with Disk Druid." a message prompt came up after I click on next.

    What is wrong?

    But neverthless, I still click on ignore to proceed. After putting a mount point on my 1st harddisk primary partition as /mnt/windows xp , I now click NEW and change the file system type to SWAP and selected my first harddisk which is hda. Do not know whether I need to change the size to 512 or just leave it as 1? But anyway, I tried both and when I click on OK, an error prompt pop up that says:

    What is wrong? I could not procceed anymore.
    Please help.
  23. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    So you've already created a FAT/NTFS partition E:? There should be an empty partition, or even better, just blank space. Are your hdd's set to use LBA?
    I'm not sure what you mean by "putting a mount point as /mnt/windows xp"..
    Try the following:
    Create a new partition, named /, set its size to be "maximum available". Then create a swap partition, set its size to 1-2 x your RAM.
  24. fredericklee

    fredericklee TS Rookie Posts: 34

    My E: is FAT32. How do I set my hdd to use LBA??:confused:

    I have followed what phantasm66, but instead of /mnt/winxp I use /mnt/windows xp

    Where do I create this new partition, named /?? At C: or E:??:confused:

    How to set the size to "maximum available", The size come in numbers with up down arrows for you to increase and decrease the value in numbers. I have check that the maximum nuber it can go is to 2076. So If I'm use 512MB of RAM, I should set this to 1024 right?
  25. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    You set this in the BIOS. Its a hard drive geometry. If you change it, you will have to delete all partitions on that drive, change in the BIOS, and then recreate partitions again.

    LBA means logical block addressing.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...