Installing Linux for the first time (& dual boot)

By svtcobra ยท 340 replies
Feb 20, 2002
Post New Reply
  1. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    OK MintabiePete, I am not sure exactly what you have done, but something I would be thinking about is trying the install again, and making sure that you have read everything carefully.

    But to be able to help you a little, try this:-

    cat /etc/fstab

    once you have logged on as root. write down what you see on the screen, and post it back here.
  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Don't forget that you're in the Unix world now, DOS commands won't work. For example, instead of dir, Unix has ls and so on.
  3. MintabiePete

    MintabiePete TS Rookie

    Thanks for taking the time phantasm66, and as requested:

    Red Hat Linux release 8.0 (psyche)
    kernel 2.4.18-14 on an i586
    localhost login root
    last login:mon may 12 12:17:15 on ttyl
    [root@localhost root]# cat /etc/fstab
    LABEL=/ / ext3 defaults 11
    none /dev/pts devpts gid=5,mode=620 00
    /dev/hda1 /mnt/winxp vfat defaults 00
    none /proc proc defaults 00
    none /dev/shm tmpfs 00
    /dev/hda3 swap swap defaults 00
    /dev/cdrom /mnt/cdrom iso 9660 noauto,owner,
    kudzu,ro 0
    0 0
    /dev/fd0 /mnt/floppy auto noauto,owner,
    kudzu 00
    [root@localhost root]#

    I hope I have everything right as I had to copy it longhand:) and it was in 3 columns but comes out different when I post it
  4. MintabiePete

    MintabiePete TS Rookie

    I have installed again and after logging on as root gave the command startx and get the following error page.

    reporting problems
    build operating system : linux 2.4.18-11 smpi 686 [ELF]
    build host: daffy.
    module loader present.
    os kernel: linux version 2.4.18-14 ( version 3-2 20020903)(redhat linux 8.0 3.2-7))#1 wed sep 4 11:57:edt 2002
    markers:(--) probed,(**)from config file,(==)default setting,
    (++)from command line,(!!)notice,(II)informational,
    (ww)warning,(EE)error,(NI)not implemented,(??)unknown
    (==)log file:"/var/log/xfree 86.0.log,"Time:tue may 1305:38 2003
    (==)using config file: "/etc/x11/xf86 config"
    (EE)no devices detected

    Fatal Server Error
    no screens found

    x10:fatal IO error 104 (connection reset by peer)on x server :0.0 after 0 requests (0 known processed) with 0 events remaining.

    hope you can understand it , miss the copy and paste tools where you know tht everything is correct:)
  5. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    you have a misconfigured X server. when i get time i will post how you fix this. all that's the matter is that you are not getting the graphical user interface.
  6. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    You could try xf86config. Your profile doesn't tell which gfx card you have..
  7. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    I think there isn't Xconfigurator or XF68Config in Red Hat 8.0, I think it uses something like redhat-config-display or something, if used in text only mode. You could try editing the config file by hand, but i don't recommend that for a newbie.

    when you install, and get to the graphical setup bit, do you REMEMBER TO TEST THE CONFIGURATION??? Install again, this time make sure you get a working desktop display before you move on from that section of the install.
  8. MintabiePete

    MintabiePete TS Rookie

    when I was installing it gave me a test box for the different config of the window , I set it as 800x600 and it picked up my video card as s3trio64v2 and my monitor as IBM P50 so I would have presumed it worked .

    But a question, does it show it worked in that little box or should it show it as full screen ? which is doesnt , I am not sure with this .:confused:
  9. MintabiePete

    MintabiePete TS Rookie

    installing Red Hat Linux 8.0 is certainly getting easier , and as far as I know I am following the instructions to the "T" but seem to have problems with the monitor configurations .

    I have tried what comes up which is a s3 trio 64v2 4mb video card with the monitor which it seems to recognise IBM P50
    and no go , I have then reinstalled and tried all the generic monitors with no luck , I know that my monitor horiz scan range is 30.0 - 69.0 khz and vert refresh range is 50.0-120.0hz
    and have set it at 800x600 @ 60 hz

    I have used the command xf86config command and have changed settings keeping within the guidelines with no luck

    Have come to the conclusion that maybe my computer is just too old , Monitor built in april 1997 but it handles XP in windows OK , so I just dont know . Everything seems to be OK except the display and yet it handles the bootloader screen ok , but wont go into the graphic to boot up .

    Is getting a bit later here , I will have to shut off the generator and hit the sack for the night and try tomorrow night.

    Hopefully I can get some help with something that I have missed.
  10. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    I am afraid all I can suggest is continuing to attempt to configure the X server properly. You need to try different card and monitor configurations. try standard montor, etc. Good luck.
  11. MintabiePete

    MintabiePete TS Rookie

    yeah eventually got it running OK , the monitor was OK the problem was the video card configuration , have experimented a few times but is late now will keep trying and try to understand this system a bit better , thanks for the encouragement, I ended up taking Red Hat 8.0 off and putting Mandrake 8.0 on which did most of the configeration and put me on the right path .:) but have since put Red Hat Linux 8.0 back on .
  12. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    glad you are making some progress. if possible, I would try red hat 9 which is a great improvement IMHO.
  13. darkdan

    darkdan TS Rookie

    Dual Booting Mandrake and winxp pro

    Ok, here's my scenario:

    I've finally decided to take the plunge, and give linux a try. Actually, a while back I had installed redhat and had it working for a bit...but after all the countless hours of trial and error (lots of the latter..) I gave up. Well, filled with a desire to stop using windows I have to decided to give linux another shot.

    First off, I have chosen Mandrake because of some of the good things I've heard about it. My question is, for a newby like myself, is Mandrake better or redhat?

    Ok, onto the real question. I want to know how I can install mandrake 9.1 and dualboot either mandrake or windows. I have 2 main partitions as of now. On my 40gig WD 7200 rpm drive, I have a 10gig windows partition and the rest (27.3 gigs or so) is devoted to files..mp3, warez (oops) etc..can anyone point me to a tutorial or guide that explains installing mandrake with winxppro WITH winxppro already being installed (i recently formatted and want to avoid doing so for a while)

    As always, any help I receive is greatly appreciated.
  14. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Mandrake or RedHat would be good. You would be good with either. Mandrake maybe for you would be nice for now.

    As regards your second question, follow my guide which is available at the start of this thread as closely as possible. I would work on a partitioning scheme a little like this:-

    10GB Windows XP
    10GB Linux
    2GB Linux SWAP
    Remainder Data drive (for mp3s, etc) format as FAT32.

    If you read my notes, which as I said are available at the start of this thread, I explain how to do all of this. The instructions are easily adapted for mandrake.
  15. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Re: Dual Booting Mandrake and winxp pro

    Phantasm66 seems to prefer Mandrake, I prefer Red Hat 7.3, not newer :)
    So, you'll need to resize your partitions and don't want to lost data?
    P.S. Welcome to TechSpot forums!
  16. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Actually, right now my favourate Linux is Red Hat 9.

    Red Hat 7.3 is good for servers. Lots of security holes have been fixed. But I would upgrade to the latest kernel, and maybe download latest apache2, php, mysql, etc and build from source if trying to build a secure server using this linux. You can also use Red Carpet from XIMIAN GNOME with this version of Red Hat, which will easily keep you up to date with the latest bug fixes and security patches. That's important for a live server.

    But as far as workstations go, I would use Red Hat 9, Mandrake 9.1, or maybe SUSE, whatever the latest version of that is.
  17. darkdan

    darkdan TS Rookie


    Hmmm, are you saying that this won't work if we already have more than one existing partition?...I went and got partition magic, and resized my files partition leaving now leaving 10 gigs for windows 10 for linux (including swap file) and the rest for files...basically the remaining 10 gigs or so shows up as "unallocated".

  18. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Re: Hmmm

    No, I am not saying that. Although I can understand why you made the confusion.

    I recommended this strategy because the user was (as far as I can recall) fairly inexperienced with disk partitioning. I was urging them to ensure that their target disk area for linux was unused disk space, and ensuring that they did not already have an unformatted partition in that target area, which would have confused the instructions.

    I can understand your confusion, though.
  19. darkdan

    darkdan TS Rookie


    Wow, perhaps I am just lucky, but I am writing this post using Mandrake 9.1
    I didn't notice any problems with the installation , and upon rebooting lilo immediately came up and gave me a few choices ...linux-secure, linux, windows (which I haven't tried yet) and some others that I can't remember. I chose KDE as my environment. Now, it's time to start learning..i'll post later on how I'm doing.

  20. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    No, you are not lucky, you are just sensible and you followed instructions properly.

    KDE puts the user closer to the system controls than GNOME, so its a good place for you to start.

    The other options in LILO are booting your kernel or another similar kernel with various options. There is no need to choose anything else here other than the default, I doubt that you would notice a difference in some cases anyway.

    I hope you have fun using Linux. If you are not too familar with UNIX commands, try to get a small book on them. Using the command prompt is the key to mastering Linux, as the graphical interface is still fairly young, and much less mature than what you get with Windows. But the underlying technologies are, in MANY CASES, so much better engineered and thought about than the Microsoft world. Linux is a fascinating place to inhabit, however I would caution that it is also tiresome and awkward at times.

    I have been into Linux for 5 years now, and there are so many things I still can't do. It will always be that way, I guess. But if you keep reading and keep learning, you will get there. Some UNIX is truly mind bending and something I feel a lot of you here would benefit from trying.
  21. darkdan

    darkdan TS Rookie

    Few questions

    Hmm, still no problems but I do have a few questions.
    #1 what is the best irc client for linux and where do you guys hang out?
    #2 How do i log in as root (from command prompt)?..I've searched around for a tutorial on shell access etc..but everything seems a bit over my head. Something that explained it step-by-step would be very helpful.
    #3 How can I access my F: drive from linux? My F drive is all my files and is mounted as files
  22. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    1) X-Chat. It should already be installed. There is a #3dspotlight channel on starchat.

    2)If you are logged in as a regular user, and wish to do something as root, open terminal window and type "su" the give the root password.

    3)If your drive is mounted in linux, change directory to that mount point. Like if you mounted it /files then cd /files and it should all be there.
  23. darkdan

    darkdan TS Rookie

    adding programs

    Ok, I just installed AIM on linux and got it working with no problems..what I want to know is how do I get it to where I can have it as a selectable item in my menu..i really don't want to have to type /usr/bin/aim everytime i wanna use it.

    Also, I noticed that mandrake did install the webserver package because I can access it via http://localhost ..I'm very pleased to see it comes with all the bells and whistles, BUT i don't know how to configure it. Meaning, where do I edit the configuration file and also where do I put the files for my site?
    The same question applies to the ftp server...where can I configure it?
  24. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    as regards adding things to the K menu, etc, look to the control centre thing.

    if you are using the apache web server (almost certain), then the config file will be something like this:-


    but also look for /etc/httpd.conf

    try the command

    whereis httpd.conf

    and see what you get. backup config files first before changing.
  25. darkdan

    darkdan TS Rookie


    Hmmm, well I compiled and installed xchat...but now I can't get it to run (rather I don't know how)..I installed the 1.8 version ...I downloaded and followed all the instructions..what now? :[


    also, ever thought of starting a #techspot channel on some network..I think it'd be cool to have a place where techspot users can gather and chat etc. :) Just a thought

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...