Intel DG45ID motherboard dead (solved)

Short version :-
I used a non compatible cpu which has the effect of leaving the board switched on.

Long version :-
I bought the DG45ID off ebay and got a 775 CPU to go in it.
I switched on......the fan worked and HDD was active but no screen.The
USBs were active.When I switched off at the mains.When I switched on
it powered up without the start button.
I realised I had a non compatible cpu.I bought an E2140.
The first time I switched on at the mains it came on (without the start button)
but subsequently I had to press start to power the board (ie as normal).

CMOS jumper.
When I bought it the jumper connected pin 3 with the LED pin.
I assume that is like a removed jumper......ie BIOS flash mode.
Hence, when I connected a DVD drive it crashed.I assume it was looking
for a .bio file.
Nothing I could do would recover the board.The green standby light came on
but nothing else.It was dead.No USB power,no fans ,nothing.

I remembered the wrong CPU that had left the board "switched on".
I put it in and it behaved as before....power but no monitor.
I then replaced the E2140 and hey presto I was in.......but only
on cmos recovery......there was no bios.But the USBs were active.So
I removed the jumper,flashed the BIOS from a USB stick and it's up and
running.

NB. the intel manual is wrong regarding the CMOS pins.
It shows pin 1 closest to the battery.That is actually pin 3.
If you look...(I can't post the pdf link)

page 52 the pin 1 is clearly show closest to the battery.
I thought it was strange that all the images on Google show the jumper
on pins 2,3 furthest from the battery (the manual says that is the recovery position)