Intermittent 'No Bootable Devices' message after clean WinXP install

By zestfester ยท 5 replies
May 17, 2011
Post New Reply
  1. I have just done a clean re-install of WinXP SP3 ('slipstreamed' WinXP SP2 Install Disk with SP3) on my Dell Inspiron 1300 & now have intermittent 'No Bootable Devices' message on boot. When I have message & enter setup, Primary Hard Drive = {none}. Only way I've stumbled across to avoid is to reboot using WinXP Install Disk, F3=Quit & this seems to work for a while (note: then Setup shows Primary Hard Drive = my main HD). All I've installed so far additionally are drivers (as per Dell list, except one that failed so found online), Norton Internet Security 2011 & Windows Updates. Note: don't think I ever had this message prior to WinXP install (had PC about 5 years). Any ideas?
  2. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Did you follow this guide to install the Dell System Software before anything else?

    If you did then my next suggestion would be to test your hard drive, follow this guide.

    The error you get is because the system cannot see the boot sector on your hard drive. Being an intermitent fault would suggest a bad connection on the hard drive connector. Try removing the drive (power off and remove the battery first) and then refit it which will reseat the connection.

  3. zestfester

    zestfester TS Rookie Topic Starter

    Mark56, thanks for advice. I did follow Dell guide with 1 issue that the Modem Driver install failed (tried twice) - but it doesn't seem like that would be related. I did wonder if I made an error during WinXP install. In one article online ( it says:

    At this stage it will ask you to press F6 if you want to install a third party Raid or SCSI driver. If you are using a an IDE Hard Drive then you do not need to press F6. If you are using a SCSI or SATA Hard drive then you must press F6 otherwise Windows will not detect your Hard Drive during the installation.
    I've just checked my HD & it is a Samsung MP0603H, where interface is described variously as UDMA100 / Ultra ATA-100 / ATA-7. Do you know if this relates to IDE or SATA? I think it unlikely that it is really a hardware fault as it coincides with the WinXP reinstall.

    One further point... I used chkdsk to see if any errors (but I didn't see results as they flashed off screen too quick!) and now I get message: "Error loading operating system" on bootup.

    Not yet run Samsung diagnostic as you advised.

    What do you recommend next?
  4. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    If you had installed XP on a SATA drive it would Blue screen as soon as you booted and most likely would not have let you install it. ATA is a form of IDE.

    Please run the Samsung diagnostics to confirm that your drive is OK, then we can move on.

    To get the error you have received on a new install does suggest a failing drive.
  5. zestfester

    zestfester TS Rookie Topic Starter

    the more I think about it the more it makes sense that the drive is on the way out (installing Norton Security 2011 / Utilities & running registry cleaner seemed to mess it up & cause massive disk read/write that meant it kept 'freezing').

    In terms of Samsung tool, I tried to make a disk but it didn't work... just to check, there are 2 files:
    ESTOOL.exe is the program that should be on the disk?
    ESTOOL301v.iso is the 'image' file to make it bootable?

    I first used ISO Image Burner but I don't think this puts .exe on & old laptop I'm using doesn't have CD writing software, so I switched to use ImgBurn, which I only just used for first time to slipstream WinXP SP3, but I must have done this wrong as pc didn't boot from the disk. Any chance you could talk me through it in more detail (sorry for my lack of pc prowess!).

  6. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    All you need to download is the (at the bottom of the page) extract the ISO file and burn that to a CD with an image burner. The .exe file is for a floppy disc.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...