Issue with Hamachi installation

By Kagamex ยท 27 replies
Sep 30, 2012
Post New Reply
  1. I've been searching for a solution for a few days now, I've browsed through countless of threads everywhere, and no one seems to have the same problem as me. I've even searched through all Hamachi related threads on the Swedish tech forum I daily visit.

    So here's the deal; about 1 year ago I uninstalled Hamachi from my computer (don't ask me why) and lately I wanted to get it again. So I downloaded the hamachi.msi installer from the LogMeIn website, ran it; and got the message that an older version had been found on the computer and asked if I wanted to update it. I clicked no, which caused the installation to turn off completely, I started it again and clicked yes this time, which caused it to proceed with 5/6 of the installation before shutting down and giving me the message saying that it couldn't be installed and that no changes had been made to my system.

    After this, I started googling around, I found that if you deleted all logs and registry entries connected directly to hamachi it would work. But as always when it comes to me and software, it didn't. Now, when I try to install it gives me the message; "LogMeIn Hamachi Version [PREVIOUSVERSION] has been on your computer. Would you like to proceed with an update?". Just like the last time, when you click no it shuts down completely, and when you click yes you get the message saying that it couldn't be installed and that no changes has been made to the system.

    Here's a guy who seems to have the same problem with his Hamachi installation, but his solution doesn't work for me:

    System Specs

    Windows 7
    AMD Athlon II x4 640 @ 3.3 GHz
    Gainward GTX560
    Fractal Design Tesla 650W
    Gigabyte GA-870A-UD3 Rev 2.1
    Western Digital 7200 RPM 64MB 1TB

    A little offtopic.. How do you change the text so that 10% of it doesn't randomly get reduced to a small font?
  2. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    Try full UNINSTALL, reboot and then install fresh copy
  3. Kagamex

    Kagamex TS Rookie Topic Starter Posts: 17

    I'm guessing you mean a full uninstall of windows? ;)
    So there are no simpler means of solving the problem?
  4. bobcat

    bobcat TechSpot Paladin Posts: 688   +67

    Obviously, the previous version has not been fully uninstalled. Try Revo Uninstaller Pro which in my experience has best chances for a full job. Follow the procedure for forced uninstall. If you don't want to buy it, you can get it on a free trial.
  5. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    I'm pretty sure he meant Hamachi, the subject of your post.
  6. Kagamex

    Kagamex TS Rookie Topic Starter Posts: 17

    Ah well, I thought people would understand that it's already uninstalled since I even cleaned the registry of it, but nvm, my mistake.
  7. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +242

    As BobCat posted. You might want to try this program, (Revo). Just because it is out of the registry. Dose not mean it is already uninstalled. It could have left a few files. Which very well be causing your problems.
  8. Kagamex

    Kagamex TS Rookie Topic Starter Posts: 17

    I ran the forced uninstall tool with the keyword LogMeIn Hamachi and found 10 files, removed all of them, rebooted, still the same error. After the reboot and failed attempt to install I ran the tool again and found no files. Any other ideas?
  9. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +242

    My guess there is still something in there pertaining to the program. Where at hard to say. You may have to do a manual search for a dill or file.
  10. Kagamex

    Kagamex TS Rookie Topic Starter Posts: 17

    How thorough should I be? I've looked everywhere but in the windows folders and I've found nothing so far.
  11. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +242

    There may be a hidden file. Other then that I can not think of anything else at this time. Hopefully someone else may have a good suggestion.
  12. Mavrickx888

    Mavrickx888 TS Enthusiast Posts: 64   +9

    I know you said you have uninstalled the application and that may render this tip obsolete, but it could be worth a quick look; Check your Network Connections/Adapters and see if Hamachi's virtual adapter is still there. I've had an issue in the past uninstalling Hamachi where I couldn't get it to properly uninstall until I went and manually disabled the network adapter. You also might want to check to make sure there are no active services installed/running and that the Hamachi drivers have all been uninstalled in Device Manager (Should be under Network Adapters) as they could prevent a proper uninstall/reinstall.

    If you're still hitting a wall, you could try turning on Windows Installer Logging, which will log the progress of program installations (Specifically .msi). This may give you a better idea of where to go next. For instructions on how to turn on Windows Installer Logging, go here:
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    This is a shot in the dark but worth a try..... Logmein uses the Windows Installer. So, use Windows Group Policy to enable Windows Installer logging. Then try again and look through the Installer log file. Maybe it'll leave a hint of what's going on

    1. Click Start->Run, enter gpedit.msc. The Local Group Policy editor should open
    2. Under Computer Config click Admin Templates->Windows components->Windows Installer
    3. Then in right pane, double click Logging. Activate all the logging options.
    /* Edit */
    just realized someone above also mentioned Installer logging. Tho easiest/best to use the Group Policy editor for Win 7

    Good luck. Hope it might show something useful
  14. Darth Shiv

    Darth Shiv TS Evangelist Posts: 1,811   +472

    You can also use "Process Monitor" to see which files and registry keys are being accessed by the install so you will directly see where it hits.
  15. Kagamex

    Kagamex TS Rookie Topic Starter Posts: 17

    Apparently "run" can't find gpedit.msc, I've also tried to delete the virtual adapter; which didn't work. :)
  16. Mavrickx888

    Mavrickx888 TS Enthusiast Posts: 64   +9

    Most likely you're running Windows 7 Home or Starter which don't include the Local Group Policy editor. While a bit more tricky, you should still be able to activate Windows Installer Logging from the registry (See my previous post).

    When you say that you've tried to delete the virtual adapter, does that mean that the Hamachi adapter shows up the Network Connections and/or Device Manager? If you still see it in Network Connections, try finding the adapter in Device Manager under Network Adapters. It should be called Hamachi-something-or-other. You should be able to right click on it and select Uninstall (If it gives you an error about it being in use or something, try doing it in safe mode without networking enabled). If you're able to do all that, then I would try reinstalling it again and see if you can get it to go. If not, try the Windows Installer Logging and see if that can shine a little light on things.

    Also, it appears that Hamachi dumps an install log of its own in the temp folder (Type in %temp% in the start menu). I don't know if it will still dump the log if the installation failed, but it may be worth looking into.
  17. Kagamex

    Kagamex TS Rookie Topic Starter Posts: 17

    Oh, I've already removed it from the Device Manager, that's kind of what I meant :p. And now that you mention it, it has been a while since I cleaned the temp folder, I found 1.84 GB of crap in it.. Gonna see if this solves anything.
  18. Kagamex

    Kagamex TS Rookie Topic Starter Posts: 17

    I created that Installer key and set the value of the Reg_SZ to voicewarmupx as the guide told me to. After that I ran the installation, but I can't seem to find the log file.
  19. Mavrickx888

    Mavrickx888 TS Enthusiast Posts: 64   +9

    Hmmm... it should be in the temp folder (%temp% again) under a randomly generated name. For instance, the one generated for me was called MSIfeb8a.LOG, but they should always start with "msi" and should always end in .log.

    If you can't find that, try finding the Hamachi installer log also located in the temp folder (Should be called HamachiSetup.log) and take a look inside. You could post the contents of the log as well if you're comfortable with that and it's not too lengthy.

    An obscure question that may yield some results; Do you happen to remember what version of Hamachi you had installed in the past? Do you know if it was Version 1 or Version 2?
  20. Kagamex

    Kagamex TS Rookie Topic Starter Posts: 17

    I have no idea which version, but I know it was a fresh download sometime during the late summer of 2011.

    As for the log files, I found the log files in the specified folder. Two of them said the same thing the error message says when you're done with 5/6 of the installation;"the older version of hamachi cannot be removed, please contact your technical support group".

    The other file says;
    searching previous config & install ..
    SearchVersions - ui language is 'sv'
    GetRegValue - RegOpenKeyEx 'Software\LogMeIn Hamachi' failed (2)
    GetServicePath - OpenSCManager failed (5)
    checking file 'C:\Users\User\AppData\Local\LogMeIn Hamachi\h2-ui.cfg'
    SearchVersions - H1 config not found
    selected language is: sv
    selected language is: en
    setting language features ..
    searching previous config & install ..
    SearchVersions - ui language is 'sv'
    GetRegValue - RegOpenKeyEx 'Software\LogMeIn Hamachi' failed (2)
    GetServicePath - OpenSCManager failed (5)
    checking file 'C:\Users\User\AppData\Local\LogMeIn Hamachi\h2-ui.cfg'
    SearchVersions - H1 config not found
    selected language is: sv
    selected language is: en
    setting language features ..

    I've tried installing in both swedish and english, both seems to end with the same thing.
  21. Mavrickx888

    Mavrickx888 TS Enthusiast Posts: 64   +9

    Interesting... I'm speculating here, but based on what it's saying (Where it says "failed" next to GetRegValue, GetServicePat, etc.), it looks like you have indeed gotten rid of everything you possibly can when it comes to Hamachi. Why it's still saying you have a previous version installed is beyond me.

    Here's another complete shot in the dark:
    Try installing with this installer: (Version, released Nov. 9 2009)

    It best matches the date of when you think you installed it. I know it says 2009, but it was the most current version as of summer 2011.

    The basis of my thinking is that maybe the newer versions of the Hamachi installer can't completely detect where the older versions of Hamachi reside and/or cannot completely uninstall previous installations. After doing a little bit of research, just about everyone around the net with a similar problem to yours has one thing in common: they are trying to reinstall Hamachi where the previously installed version is old (Usually around 1+ years). I know this seems unlikely (Seeing as the actual installer probably changes very little from release to release), hence the "complete shot in the dark" statement, but I'm hoping to prevent the seemingly inevitable solution here... reformat.

    If all of that doesn't work, my only guess is that we're focusing on the wrong culprit here. Maybe it's not the installer that's the problem, but something else entirely. However, I'm fresh out of ideas at the moment...
    Kagamex likes this.
  22. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Here's another idea you can try. Install Regscanner 32 or 64 bit version as appropriate for your Windows installation. (IMO best - and fastest - registry scanning tool I've found :) )

    We'll search the full registry for either words Logmein Hamachi and also any references to that product's Windows Installer ID.

    Scanning for the ID
    > Open Regscanner.
    > Copy/paste the Windows ID below as the Find String
    > Set Matching to "Exact Match"
    > Check all Look At boxes to look at: Values, Data, Keys and Search Unicode values
    > Check Scan the following base keys then click on each base key so they're all highlighted
    > Now click OK
    > If anything found, click Ctl-A to select all the registry items found. Then Ctl-S to save. And be sure to change Save As to "Tab Delimited Text". Don't delete anything. Just upload the file to your next post.

    Scanning for text
    > You can start a new scan by typing Ctl-N
    > Type Logmein Hamachi as the Find String
    > Set Matching to "Registry Item contains one or more words"
    > All the other values should be same as we did for above. Click OK. And report any items found (but don't delete anything)
  23. Kagamex

    Kagamex TS Rookie Topic Starter Posts: 17

    Really sorry about the late reply, been busy the latest weeks. Anyway, here's the file you requested. And a side note, I had to run what most likely is the 32-bit version because the 64-bit version gave me the error code "0xc000007b".

    Attached Files:

  24. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Not sure where this may lead us but here's a few more thoughts based on your scan.

    Here's one of the notable registry keys that appeared in your scan
    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{47E16407-05D3-4D2A-B2B9-C30700B7C2AD} Publisher REG_SZ LogMeIn, Inc. 2012-09-29 22:28:08

    This is the section of the registry containing Uninstaller info
    1. Do you still have LogMeIn installed? I'm guessing not...
    2. Note that Windows translates things like Program Names into internal IDs. It uses the internal ID to store data in the registry about the program. In this case the ID is 47E16407-05D3-4D2A-B2B9-C30700B7C2AD. LogMeIn is just a value of the key (Windows would use it to later display it to us humans rather then dispaly the internal ID).

    So do another scan this time searching for 47E16407-05D3-4D2A-B2B9-C30700B7C2AD and post the result. Don't remove the uninstaller key yet.

    References to that internal ID and LogMeIn text are also found under keys for VirtualStore. I googled VirtualStore Windows 7 and found this M$ KB. It mentions installation issues. See if any of it applies. Common file and registry virtualization issues in Windows Vista or in Windows 7. Though I'd also say don't delete any registry keys just yet but see if any other situation they describe may apply
  25. Kagamex

    Kagamex TS Rookie Topic Starter Posts: 17

    I searched for the "47E16407-05D3-4D2A-B2B9-C30700B7C2AD" ID and found nothing. Neither did I find anything concerning Logmein Hamachi in the VirtalStore folder.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...