Kingston 32GB Pen Drive


I have a problem with opening files from my pen drive. Actually I have deleted all my files from pen drive manually and after when I tried to open the pen drive contents its showing an error

"Please insert a disk into drive G:"

Please help me in resolving this problem.

I tried to rename the drive letter going to disk management but still its not working.

Is there any other method where I can repair or correct my pen drive to work.


Posts: 19   +5
Try using diskpart to format your flash drive.

  1. Open a command prompt (run as administrator).
  2. Type in diskpart and press enter
  3. Type in list disk and press enter
  4. Type in select disk x (substitute x with the corresponding disk number of your flash drive in the list) and press enter
  5. Type in clean and press enter
  6. Type in create partition primary and press enter
  7. Type in active and press enter
  8. Type in format fs=ntfs label=Kingston_32GB quick and press enter
  9. Type in assign and press enter
  10. Type in exit and press enter

I hope that will fix your problem.
when I connect my sony microvault 2.0 USM8GR pendrive to my laptop it shows pendrive with storage for 2 sec and immediately it goes of labelling fat32 instead of storage space. Iam using windows 8 and if shows scan and fix it but it didnt work. I tried the above method but when I type clean and enter, it says 'disk part has encountered an error: Incorrect function. See the system event log for more information'.
when I delete the drive leeter in disk management it shows helathy partition and when I assign drive letter it shows unallocated space and same problem . Please help me


Posts: 19   +5
I think there might be a possible compatibility issue with your Windows 8 USB controller drivers. You may try to plug your pendrive on to a different PC/computer to find out if you still experience the same problem when trying to format/reformat your flash drive.