Spread the love! TechSpot Tech Gift Shortlist 2017

LAN doesn't work on my Dell laptop

By gingin ยท 6 replies
Mar 10, 2011
Post New Reply
  1. I'm not a tech person so bear with me.
    The LAN connection worked fine fine up till a few weeks ago but now I can use the internet through wireless connection only.I tried turn off the wireless connection & connect the modem to my laptop using the LAN cable...didn't work. I used another cable (i thought the one I used before was faulty). It still doesn't work & I can't see the LAN symbol either. Is the LAN port broken or something? what should I do?
  2. mike1959

    mike1959 TS Evangelist Posts: 1,031   +54

    In your BIOS screens, look for 'On-board devices'. Click it open to expand the options, look for 'Integrated NIC', select that. Select the option 'enable'.
    Press F11 (save and exit). That should make the LAN icon appear in your taskbar, and let you connect your pc to the router via a CAT5E cable, and the 'net.
  3. example1013

    example1013 TS Enthusiast Posts: 265

    When did this stop working? Did it coincide with the set-up of the wireless connection?

    Also, a good idea would be to check the device manager. Right-click on "My Computer" ("Computer" in Vista/7), select "Manage", and in the Computer Management window go to the Device Manager. Then look under "Network Adapters".

    Right-click on your wired adapter and go to Properties, and make sure it says everything is working properly (under "device status" it will say "This device is working properly.").
  4. gingin

    gingin TS Rookie Topic Starter

    The Integrated NIC is already enabled.

    umm there are two kinds of adapter here?
    Broadcom virtual wireless adapter &
    Microsoft Virtual Wifi Miniport Adaptor
    In any case both the devices are working properly.

    The problem DID coincide during wireless setup.
  5. mike1959

    mike1959 TS Evangelist Posts: 1,031   +54

    Can you try; (in 'Search')
    then expand the 'components' line.
    then click on 'problem devices'.
    See if it shows up one of your devices as missing drivers or other problem.
  6. gingin

    gingin TS Rookie Topic Starter

    Just one device is showing up.
    RealTek PCIe FE Family Controller (Error Code: This device cannot start.)
  7. mike1959

    mike1959 TS Evangelist Posts: 1,031   +54

    Do you use Microsoft updates? If not, go to your 'All programs' then 'Windows Updates'. then in the left side of screen,' check for updates'.
    Or go to MS home page,',' Security and updates', 'Microsoft updates', 'check for updates'.
    Also I use a free program at; www.drivereasy.com
    If you download and install it, 'Scan' and find if any network drivers are missing.
    The program will produce a list. At top of list, entries in red are missing, next down, entries in orange need updating, last entries in green are ok.
    The free version of the program can download the drivers, but it's very slow (on purpose). So you can note the info, and go to the makers site to D/L the driver.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...