Keyboard / Mouse Logitech G502 mouse connection/recognition issues

Hi all,

So I got G502 today from an online webstore today.
I've been using a super old, 3 button, logitech back-up mouse since my G5 died.

I'll describe my procces thus far;

Plugged in G502 when computer was on. No sign of life, windows tries to install a driver, fails
Device manager lists the G502 under 'Other devices' with a yellow triange telling me no driver is installed.

Then went to to download the drivers and support software

LGS (LGS being the Logitech Gaming Software utillity that is the only downloadable support from fails to recognize my mouse, just the G15 keyboard I have

Tried the troubleshooting option of rebooting and re-installing the LGS, no dice
However the G502 does light up during booting up.

Booted the computer with the backup mouse unplugged and the G502 plugged in.
It works (cursor movement, left/right click, no advanced buttons) for +/-2 mins before going back to the 'Device fail to install' and the Device Manager placing it under 'other devices', etc

Plugged my backup back in, tried manually updating drivers in the Device manager, selecting it as a 'Mice and other pointing devices' type of device and choosing the drivers from 'LGS/drivers/LGSHidFilter' (tried all subfolders of 'drivers, but this one was the only one that held any .inf files the Device manager recognised as a good drivers.
Selected the g500 driver. No G502 driver was listed, only a G500s. It tried to install but gave the error 'Device could not start (code 10)'

After reading threads in the logitech forum, tried the FWUpdate (a firmware update for the g502) option, but installer tells me to connect my mouse before proceeding.
Even though my mouse IS plugged in. Plugging it in and out doesnt help

As for now, im at my wits end. I even tried borrowing someones g100 mouse and encoutered much the same issues.
All I can think of is to race from booting up with just the G502 plugged in to either the FWUpdate or the manual install from the device manager and see if the install goes through when it still works.
Seems rather unlikely and a silly way to go about things

I hope anyone with similar issues can help me out, any advice is super appreciated!

P.S. oh, using Win7 ultimate, 32bit
I just fixed this exact problem on my Win7 Media Center x64. It's a bit convoluted, but the core of the issue is Windows not recognizing the device type properly. What you have to do is open up Device Manager and assign the drivers for Windows. This should fix the mouse.

Head into Device Manager and click View up top. Choose Devices by Connection. You'll see why in a second.
Expand the top entry until you find a PCI Bus. Expand that, then expand all the USB Host Controllers. One of them should have an entry for G502 Gaming Mouse under it.
Right click it and select Update Driver Software, then Browse My Computer for Driver Software. Now click "Let me pick from a list of device drivers on my computer."
Go down to USB Devices and install it as a USB Composite Device. The mouse should light up. Nice! It still doesn't work, though.
Now there'll be two more entries underneath the USB Composite Device, both of which should be G502 Gaming Mouse. Right click one and go back to the list of device drivers. This time go to Human Interface Devices and select USB Input Device for each of them. A bunch of new devices should populate beneath each USB Input Device, one of which should be HID-Compliant Mouse. Your mouse should now work!


All ok up to the point where it should have the G502 as a device in the USB list - it doesn't