Logitech Wireless USB headset "USB Device Not Recognized"

By HaLo2FrEeEk · 14 replies
Dec 17, 2008
  1. I don't know why it's doing this. It happens sometimes when I restart the computer. The transmitter is plugged into the extender base, which is just a USB extension cable. The extension cable is plugged into a PCI card that adds 4 USB ports to the computer. I also have my wireless gaming reciever for using my wireless xbox 360 controller to play PC games and my cell phone charger and my capture card plugged into this card and they all work great. I've tried reseating the connection by unplugging and plugging the transmitter from the extender and that's not working. I tred all the other USB ports on my computer (I have 12) and none of them are working with it. Most times I can simply unplug and replug a few times and it'll catch on, but I'd like to know if anyone else has this headset if you've had this problem?

    I have Windows Vista Ultimate 64 bit, by the way.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    12 USB ports? You may need to upgrade your computers power supply. Is the USB extender externally powered?
  3. HaLo2FrEeEk

    HaLo2FrEeEk TS Enthusiast Topic Starter Posts: 164

    12 USB ports, but I don't need to upgrade my PSU, it's a 500W. I have 4 built in to the mobo, 2 on the case, 4 from that PCI card, and 2 on my external HD-DVD drive (which is externally powered). The USB extender is only one connection, male on one end, female on the other, it doesn't need extra power.

    I actually got it to work, like I said, sometimes I just have to reseat it a few times, but it's frustrating to have to do that half the time when I restart.

    To answer your question, no the extender is not externally powered, but like I said, it's a one connection extender cable.
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Your intermittant symptom indicates that you are right at the threshold of not having enough current/voltage to the extender for proper operation. Have you tried plugging the extender to one of the back motherboard USB ports?
  5. HaLo2FrEeEk

    HaLo2FrEeEk TS Enthusiast Topic Starter Posts: 164

    Yes. None of my other USB devices are doing this. I measured the output voltage with a multimeter and I'm getting enough juice.
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Try another Logitech headset
  7. HaLo2FrEeEk

    HaLo2FrEeEk TS Enthusiast Topic Starter Posts: 164

    I don't have the money to buy another headset. I had a wired headset that was logitech (it's actually almost exactly the same as the wireless version, only...it's wireless. It worked fine.
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Misc things to do /check
    I list a number of tools below. You’ll need check (or just test to see) if they work/are issues working under Vista 64bit

    1) As Tmagic suggested, certainly try a different headset

    2) Use USBDeview
    ==> Use USBDeview to review current and previous USB device descriptors still on your system - may show some interesting data (removing USB devices doesn’t remove their USB descriptor).
    ==> But after review, DO UNINSTALL all descriptors/devices that aren't currently connected. To remove the USB descriptor / un connected device
    =====> For each USB entry where Connected column = No, rt click Uninstall

    3) Ghost Devices
    Ghost devices have their driver loaded into Windows altho the device is not currently connected to computer. USB devices are nototrious for leaving Ghost devices behind (e.g. just moving a device from USB port A to B will leave a ghost behind in port A) I've seen ghost devices cause different issues especially USB ghost devices
    ==> If you can't use USBDeview on your system or to just double check for ghost devices use Device Manager
    ==> First, modify your environment per this link which says XP but same is true for Vista.
    ==> In Device Manager, click View->Show hidden devices.
    ==> Ghost devices are the semi-transparent icons. ONLY REMOVE ghost devices for those devices you recognize

    4) There’s a USB Sniffer tool that might work under Vista to see when the device change is first noticed on the bus vs. reflected on system http://www.pcausa.com/Utilities/UsbSnoop/

    5) Check power draw with / without device on your hubs
    ===> Open Device Manager. For each hub listed, rt clkck Properties. Click Power tab. Now look at devices and power usage vs. limitations and how close you are to it
  9. HaLo2FrEeEk

    HaLo2FrEeEk TS Enthusiast Topic Starter Posts: 164

    I'll look into those, thank you. I don't have and hubs. I hate having anything external. The PCI card could technically be called a hub but that's not really what it is. All the ports are either built into the mobo, connected directly to the mobo via PCI or through the connector for case mounted ports, or, in the case of the HD-DVD Drive, externally powered.
  10. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 3,486   +45

    ehhh I had the same issue with my upgrade to vista 64, it was simply fixed by a fresh install. You cant install service pack 1 until all usb drivers are installs. Goodluck, hope it helps.
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Look in Device Manager. By definitiion you have Hubs (you're just thinking of external hubs)

    /** Edit **/
    Didn;'t look closely . Unless those USB ports are native the computer, yea, then probably no hubs
  12. HaLo2FrEeEk

    HaLo2FrEeEk TS Enthusiast Topic Starter Posts: 164

    Well, technically I have USB controllers, not hubs. And smashbrada, I have SP1 installed, but it probably is time for a fresh install of Vista, I do it periodically.
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    what does device manager say you have? what's all listed under Start->Run, enter: devmgmt.msc, expand USB. What's there?
  14. HaLo2FrEeEk

    HaLo2FrEeEk TS Enthusiast Topic Starter Posts: 164

    Before it said it was there but not recognized, now its working right.
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Well, that's great news!

    I assume you're talking about the headsets as to previously not recognized but now working?

    It would be very helpful for me to know what things or circumstance finally fixed the problem
    ==> I'm assuming your headset problem is still fixed as of now, Correct?
    ==> What changes did you end up making on your computer? Were they all USB related?
    ==> Not certain from your answer if had looked at device under Device Manager. Did you? Did you controllers and/are root hubs and/or generic hubs?

    When you have the time to answer, it would help to have knowledge of what changes remedied your problem. Thanks!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...