Medival 2 total war won't start

By dragonlust
Jun 2, 2009
  1. hey folks,

    ok, I bought Medival 2 total war the other day, plopped the disc in my drive and started installing. The install seemed to go okay, even though it took quite a while. (close to an hour).

    I clicked the icon on the desktop, and the launch screen comes up. I hit 'play' and the acreen disapears and the little 'demo shield' blip appears in the middle of the screen for about 2 sec. then disapears. After this, nothing. The dvd drive spins for about 30 sec. then stops, the HD seems to be accessing something, then stops. Then the whole system gets laggy, but never shows anything besides the desktop. No error message or anything.

    I tried un- then re-installing, then adding the patches; up to 1.2. Same results.

    My specs from memory (I'm currently at work),Windows xp sp3, AMD 3400+ @ 2.8 ghz, 1gb ram, geforce 7600 (gt i think) 512mb. Thaat's all I can remember at the moment, though I ran a system spec test off of some website, as well as compating it with the box, and it seems I shouldn't have any troubles.

    Any help would be appreciated.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...