1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Memory Stick (Sandisk Cruzer Mini) HELP NEEDED

By slb321 ยท 35 replies
Feb 6, 2005
  1. When I go to My Computer to access my memory stick (which shows up as Removable Disk [G:] ) I get a message that says "Please insert disk into drive G:".

    I can't format the memory stick (don't know if you are supposed to format a memory stick).

    When I click on Properties, it says 0 available space, 0 used space.

    I am running XP with SP2 on a Compaq.

    Please help!
  2. thompson626

    thompson626 TS Rookie

    SanDisk Cruzer 512mb Mini - Needs to be formatted somehow?????

    So, it appears that you are having the same problem that I am having. Here is how my problem happened. I had it plugged into a computer that I was about to Fdisk and format. I thought that there was a small partition on this hard drive of 512mb, so I removed the partition, only to realize that the partition I removed was my SanDisk 512mb memory stick....So, any luck getting yours back. Essentially, you should be able to fdisk or create a partition and format again, but it doesn't work like a hard drive. It keeps asking me to insert a disk into my Drive E (the drive letter that is designated). On yours it could be E or F or whatever....Can't seem to get any help from SanDisk on line, so I am searching around the net. My e-mail address is thompson626@shaw.ca if anyone can help. Thanks. JT
  3. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,452

    Go into Computer Management/Disk Management, your stick should be listed in there.
    Rightclick the stick, check the properties. You can format it from there.

    Also, go to the HP website and look for SoftPaq SP27213.exe That can format your USB-key.
    There is another utility: X-Format-Setup-series3000.exe but I can't remember where I got it from.
  4. slb321

    slb321 TS Rookie Topic Starter

    need more advice

    Thanks for the advice. I downloaded the HP USB Format Tool, but when I try to format, it says "device media is write-protected."

    Any more ideas?
  5. patio

    patio TS Guru Posts: 480

    It just M\might have shipped with CruzerLock2 which is a security lock for the data stored on the stick...
    Check the documentation and or software that was included with the drive...

    patio. :cool:
  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,452

    Just found my old post from last year:
  7. slb321

    slb321 TS Rookie Topic Starter

    keep trying


    I downloaded the X-Format utility, and when I try to use is it says "No USB disk found."


    I checked the SanDisk website for info about CruzerLock2, but I still haven't had any luck.

    The problem is that I found this memory stick in my car. I've talked to everyone who could possible have been in my car, and it doesn't belong to anybody. But I don't have any documentation/software for it.

    Any last suggestions before I throw it away?
  8. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,452

    I have 2 of those identical 256MB sticks, one is still unopened in its original wrapper.
    There is only 1 program on the stick itself: SanDisk CruzerLock Installer v1.1.exe, which I have not yet used. There are no other programs with it. If you need it, you can only download a driver for W98SE, or Cruzerlock2.

    But I found some more info on the Sandisk website:
    If all else fails, you can always mail it to me (please) rather than dump it.
  9. gafar

    gafar TS Rookie

    my cruzer doesn't work when i put it in the USb drive the light on the cruzer not turnig on, and computer doesn't recognize it what can be my problem? :confused:
  10. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,452

    What OS are you using?
    If W98, you need to install drivers, it does NOT work on W95.
    ME, W2K, XP and W2K3 should work out of the box, provided the USB-drivers that come on the motherboard-CD have been installed.
  11. gafar

    gafar TS Rookie

    it work before for 2-3 month but yesterday i put it it did't work at all i'm using winXp can something broke in the cruzer?
  12. patio

    patio TS Guru Posts: 480

    I have had this happen a few times with XP. Remove the stick and do a clean boot to XP. Power down plug in the stick and re-boot. See if it shows up.
    I have absolutely no idea why this works but i have had to do it more than once. USB can be finicky i guess.

    patio. :cool:
  13. gafar

    gafar TS Rookie

    how i have to boot Xp ?
    can you tell little bit about it?
  14. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,546   +430

    Start Menu -> Turn off Computer.

    Then Click Turn Off.

    Then press the button on the front of your computer. (if there are 2 or more its the biggest).
  15. styleajet3

    styleajet3 TS Rookie

    memory stick format

    I had the same problem, and i found this in duh i forget where, Go to administrative tools, computer management, and then disk management. I formatted my scandisk mini cruzer from in there, AND IT WORKED :wave:
  16. jemrock

    jemrock TS Rookie

    I'm also having the same problem with not being able to find the G drive? I also have no idea how to format a disk, so elementary instructions will be very helpful. Thanks!

  17. gafar

    gafar TS Rookie

    but computer didn't see the memory stick and this way i cant do anything with it
  18. jemrock

    jemrock TS Rookie

    i've tried restarting my computer and now its freezing up, any suggestions? :blush:
  19. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,546   +430

    We used to have about 5 active threads on similar problems on this but somehow I can't find them (haven't looked real hard though).

    But I do have a 1 gig sandisk cruzer mini, and it did die on me, and I did bring it back to life. And it does work fine now. I'll tell you how I did it:

    The drive had problems with shutting off (light goes otu) in XP. XP also had problems noticing it, device manager woudl notice it, btu explorer would not. Windows98 read and wrote to it just fine during this period.
    I tried to open up dos prompt in 98 and fdisk it, but for some reason (probably very obvious reson to you dos gurus) it didn't see the drive.
    I took it back to XP and found it though disk management, and I COULD NOT DELETE PARTITION like so many threads I see about it. That option was greyed out in XP Pro. So either the dudes that tell you to do that are blowing smoke up your ****, or my drive was just dorked up.
    In any case my drive showed up there as healthy, but it didnt' give any file system. So I told it to format from there, it defaulted to FAT, I changed that to FAT32.

    Once it formatted, the drive worked fine.
  20. dob

    dob TS Rookie

    Cruzer Mini sparked

    Hi fellows,
    Hi came by that forum because I suspected myseft to have sparked my Cruzer-mini 512... Not so hard to do, here the instructions: " Put the likle strap arround your neck and let the Sandisk cruze between your T-shirt and sweather..."

    Static energy kill little helpless cruzer-mini and friends.

    So XP nor any computer didn't recongnize the disk, neither by the standard disk applications.

    But this worked,

    (Thank-U guys)
  21. crshoveride1

    crshoveride1 TS Rookie

    Don't throw it away. Hell I'll take it if you just want to get rid of it. I have a new one now and it has two small programs on it. I can zip them up for ya if you'd like.
  22. crshoveride1

    crshoveride1 TS Rookie

    Does the computer see something attached to the USB drive but its unrecognizable? I had this problem recently and again I sent the drive back to the manufacturer. They sent me a new one. I lost the information that was on the disk though. Word of advise... If anyone uses there flash drive to save important information, save it to a cd as well. These things aren't bulletproof yet LOL
  23. Bodtje

    Bodtje TS Rookie


    I had the same problem and proceeded as follows:
    1. Start - Control Panel - Performance and Maintenance - Administrative Tools
    2. Doubleclick Computer Management
    3. Click on Drive Management (in the left Column)
    4. Richt-click your Memory Stick (appearing in the right column) and choose Make Partition.
    5. Bingo!


  24. Fred

    Fred TS Rookie

    I bought a cruzer mini, and it came with minimal paper work. The cruzer lock was just an encryption program that I had to download off their site. It doesn't lock the drive, it's just a standalone encryption program that you can put on the disk, and I don't think it works if you run it off your hard drive. Somehow the cruzer mini is tattoed. I've heard that some thumb drives come with a write protect slide on the the side of it similar too a floppy disks, but mine doesn't have one of those. Other than that I've never had a problem with it. It's pretty durable, and it's autodetected by XP. The light always lights up. I would try a different USB port.
  25. Sadashiv Kale

    Sadashiv Kale TS Rookie

    I have a problem with my 256 MB Sandisk. Explorer shows no files on the stick. However, the properties show 121 MB used. I can not place more than 130 MB in it. What may have happened. Google search did not provide Sandisk web site.
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...