1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Modem won't assign me an IP address

By skitzo_zac ยท 9 replies
Mar 16, 2008
  1. Okay I have a D-Link DSL G604T Wireless ADSL Router (revision B3), I works fine it works both with the LAN and wireless parts, I am connected via a ethernet cable on the computer I am using currently and my mums iBook is connected via the wireless.

    But it wont give my computer an IP address, It was working fine but recently it stopped working, I am not sure what I did to stop it from working.

    I tried connecting via my wireless adapter D-Link DWL-G510 (revision C) and then I moved the modem/router into my room and used an ethernet cable and plugged it into my onboard ethernet port, it wouldn't assign me an IP for that connection either.

    I don't have a MAC address filter running on the modem, there is no wireless security nothing on the modem side that blocks my computer.

    I tried using static IP's for both a wireless connection and using the ethernet, it connects to the modem, and I can access the modem but not the internet. It appears that when using static IP's it isnt routing me to the world wide web.

    So It must be something to do with my computer. I tried to do a system restore, but that doesn't work :( It goes through the process of restoring, then when it restarts it comes up with incomplete restore cannot complete process or something. I tried multiple restore dates to restore to and none worked.

    I would just re-install windows and be done with it, but I dont have any means of backing up data that I dont want to loose :(

    Does anybody know what is going on or how to help me?
  2. Nodsu

    Nodsu TS Rookie Posts: 5,452   +6

    The router does not assign you an IP. Your computer is supposed to ask for one. Since the iBook is working OK, your router is responding to DHCP requests properly and your coomputer is to blame.

    When you set up the static IP configuration, did you fill in all the data correctly? IP, mask, gateway and DNS exactly as on the working client? (The last octet has to be different for the IP address of course.)

    Have you removed any malware recently? It could be that the removal program overdid it. Maybe run WinSockFix..

    From your PC, post the output of "ipconfig /all" command.
  3. skitzo_zac

    skitzo_zac TechSpot Chancellor Topic Starter Posts: 413

    Yeah the router is working okay as it assigns the iBook and the other computer IP's no problems.

    And yes I am sure that I entered the Static IP correctly, even though it didnt work (well it did to a degree as I could gain access to the router, but it wouldnt route my to the world wide web. AKA give me internet access)

    Malware, Hmmm maybe. It is a fresh windows install maybe a week or two old. I am not using any new programs, just my ussual antivirus, spyware and firewall which I havent had a problem with in the past. Maybe I deleted a required resgistry entry using CCleaner? that is the only program that I would of used to remove anything, as I hadn't installed ad-aware yet.

    I ran WinSockFix, it ran successfully, but failed to solve my problem :(

    here is the result from mmy ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : skitzo

    Primary Dns Suffix . . . . . . . :

    Node Type . . . . . . . . . . . . : Unknown

    IP Routing Enabled. . . . . . . . : No

    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Wireless:

    Connection-specific DNS Suffix . :

    Description . . . . . . . . . . . : D-Link AirPlus G DWL-G510 Wireless PCI Adapter(rev.C)

    Physical Address. . . . . . . . . : 00-15-E9-32-52-1C

    Dhcp Enabled. . . . . . . . . . . : Yes

    Autoconfiguration Enabled . . . . : Yes

    Autoconfiguration IP Address. . . :

    Subnet Mask . . . . . . . . . . . :

    Default Gateway . . . . . . . . . :


    "Autoconfiguration IP Address. . . :" it starts trying to acquire an ip (says acquiring network address, then eventually goes to the state of limited or no connectivity) and has that IP. which is strange as it should be using an ip on the 10.1.1.x subnet.

    also with the subnet mask if the DHCP was working properly on my computer the subnet mask should be

    But I have found a way of backing up my data* and am going to format and start with a clean windows install again and see if that will let me connect to my router successfully, hopefully it will.

    *Created a second partition out of my free hard drive space with Acronis and copied data onto that partion.
  4. skitzo_zac

    skitzo_zac TechSpot Chancellor Topic Starter Posts: 413

    Okay I just finished installing windows and then the drivers for all my hardware, and I successfully connected to my wireless first try YAY :D

    Hmmm well I dont know what the problem was before, but if anyone cares to shed some light I would love to hear what you think was going on, or not going on?
  5. MrSnoobs

    MrSnoobs TS Rookie

    looking at the ip config, whatever Static IP addresses you had werent feeding through to the IPconfig. Also, there was not a default gateway set up: this should be the address of the router: or something similar.

    Hope it stays working!
  6. skitzo_zac

    skitzo_zac TechSpot Chancellor Topic Starter Posts: 413

    that ipconfig /all report was after a failed attempt at getting a DHCP assigned IP not my static one. and my modem uses the IP of, not like most!

    And I have discovered what the problem was.

    My onboard raid controller was killing my internet, when i installed its drivers my wireless stopped, uninstalled it and wireless is back!

    luckily for me I dont use raid or dont really plan to in the near future.
  7. jobeard

    jobeard TS Ambassador Posts: 12,493   +1,430

    please detail how you discovered that RAID was interfering with the Wireless;
    Device Mgr? Red/Yellow? IRQ conflict?
  8. skitzo_zac

    skitzo_zac TechSpot Chancellor Topic Starter Posts: 413

    Umm well when It stopped working I decided I would uninstall stuff at a need basis (uninstalling stuff i didnt need or needed less than others first).

    So i opnened up add or remove programs from the control panel and saw the raid controller, and I was like well I dont use raid so I might uninstall it and see what happens.

    And what did happen was that I was successfully assigned an IP address and as my interwebs was fixed.
  9. jobeard

    jobeard TS Ambassador Posts: 12,493   +1,430

    very good reasoning there -- glad it worked for you.

    I would love to have figured out what the core issue was, however.
  10. skitzo_zac

    skitzo_zac TechSpot Chancellor Topic Starter Posts: 413

    Yes I would also like to find out what was actually going on. And I am sure that befoe my recent re-install of windows my wireless was working fine whilst I had my RAID driver installed.

    I am 99% sure I had my RAID driver installed as I don't like having devices showing up in the device manager with errors because they dont have drivers installed.

    So it may be the RAID controller driver that killed my internet, but I do belive that its not quite as simple as that.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...