1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

MSCONFIG access denied error

By CYPHERUS ยท 67 replies
Jan 23, 2006
  1. BruceMyers

    BruceMyers TS Rookie

    One day I will sit down and check it out. Next time I load the OS I will leave HP off and see if I still get it. I can live with it too. Bruce
  2. CaptainLee

    CaptainLee TS Rookie

    Just for reference, I began recently to recieve the same ...."An Access Denied error was returned while attempting to change a service. You may need to logon using an Administrator account to make the specified changes.".... message, whenever I attempted to change any items in my "startup tab' in MSCONFIG.

    I have spent numerous hours searching for a fix for this error, because I am using the Administration account. I have read all the messages on this board regarding the issue and didn't find any help. I don't have Zone alarm, I never have. I don't have a HP printer, I never have. However, if it may help anyone else, the message for me stopped immediately after I decided to get other virus protection program other than McAfee. I uninstalled McAfee, rebooted, and before installing another virus program and tested MSCONFIG. I haven't seen the error appear since.
  3. BruceMyers

    BruceMyers TS Rookie


    Thanks for letting us know. I have MCafee and do still have that problem. I will get hold of McAfee. Thanks Bruce
  4. almuawak

    almuawak TS Rookie

    I did exactly what klondon101 said and I finally was able to get rid of this "msconfig access denied error" nuisance, I am running windows xp professional on a Dell INSPIRON 6400, crossing my fingers that this nightmare never re-occurs...

    Solving this problem was the reason why I joined this site, credit goes to you Klondon101...Keep up the good work and thanks once again!
  5. BruceMyers

    BruceMyers TS Rookie


    I do use McAfee and as soon as I get a chance I will try removing it. I still believe that I have seen this message on computers that don't run McAfee. Thanks Bruce
  6. shortnapoleon

    shortnapoleon TS Rookie

    help me, same problem

    can u pls be more specific for the steps need to take for the explanation you gave. I'm not that savy to enough. can u give step by step in how to arrive to those steps u gave.
  7. shortnapoleon

    shortnapoleon TS Rookie

    can u pls be more specific for the steps need to take for the explanation you gave. I'm not that savy to enough. can u give step by step in how to arrive to those steps u gave.
  8. Jay Aitchsee

    Jay Aitchsee TS Rookie

    solved msconfig access denied

    Hello, I just wanted to let everyone know klondon 101's solution (setting value in regedit for PML Driver HPZ12) worked for me - the second time!

    I have a Dell 8300 with XP home SP2, an HP PSC 1610 all-in-one, Mcafee Virus Scan 12, and Zone Alarm pro. This problem came to light when SP3 failed to install. I soon discovered the "msconfig access denied problem". I tried all of Microsoft's suggestions including running subinacl and reset.cmd. No luck. I found many posts in various forums relating to this problem and HP, McAfee, and Zone Alarm. First, I uninstalled Mcafee, no luck, then I set the value of PML HPZ12 to 3 (manual start) no luck, then I uninstalled all hp software using add/remove and their cleaner - no luck. Then, looking over services, I noticed HPZ12 was still there. So I went back in and changed the value to 4 (disabled), and it worked!!

    Now I don't know what to do about the printer. Maybe HP will come out with a fix or patch. There must be hundreds of people with this problem.

    Anyway, thanks, Klondon.
  9. Gr11zzly

    Gr11zzly TS Rookie

    Access denied extends to other areas?

    I also run mcafee and have this issue. Just ran Ghost to recover from an lol.exe infection but apparently didn't go back far enough to solve the MSCONFIG issue. Did anyone get a useful response from Mcafee?
    No never had an HP printer.
    Running XP SP3
    No virus found and have tried to replace msconfig.
    Turned off Ad-Watch.
    Nothing seems to make a differnce. Everything else is working fine it seems.
  10. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Two morals here are

    - never install any HP printer monitoring software, it has been a load of rubbish for years. Just install the driver and nothing else.

    - do not use any form of 'registry booster' software, ever. Far too many are malware themselves or downright extortion attemps, or are honest attemps which cannot keep up with the pace of change imposed by MS constant updates aka foul-ups.
  11. Gr11zzly

    Gr11zzly TS Rookie

    Thanks for that. Good advice I would say.
    Unfortunately I haven't done either of those and still have the same problem. Spoke to mcafee and they quoted from this board and told me it wasn't them but the HP printer software trying to access the web and getting stopped by the firewall??
    Once more Mcafee--I do NOT have any HP software on this machine of mine.
    Oh and no registry boosting software either so there must be some other reasons for this sort of issue
  12. detroitcity

    detroitcity TS Rookie

    This annoying message. My problem started the first time I tried to change my startup configuration in msconfig after I had upgraded to the McAfee firewall version. Still can't get rid of the message, and I get the message at restart too. However, the changes I made in msconfig-startup worked. I have no HP printers attached.
  13. Gr11zzly

    Gr11zzly TS Rookie

    McAfee told me "they were looking into it". I think they were stringing me along. Might help them believe the issue is real if more people complain to them.

    Like you---still have the annoying message and can't help thinking its the tip of a nasty iceberg but the changes I put in seem to work.
    WE have no choice but wait for someone to discover the cause
  14. detroitcity

    detroitcity TS Rookie

    This is the most logical explanation I have found during my three day search. It comes for McAfee people posting in forums:

    This alert is due to registry permissions on an entry created for McAfee
    applications. There appears to be a bug in msconfig that causes it to
    attempt to modify registry keys that it isn't directly editing, which
    results in the error message.

    We have contacted Microsoft about this issue, but for security are keeping
    the permission on the key the way it is.

    McAfee Development Engineer

    This is a security feature and there is no option to disable it. MSConfig
    reports error but you can ignore it.

    McAfee Development Engineer

    To clarify, when you modify anything in MSConfig, Windows attempts to change
    the registry settings for everything in the MSConfig list. When Windows
    reaches the McAfee items and attempts to change them, McAfee prevents this
    from happening and Windows shows an error. This is a good thing from a
    protection standpoint, as malware could otherwise use the same mechanism to
    shut down your McAfee protection.

    I would have expected that when I make a change in MSConfig, Windows would
    only change the settings for the application I tried to change. But that's
    not how it works. MS apparently doesn't want to modify MSConfig to do so.
    Hence, the error.

    In the end, even if you see this error, whatever changes you made will be
    saved, unless you tried to turn off a McAfee product. If that's your goal,
    it's best to do this within SecurityCenter.

    McAfee Development Engineer

    So, to sum up, to get rid of this error we will have to get rid of McAfee. However, I have read the same problem happens when using Zone Alarm. I guess it is just an unintended result of Microsoft Windows programming clashing with our Firewall software. Good thing it's just an annoying pop-up instead of a true security risk or registry error.

    I will keep on looking for a solution and checking back to this forum, but I am not going to drive myself nuts over it.
  15. Gr11zzly

    Gr11zzly TS Rookie

    Hey thanks for that!! You are right its a very logical explanation and takes away the fear that it might be an iceberg.
    Thanks for your hard work.
  16. rpmchem

    rpmchem TS Rookie

    I believe McAfee is part, if not all of the problem. I could not make modifications to startup using the msconfig. I kept getting an error that said I didn't have rights to do this and suggested I needed to login as the administrator. I did that and still couldn't make modifications. I finally removed McAfee and everything worked fine.

  17. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    I can confirm that - exactly the same symptom on an XP SPII machine.
  18. Gururajmeghraj

    Gururajmeghraj TS Rookie

    Msconfig Access Denied


    Just disable Mcafee Access protection.
  19. mphanikumars

    mphanikumars TS Rookie

    Msconfig Access Denied

    After disabling Mcafee Buffer Overflow protection it worked for me
  20. madmaninct

    madmaninct TS Rookie

    One problem...many causes

    Seems there is one problem here - with the possibility of more than one cause.
    I experienced this same problem (Admin error notice when making changes to MSCONFIG file) on TWO machines, both of which run XP Home Edition (SP 3). Neither has Zone Alarm and neither has any HP printer software installed. Furthermore, I also checked the registry and neither has an HPL entry either (either/neither???). However, the not-so-inconsequential common denominator for my two machines is that they both have/run McAfee Security software. Both laptops run fine (i.e. no evidence of spy or malware) and, most importantly, all changes I make to the MSCONFIG file are found to have been executed once I restart the machine (rendering the problem, as I see it, as nothing more than a nuisance that doesn't really affect the desired intent). What's interesting here is that of my two laptops in question, one a recent (less than 2 months old) build with a fresh install of both Windows and McAfee. I never had the problem on this newer machine until, lo and behold, I installed McAfee. Then, suddenly, the problem manifested itself on that machine as well.

    Talk about things that make you go Hmmmmmm.....

    Anyway, I just thought it worthwhile to post my obersvations: That, in my case at least, the McAfee software seems to be the culprit (as DetroitCity so thoroughly researched...thanks DC) and, more importantly, that sometimes a single problem can have more than one cause - as seems to be the case according to what I've read in this forum regarding this particular problem.

    Kudos to all who participate in the sharing of their knowledge...and their power.

  21. csterl01

    csterl01 TS Rookie

    Solved it for me. Thanks

  22. csterl01

    csterl01 TS Rookie

    I have been fighting this problem on a couple of my computers for while and this solved it on all of them. Looking at the thread, it appeared that the pml driver was a common link. DIsabling it in regedit took care of it. Thanks klondon101!
  23. madmaninct

    madmaninct TS Rookie

    Still searching for a solution

    Hey folks...

    First, I want to say thanks to all who took the time and effort to respond...

    I tried Klondon101's suggestion and edited the PML Driver HPZ12 Service. I tried changing the setting to either 3 or 4 (restarting the machine inbetween each change) and, unfortunately, the problem still persists. problem,

    I also tried mphanikumars' suggestion to disable the buffer overflow protection in McAfee. I restarted the machine and, again, the problem still exists.

    I have NOT tried Gururajmeghraj's suggestion to disable McAfee's Access protetion as I am unable to locate (and, thus, disable) that option in my version of McAfee.

    Any other ideas or suggestions would be welcome...and appreciated.

  24. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    I would uninstall McAfee. restart the machine twice and then see. You can always reinatall it if it makes no difference.
  25. esbo

    esbo TS Rookie Posts: 102

    I have tried most thing here apart for system restore, uninstalled mcafee, made regristry change despite not having that key in the first place.
    I had ran a registry optimizer (free trial) it made some changes,(dunno what) I suspect that.

    Surely Microsoft know what this is, the error comes from the program (msconfig) further more it is a false error message.

    The problem lies with microsoft hence as there is a fault with msconfig.

    Maybe the solution is to get an Apple Mac.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...