MSCONFIG access denied error

By CYPHERUS · 67 replies
Jan 23, 2006
  1. esbo

    esbo TS Rookie Posts: 102

    I would like to add that I don;t have a Pml Driver HPZ12/Start key not even a Pml Driver HPZ12 folder
    althought I created both but it made no difference.
    Why don't I have one?
  2. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    try creating one in the root directory as sometimes these things won't run unless they start from there.
  3. esbo

    esbo TS Rookie Posts: 102

    I have read some stuff about anti virus being the problem.
    The hp printer fix sounds stupid to me, I don't have one and it just sounds so unlikely.
  4. esbo

    esbo TS Rookie Posts: 102

    IF you have the problem try starting in diagnostic mode and take it from there ;)
    I have fixed mine :)
  5. ntriqetev

    ntriqetev TS Rookie


    try smartcommand to fix msconfig error:
  6. esbo

    esbo TS Rookie Posts: 102

    Not realy interested in using software to cure a problem, would rather know what the problem was and what the fix then run some obscure thing not knowing what it was doing to my computer.
  7. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    I recently came across a client's machine infected with threatware which as part of it's generally screwing things around denied access to msconfig, regedit and the system admin tools. In safe mode too.
  8. zeta27

    zeta27 TS Rookie

    U have a virus, if u can restored do it, and use your updated antivirus
  9. esbo

    esbo TS Rookie Posts: 102

    I don't have a virus. i fixed it without anti-virus stuff.
    Well if I had one it's gone anyway.
  10. codemonkey98

    codemonkey98 TS Rookie

    Same issue as above but none of the solutions worked!

    I'm having the same problem. I removed McAfee and do not have an HP printer but still cannot turn on my System Restore Service due to the "Access Denied error":

    Two days ago, for no apparent reason, the majority of my Services have been stopped when the machine boots up. I have not installed any new software recently or anything. I boot the machine up in Safe Mode and login as the Administrator and then open MSCONFIG and go to Services. I notice nearly ALL of my services are stopped. When I attempt to enable the "System Restore Service", it throws the error "An Access Denied error was returned while attemnpting to change a service. You may need to log on using an Administrator account to make the specified changes". I'm already logged in as Administrator! I have uninstalled McAfee per a Google search, and attempted to create a new Administrator user in my User Accounts section, but when I open User Accounts I just have a blank folder. Additionally, I cannot open any applications by double-click or by launching from the command line such as Help, Internet Explorer, etc. The "Start" button is not visible on my desktop either. I have found that by doing clicking Tab -> Enter I'm able to bring up the start menu so I can get to a command prompt.
  11. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    This is probably the result of the latest McAfee update which is causing all sorts of difficulties. I have just collected a machine and the only solution to the total foul-up created by this is a reinstall of the OS. Punter is not happy - local McAfee support charges £1 a minute! (same as me but at least you get a result and your data saved!)
  12. esbo

    esbo TS Rookie Posts: 102

    When you get the message about needing to be sys admin just iignore, On mine the changes ar made anyway.
    Enable all your services and disable all your startup programs and see if that helps.
    If it does gradually restore it to the options you want at start-up.

    Normally the access denied error is made in error and ignore it and save the changes (they are saved anyway) so you should be able to do a system restore.

    Disabling anti-virus might be a good idea as they can cause probelms.
  13. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    I have two more machines into the workshops this week with the same symptom - and both as a result of a McAfee update that went wrong. And in each case the client had asked McAfee for help and the fix made the situation so much worse that the best option for a fix was a reinstall of the OS in each case,
  14. achahine

    achahine TS Rookie

    Access denied error MSCONFIG

    This can be easily solved by Typing msconfig in command prompt than choose Normal startup then click on startup to choose whatever you need to start when Windows starts. Then go back and click Selective startup. Problem solved.
  15. esbo

    esbo TS Rookie Posts: 102

    I have solved it!!

    well to a certain extent!!

    The problem is the

    True Vector Internet monitor

    Which is under the services tab in msconfig.

    If you leave it disabled you get the access denied error, so you just enable it (tick box)
    and hey presto the problem goes away.

    I messed about with my services a bit so I may have a few other running I do not want
    but that is a minor problem.

    The process concerned is

    C:\WINDOWS\system32\ZoneLabs\vsmon.exe -service

    However that process does not exist on my my machine.

    I am just wondering how to get rid of the all traces of ZA (chuck hard drive in bin??)

    The reason why this solves it it because it enables all services.

    OK I used this.
    for this download

    It removes all traces of ZA so the problem should not come back again.
  16. ruready2

    ruready2 TS Enthusiast Posts: 202

    Just to add a little here. I have experienced this issue on a number of occasions with the problematic software being different each time. It was once Virus Total, then the Hp printer driver as discussed in previous post to this topic. It is now Avast anti-virus. Although I am not sure, however, that my symptoms are the exact. To be more specific, although I do receive the access denied error I am able to ultimately make the changes. I guess this is something I will have to deal with until Avast decides to make a patch for the issue. I'm certainly not going to surf unprotected and after years of having Avast, MABM and SAS in combination without ever even a single infection, I am just not comfortable or willing to use anything else. Point here being, if the fixes listed do not work for you then get ready to do alot of uninstalling and reinstalling and restarts. I know of no way to determine which software is causing the problem other than the process of elimination. It's on to Avast forums now to begin the tug-of-war there for a patch.
  17. esbo

    esbo TS Rookie Posts: 102

    Well I solved it by removing ZA with the tool, uninstalling it does not seem to work correctly. However as you indicate, the problem is somewhat cosmetic as the error message does not reflect reality.
    I can only speak for my experience of the problem, removing ZA worked for me.
    It seems ZA tried to protect itself from being turned off, (and failed) but still got out the cosmetic error message.

    Personally I seem to have had more problems from the the software which is protecting me that the viruses it is supposed to protect me from - lol.
    Not sure what that means, it seems the problem 'falls through the cracks' between microsoft and A/V and firewall developers.

    However I am pretty happy with my AVG and Comodo firewall at the moment.
    They wee to work, (how would I know if they didn't anyway?!!).
    So ignorance is at least bliss!
  18. rcurry2

    rcurry2 TS Rookie

    an access denied error msconfig

    I have the same problem, my culprit seems to be Norton Internet Security. I can use Norton Internet Security 2009 and the problem is gone, but if I use 2010, or 2011 the problem is there, so I either deal with it,(the changes in msconfig do take), it's just annoying, or go back to Norton 2009...untill a solution is found.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...