Msiexec.exe encountered a problem - install incomplete

By Aimsbury ยท 4 replies
May 9, 2009
  1. Hi All,

    I've been having all sorts of problems with my PC lately (running XP). I have been trying to update my graphics drivers, and it goes through the motions of installing but during the 'utillity' installation phase, installation stops and I get a message saying msiexec.exe encountered a problem and needs to close.

    I only get this message when trying to install a programme so at the moment, am reasonably confident this is a genuine message, and not something coming up to get me to download spyware etc (I've searched a few forums and this is possible apparently).

    Could anyone help me out please? I would be most appreciative

    Many thanks
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Try setting Windows Installer to create a trace file of what it is doing.

    (can be very helpful, but can also generate a HUGE file you need to look through. You might start with a few flags set and if that doesn't help set them all)
    How to Enable Windows Installer Logging in Windows XP
  3. Aimsbury

    Aimsbury TS Rookie Topic Starter Posts: 30

    Windows Installer

    Thank you - I will try that now.

    In the meantime, I have also updated the audio driver (realtek '97). They seemed to install ok, but asked me to restart.

    When I did this, I also had windows updates to install so clicked ok.

    I got a message saying msiexec.exe encountered a problem
    0x7d2bd4d3 referenced memory at 0x00000008. The memory could not be "read"

    I also got a message about syncmaster but the computer shut down before I could write down the error code

    Does that give you any clues?


    Many apologies - I consider myself a newbie at all this and am a bit wary of changing registry entries which I think is what the windows installer log support is asking me to do. Is there a dummies guide anyone can recommend?

  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    The link i gave tells two ways to do it.

    Good point, don't modify the registry. But read the section on how to Enable Windows Installer Logging by Modifying Group Policy
  5. Aimsbury

    Aimsbury TS Rookie Topic Starter Posts: 30

    Cool - I'll try that one.

    As the error said something about memory, am currently running a memtest just to be sure.

    I've got 2 passes so far. On test 8 on number 3 - fingers crossed!

    Thanks for your help so far. I hope we get this fixed simply!

    Regards x


    Update - memtest came back with 20 passes (left it running since yesterday afternoon and overnight). Will try with windows installer thing now


    Update 2

    Just tried to change the group policy as per the windows support thread. Did start, run, open and typed gpedit.msc but got the red cross message saing that windows cannot find it. Now I'm lost... any ideas?



    Update 3 - Sunday 10th May, 12.30pm (UK time)

    I had a look around the windows support site about msiexec issues. I tried a couple of things that didn't work (unregistering the windows installer and reregistering etc).

    In the end, I found the page with the latest version of Windows Installer and instaled that. On the restart after reinstalling, I got an error message, but I think that's because the update had not taken effect and that the error message was warning me of an issue on shut down, not start up (it couldn't download the auto updates that were waiting). I did get a message about Sync Service with the error code of 0x012e615 though

    I've now managed to successfully download the driver updates for my graphics card and also the latest patch for World of Warcraft for my other half which I haven't managed to do since it was released 4 weeks ago! I've won some brownie points there!

    On a second reboot, the automatic updates seem to have installed themselves as I have not had another error message about msiexec.exe or sync service so I am hoping that the hotfix has rectified the problem.

    I still have a few issues with the pc, but for now, at least I am able to download and update software. Still can't find the gpedit.msc file but hope I don't need it anymore! Will be in touch again if I have any more problems,

    Many thanks
    Amy x
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...