Multimedia Audio Controller missing XP

By daytymer ยท 4 replies
May 31, 2008
  1. Hi,

    I'm without sound, and without a solution. Have a custom desktop (XP Pro) that a few months back had a new motherboard installed (professionally). Everything was working great. Last week, I formatted and put XP back on. All worked smooth except for the SM Bus, USB and Multimedia controllers (they were yellow ? in device manager). Through "everest" I got all the system info and installed what I've understood to be the correct drivers. SM Bus and USB are now fine, but the multimedia controller, and multimedia audio controller are still missing.

    I've read through Techspot taking suggestions and advice, but haven't been able to fix my problem. Here are some of the things I've done so far:

    1. Admin tools/component services/services - there is no listing for audio
    2. Control panel/sounds - no audio device found
    3. Sound Hardware - Sony DVD RW DRU510a, audio codec, legacy audio drivers, legacy video capture devices, media control devices, video codecs
    4. Installed Sony DVD bundled software - (My DVD, Recordnow DX etc)
    5. Installed - Intel Chipset Device Software Installer v
    6. Installed - Intel Chipset v
    7. Attempted to install - ADI soundmax audio driver - error says "audio driver not found"

    I'm at a loss. Have I tried too much of the wrong thing, at this point?

    Your help would be greatly appreciated.
    Thanks :)

    Here is the Everest info:

    CPU Type DualCore Intel Pentium D 930, 3000 MHz (15 x 200)
    Motherboard Name Unknown
    Motherboard Chipset Intel Lakeport-G i945G
    System Memory 503 MB (DDR2-667 DDR2 SDRAM)
    BIOS Type Award (07/18/07)
    Communication Port Communications Port (COM1)
    Communication Port Printer Port (LPT1)

    Audio Adapter Intel 82801GB ICH7 - AC'97 Audio Controller [A-1]

    Motherboard Properties:
    Motherboard ID 07/18/2007-LakePort-6A79H0ZAC-00
    Motherboard Name Unknown

    Front Side Bus Properties:
    Bus Type Intel NetBurst
    Bus Width 64-bit
    Real Clock 200 MHz (QDR)
    Effective Clock 800 MHz
    Bandwidth 6400 MB/s

    Memory Bus Properties:
    Bus Type DDR2 SDRAM
    Bus Width 64-bit
    Real Clock 267 MHz (DDR)
    Effective Clock 533 MHz
    Bandwidth 4267 MB/s

    Chipset Bus Properties:
    Bus Type Intel Direct Media Interface

    South Bridge Properties:
    South Bridge Intel 82801GB ICH7
    Revision / Stepping E1 / A1
    Package Type 652 Pin mBGA
    Package Size 3.1 cm x 3.1 cm
    Core Voltage 1.5 V

    AC'97 Audio Controller:
    Audio Controller Type Intel 82801GB ICH7
    Codec Name Avance Logic ALC655
    Codec ID 414C4760h
    S/PDIF Output Supported

    Sound, video and game controllers:
    Audio Codecs 5.1.2535.0
    Legacy Audio Drivers 5.1.2535.0
    Legacy Video Capture Devices 5.1.2535.0
    Media Control Devices 5.1.2535.0
    Video Codecs 5.1.2535.0

    System Devices:
    Intel(R) 82801 PCI Bridge - 244E
    Intel(R) 82801G (ICH7 Family) SMBus Controller - 27DA8.3.0.1011
    Intel(R) 82801GB/GR (ICH7 Family) LPC Interface Controller - 27B88.3.0.1011
    Intel(r) 82802 Firmware Hub Device 5.1.2600.0

    Multimedia Audio Controller
    Multimedia Controller
    Intel(R) 945G/GZ/GC/P/PL Processor to I/O Controller - 27708.3.0.1011
  2. turbo1

    turbo1 TS Maniac Posts: 353

    Have you enabled the onboard sound from your BIOS settings?
  3. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Did you remove or disable the old drives before you attempted the install of the ADI soundmax audio driver ?
  4. daytymer

    daytymer TS Rookie Topic Starter

    Nope, didn't do that. Here is what I found:

    Azalia/AC97 Audio Select
    Auto (was selected)
    AC7 Audio & Modem
    Audio Only
    Modem Only

    I selected AC7 Audio & Modem and when Windows booted back up, it found "new hardware" and was able to install drivers for "Pinnacle DV/AV". So now I have the multimedia controller, still missing the multimedia audio controller. PCI Modem is now in yellow, but I'm not too concerned about that for the moment. (unless I should be, of course)

    Sadly, I don't know what I have installed/uninstalled/wasn't able to install etc.
    I've attempted to remove everything that I've already done, and at this point don't even know what I need to put back. <sigh>

    I can run another Everest report if that would help out. The entire report is huge and I'm guessing the whole thing isn't needed with this problem. Which categories should I select under customize?

  5. turbo1

    turbo1 TS Maniac Posts: 353

    By default,the onboard sound must be enabled in BIOS for the driver to
    be able to detect the sound chip.try checking it first.when done (enabled),
    un-install the sound driver,reboot then re-install it again.

    if that didnt worked,boot to safe mode & install the sound driver.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...