Multiple BSODs, can't boot in any mode

By Borealis ยท 4 replies
May 15, 2010
  1. Hi there! Hope to find some advice with my computer issue.
    I have Dell xps 410 with Windows XP home edition sp3.
    2G of Ram (2 sticks); Processor Intel,6400,2.13, Dual Core
    Bios v. 2.5.3

    I used to have many BSODs in past 6 month, mostly 0x50, sometimes with reference to win32k.sys. They usually occured when i attempted any type of scanning (for viruses, doing registry backup, etc). Otherwise computer worked fine, so i just didn't scan and everything was ok.
    Couple of days ago i heard weird ticking, and the front green light was flashing. So i decided to restart, and it gave me the 0x7b blue screen after the xp logo. i tried multiple times and i got computer to load my wallpaper, start panel, but then it got stuck loading my antivirus (AVG) and said about some error in c/windows/system32/drivers.
    I managed to boot in the save mode and deleted AVG and some other programs. i tried to run chkdsk /f but it would tell me it can't lock current drive, the volume is in use by another process. I then tried running SFC/scannow but it would give me error as well and say that RPC server was unavailable. I managed to boot normally and installed the Eset internet security. It was working fine for couple of hours, but then gave me bsod when i attempted scanning.
    I scheduled to run chkdsk on next reboot, and it finally did, said it fixed couple of bad sectors and announced disk C clean, but it still won't boot! My safe mode boot is getting stuck at mup.sys and won't go pass it. I've read tonnes of forums and advices. I cleaned my PC from dust, then i took out one RAM stick at a time to see if they might be faulty. After i started comp with one RAM, it almost immediately gave me BSOD with 0x24. The same one i'm getting right after safe mode reaches mup.sys. I ran the diagnostics from the "boot from utility partition" option in my boot menu. Everything was fine, except for it couldn't perform read test on my hard drive, gave an error 0f00:0232 timeout waiting for IRQ.
    I can't even boot from the Windows installation CD to run the recovery console. It would reach the "setup is starting windows" and then flash me with 0x7b BSOD. When i press F6 during the process to install extra drivers, it then would say that it didn't find any mass storage devices to install support for.
    I don't know what to do now. I can't afford the new hard drive, which might not be the issue at all. I also can't post minidumps because my system doesn't create any for some reason. It does it occasionally, but the ones i have are pretty old and most likely irrelevant. I'm currently running from usb Ubuntu, and it sees my hard drive ok. I also ran couple of virus scans from ubuntu, and no viruses found.
    I would appreciate any help!
  2. Borealis

    Borealis TS Rookie Topic Starter Posts: 16

    Any suggestions? I want to try installing 3d-party RAID drivers through slipstreaming. Does anyone know if that would help?
  3. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    0x00000024: NTFS_FILE_SYSTEM
    A problem occurred within NTFS.SYS, the driver file that allows the system to read and write to NTFS file system drives. There may be a physical problem with the disk, or an Interrupt Request Packet (IRP) may be corrupted. Other common causes include heavy hard drive fragmentation, heavy file I/O, problems with some types of drive-mirroring software, or some antivirus software.

    Windows lost access to the system partition or boot volume during the startup process. Typical causes: Installing incorrect device drivers when installing or upgrading storage adapter hardware, or a virus.

    My suggestion is to slave this harddrive in another system and do three things through said system:

    1. Anything of value transfer to a flash drive and/or burn to CD/DVD.

    2. Use the harddrive diagnostics utility provided by your HD manufacturer and run both short and long tests.

    3. Scan for infections.
  4. Borealis

    Borealis TS Rookie Topic Starter Posts: 16

    Thanks for the advice! That was my last resort - to slave it into another system. However, i followed someone else's lead and turned off RAID in my BIOS, that allowed me to boot into recovery console. I ran CHKDSK /F, it said it corrected one or more bad sectors or something like that. Then i ran fixboot and it said that boot sector was corrupt and created a new one. So i got rid of 0x24, now booting gives me 0x7b instead.
    I tried to run hardware diagnostics, but with no success. It couldn't read the HD. Also i ran gpart from ubuntu and it showed multiple read errors (differences in sector sizes) before recognizing my partitions. I'm starting to think that HD is indeed on its way out.
  5. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Yes, with your symptoms and error codes it certainly looked like the harddrive had serious issues. And I agree that the one harddrive is failing without any chance of repair.

    Good work on your part.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...