1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

My USB ports are underpowered, how do I fix this?

By rmdl51 ยท 6 replies
Apr 6, 2011
Post New Reply
  1. Hi, I'm not sure if this is the right forum but since I'm having trouble with external HDD and removable devices through my USB ports I decided to post it here.

    I recentry bought an external enclosure USB powered which after installing a HDD on it, it was not recognized I thought I got a DOA enclosure but after trying it on my friends computer it works just fine, so the enclosure is fine but does not work on my computer, it has the option to use a power cable for USB 1.1 and when I plug that cable it works fine, but it is not supposed to work like that, USB 2.0 cable only is supposed to power up that device.

    Another problem related to same issue, everytime I plug my iPad on my computer it says "not charging" and even though it charges veeery slow sometimes does not charge at all.

    USB drives, mouse, KB and printer work just fine and they are all USB, very randomly I receive a message "your device could perform faster if you plug it to a USB 2.0 port" but my ports are USB 2.0.

    I tried changing some settings from the BIOS but nothing helps so far, could you please let me know how can I check for this problem, I never seen anything like this except on defective motherboards, hopefully this is not the case, but I don't know.

  2. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    Both USB 1.1 & 2.0 supply power to the attached device(s) - - but ONLY 500ma per slot. You were right to get an enclosure for the HDD, but it needs to be externally powered to drive the higher current needs of an HDD.

    It does seem strange that
    , but that's different than the HDD issue.
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

  4. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    caveat emptor
    That's contrary to the USB specification and if the driver can actually deliver 1.2A, imo that would be risky on the 22gague wire in the USB cables.

    I have seen devices where a 'Y' cable was provided, on leg for data+power and the other going to another USB slot to get just power only, thereby boosting the current to the device to 1.0A - - fully supported by the USB specifications w/o risk.
  5. pjamme

    pjamme TS Enthusiast Posts: 208

    Joe Beard, I have one of those a hitachi X250. Didn't know why it had 2 plugs until I pluuged just one in, nothing. with both plugged in it gets enough power to show up.
    But I I must say prefer one with a transformer
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    1) Specific support for battery charging was added to the USB 2.0 spec in 2009. /* edit */ Which allows battery devices to draw more then 500mA if computer/board can support it /* end edit */

    2) The Power requirements/output for a "USB charging port" (a USB port that connects to a battery device to charge it) is different from for a USB port that provides power to a device to run it (e.g. to an external hard disk)

    3) As i recall, iPad USB cable has a new, special connector on one end. One can't use pre-existing USB cables

    4) Re: the ASUS driver mentioned in prior post
    ASUS provides an ASUS driver for ASUS motherboards to charge iPads. So i'm inclined to think they thought this through but, of course, nothing is ever 100% for sure with 'puters :)
  7. rmdl51

    rmdl51 TS Maniac Topic Starter Posts: 244

    Thank you all for your input.

    Well I have tried that Ai charger and it works fine, the "not charging" message on the iPad is gone and charges normally now, but my external HDD still does not power up with just the USB cable.

    This HDD enclosure fits 2.5 HDD and is built to be powered with just a USB cable, my goal is to use it that way, not with Y cables or a power cord, and is working good as I tried on my friend's system and powers up normally read and writes just fine with only the USB cable, I want to figure it out why I can't use it that way on my system, I checked for updated drivers on Asus website but everything seems very old (2009) for my P5Q Pro Turbo.

    Oh and to clear it up the Ipad cable is the same as all ipod versions, so I been using an old cable but I also use the cable it came with the ipad and makes no difference.

    Here is the enclosure I'm trying to use,
    if there is any known issue or suggestions why this is not working I appreciate any ideas, Thanks.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...