My WD External HD randomly started giving me access is denied messages.

By Brennan
Apr 29, 2013
Post New Reply
  1. I run Windows 7.

    WD MyPassport 2TB

    Problems first started about halfway into a Vuze transcode for a movie (the original file and the transcode folder are both on the drive). First it wasn't letting me right-click delete/rename. (the option for those wasn't on the right click list but everything else was) I restarted and still the same, I did the Check Disk in the HD menu (I ticked the recover bad sector box) and it wasn't moving (didn't feel like waiting) so I stopped it and afterwards anything I tried to do gave me "access is denied".

    I forgot that I had formatted it into ExFAT so my TV would recognize it, and I had movies files were 8gig+ in size which might cause problems?

    It says under the security tab it is "unable to display current owner"

    I would really rather not format (it's not even letting me select it for lack of privileges), but if that's all I can do then so be it.

    It's saying it has no used space or available space (its half full)
  2. Brennan

    Brennan TS Booster Topic Starter Posts: 105

    I unplugged it and plugged it back in and it seemed to work, it said there was something wrong with it still and promted me to do another check disk scan which said there were no problems (I didnt select the "bad sector" option) (durr!) but I remember it doing something similar before, should I format it back to NTFS, Is that what is causing the problem?

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...