Need help with the 8 step program

By CSJ ยท 13 replies
Sep 30, 2009
  1. Update! I managed to get Malwarebytes to work. It removed 10 Viruses. I did 3 complete full scans. But I'm still getting the Error Message below when I try to open HiJackThis.

    1)"Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item"

    Also, I cannot install SUPERAntiSpyware. Every time I do try to install I get this Error Message

    2)"Error 1321. Windows Installer has insufficient privileges to modify this file: C/Program Files/SUPERAntiSpyware/SUPERAntiSpyware.exe."

    Then I'm given these three options. :Abort: :Retry: :Ignore:

    When I select Retry, nothing happens. When I select Ignore, the program installs. But when I try to open the program. I get the First above Error Message.

    I'm not sure what is causing this so, please, if anyone knows how to fix this please tell me. Thanks.
  2. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    Chris, let's keep the thread together. I'd like to check out those error messages before someone else addresses any malware issue you may have:

    It appears that you may be having a permission issue. Before I go further, please tell me what operating system you're using. I'd also like to know what problems you are experiencing- I just saw a joke on the other thread so you need to give us some information.

    I am also going to ask you if you are using a legitimate copy of the OS. We've had several people lately who were not, so when there are error like this, it's something that needs to be verified.

    Hold on those programs and let's handle this.
  3. CSJ

    CSJ TS Rookie Topic Starter

    I'm currently using Windows XP and yes it is legitimate. The problems I'm having are just the error messages. Earlier though my Google searches were getting re-directed. But that problem went away after running malwarebytes.

    Before I was infected all of my anti virus programs worked. If you want I can even tell you exactly when this started to happen. It started right after I download Bit-torrent. And I mean literally right afterwards. Within 10 minutes of downloading it. The funny thing is I didn't even download any torrents.

    I went to the pirate bay looking for an album. When I found it. I made sure that the the pirate bay said that the user was trusted. When I confirmed that he was I clicked the link (I DID NOT! download any torrent. I was still in the search bar). Right after that my computer started to freeze. Then I was suddenly exited off of IE and then a red "X" appeared saying I was infected. The red "x" is gone now but I still can't open up HijackThis or SUPERAntiSpyware. But I can open Malwarebytes and AVG Free.

    Anything else you'd like to know?
  4. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    Okay, let's try to troubleshoot the errors. 'Permission' errors can have multiple causes. I'd like you to try this:

    Un-install IE Enhanced security from Windows Components: (you access Add/Remove Programs through the Control Panel> Windows Components are on the left.

    On the Windows 2003 server, go to add/remove windows components, then uninstall the Internet Explorer Enhanced Security component.

    This has been the most consistent 'fix' for this error.

    If Mbam has not resolve a problem for you, since you know exactly wen this began, I would have had you try System Restore. But doing so now might undo what it did.

    If the above doesn't resolve it, do this: See if you find an Error that corresponds to the time of the Error message. If so, that will give us more information to work on.

    Start> Run> type in eventvwr

    Do this on each the System and the Applications logs:
    [1]. Click to open the log>
    [2]. Look for the Error>
    [3] .Right click on the Error> Properties>
    [4]. Click on Copy button, top right, below the down arrow >
    [5]. Paste here (Ctrl V)
    • You can ignore Warnings and Information Events.
    • If you have a recurring Error with same ID#, same Source and same Description, only one copy is needed.
    • You don't need to include the lines of code in the box below the Description, if any.
    • Please do not copy the entire Event log.

    Errors are time coded. Check the computer clock on message display.

    I also have 2 policy program you can try if this doesn't work and in truth, you might have to go through the full cleaning steps- problem is malware helpers aren't available right now. But we'll go one step at a time.

    I have taken it for granted that you are signing on as the Administrator- is that correct?
  5. CSJ

    CSJ TS Rookie Topic Starter

    Yes, I am logged in as Administrator. Also I could not find "IE Enhanced security" in Windows Components so I'm assuming I don't have it. I Forgot to mention (in case it matters later on) that I already UN-installed Bit-torrent.
  6. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    Good job Chris. But the errors can't be resolved. The permission problem does have a cause as far as I can determine, but you will need to go through the steps as originally outlined. Sorry, but is was worth the try.
  7. CSJ

    CSJ TS Rookie Topic Starter

    Just to make sure. Which steps are you referring to? The 8-Step Program? If so I'll try and see what I can do. Thanks for your help.
  8. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

  9. CSJ

    CSJ TS Rookie Topic Starter

    I was looking through the forums when I came across a link called Kaspersky Online Scanner. Someone named kritius suggested it to somebody. He use use it and save a log after it scans then post the log. My intentions are to hopefully do the same and let somebody fix my problem. Here's what he said to do

    If someone can read my log and tell me what to do. that would be great.
  10. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    Chis, this scan is usually used as a follow up. It's not meant to take the place of cleaning programs. And it 'finds' but it doesn't 'fix.' Until the permission/policy problem is resolved, it is likely you still won't be able to function.

    Here is a policy program. It is used to try and resolve a permission problem.

    FixPolicies.exe from Bill Castner:
    • 1Download FixPolicies by Bill Castner and save to your desktop
    • 2Double click on FixPolicies.exe to run it.
    • 3Click on Install. It will create a folder named FixPolicies on your desktop.
    • 4Open the FixPolicies folder.
    • 5Double click on Fix_policies.cmd to run it. Command Prompt will open and close quickly; this is normal.

    When you have finished, reboot the computer- see if it resolved the permission problem so you can run the appropriate scans.
  11. CSJ

    CSJ TS Rookie Topic Starter

    Thanks for your help. But. None of those links work. I get a "404 Not Found" message for both of them thanks anyways.

    I think I'm just going to leave things as they are for now. I might still have some Malware/Spyware on my PC but at the moment thing seem fine. Thanks for all your help.
  12. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

  13. CSJ

    CSJ TS Rookie Topic Starter

    I saved FixPolocies to my desktop and installed it. But when I ran Fix_policies.cmd it didn't work. command prompt comes on for 2 seconds and then vanishes. swreg.exe won't run either.

    What kind of virus is this?
  14. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...