Software Need to change/reset the driver of a playback device that I can't plug in

I was messing around with the drivers of my new headset in the "sound" menu on the tab "Playback Devices" (Was trying to get bass boost from enhancements menu that I needed to get through updating a driver-soon realised cant do it on USB headset) and ended up changing the driver for it to a Realtek driver which said it was not compatible but I was like oh well. After attempting to restart my PC it blue screened me. After an hour or so of trying to fix it I ended up unplugging my headset and got rid of blue screen. Now every time I plug it in it blue screens,It shows up in my playback devices but when I go in properties I cant change the driver of it whilst plugged in. I'm sure there is a way I can reset this playback device's setting but I am not knowledgeable enough to know. After 3 hours in total of trying to find a fix and fix this problem the only hope is factory resetting my PC which I don't want to do and can't.I hope someone can help me with this issue,thank you for reading.
 

Kshipper

Posts: 519   +116
TechSpot Elite
Type 'System Configuration' in the search bar (without the quotes) and run that app. Click on [Tools]. Click on [System Restore]. The [Left Click] Launch. Follow the prompts to roll your machine back to an earlier time before all this started. This won't affect your data.
---------------------------------------------------------
If that fails you can hold down the 'Shift' key and reboot to the troublshooter screen and use that to get to SAFE mode and see if you can plug it in there and change/uninstall the driver. Not sure if this will work.
 
Type 'System Configuration' in the search bar (without the quotes) and run that app. Click on [Tools]. Click on [System Restore]. The [Left Click] Launch. Follow the prompts to roll your machine back to an earlier time before all this started. This won't affect your data.
---------------------------------------------------------
If that fails you can hold down the 'Shift' key and reboot to the troublshooter screen and use that to get to SAFE mode and see if you can plug it in there and change/uninstall the driver. Not sure if this will work.
I ended up just messing around with some other drives and it fixed itself thanks for the help and I will follow what you say if I ever get theis problem again in the future.