1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Network problem help

By MTrainor ยท 11 replies
Aug 28, 2008
  1. I have a Linksys BEFSR41 v 4.3 wired router connecting two computers, both running XP. Both computers can share files and the "local" computer can use the printer attached to the "remote" computer. The local computer has internet access, but the remote computer says it has "little or no connectivity" and when I attempt to repair all I get is

    "Repair Local Area Connection

    Windows could not finish repairing the problem because the
    following action cannot be completed:
    Renewing your IP address

    For assistance, contact the person who manages your network."

    Unfortunately I am the person who "manages" this network so the recommendation was not very helpful.

    Each computer can ping the other and the router but the remote computer cannot reach anything on the internet. I spent over an hour with one of the Linksys phone help folks, but he could not resolve the problem. I must say that I am at a loss as to why I cannot connect with the internet via the router when I have no problem filesharing.
  2. NetCablesPlus

    NetCablesPlus TS Maniac Posts: 207

    Have you checked for a firmware update for the router in question? It sure does sound like a router problem. However, it is also possible that you have a firewall or antivirus problem on the remote computer that is blocking the connection. Have you tried turning all of those applications off (after you have checked, of course, to ensure that the machine is no infected, which might also be the problem?)
  3. InsaneVr6

    InsaneVr6 TS Booster Posts: 219

    If the error message said that it could not renew the IP address, then i believe you need to do that manually through the router's settings. It sounds like your router is giving the same IP adress to both computers which is cancelling one out.
  4. MTrainor

    MTrainor TS Rookie Topic Starter

    I tried dropping the firewall on the remote computer with no effect. I don't believe that it could be infected with anything yet because it hasn't ever been connected to the web yet... I will try to check the anti-virus software (AVG) to see if it is blocking anything...
  5. MTrainor

    MTrainor TS Rookie Topic Starter

    Firmware seems to have been up to date.
  6. MTrainor

    MTrainor TS Rookie Topic Starter

    Linksys BEFSR41 issues

    Further investigation has led me to believe that my router is not assigning any kind of IPA to the remote computer. It has been defaulting to the alternate configuration IPA, which I entered with a number in the router's range.

    There must be some setting on either the router's set-up (which is ironically web-based) or in the computer's settings that is preventing the IPA from being assigned, but still allows the remote computer to ping both the router and the local computer...

    How can I determine if the router is assigning an IPA, but the same one as the local computer already has and how do I correct that when I do?
  7. jobeard

    jobeard TS Ambassador Posts: 12,485   +1,428

    on the remote; find the NIC and under TCP/IP, click properties
    be sure that DYNAMIC is selected for both the IP and the DNS addresses.

    the default 169.x.x.x tells you the system did not find the DHCP service in the router
    (or did not even look for it)
  8. MTrainor

    MTrainor TS Rookie Topic Starter

    On the Internet Protocol (TCP/IP) Properties page on the General tab, both IPAs and DNS are set to be obtained automatically. I only entered information into the alternate configuration tab so I could at least share files.

    This has a new wrinkle. On a lark I unpluged the remote comptuer's ethernet cable from the router and stuck it directly into the cable modem. No connection (infact the connection speed went from 100 Mbps to 10 Mbps! I am at a total loss
  9. MTrainor

    MTrainor TS Rookie Topic Starter

    I have also checked the DHCP Client table in the Linksys Local Network Setup and the remote computer isn't even listed... What's going on?
  10. jobeard

    jobeard TS Ambassador Posts: 12,485   +1,428

    EMPTY the alternative config info as it will (and as already interfered) with the operation.
    Good for you -- that should have worked!

    Is the NIC even operational? check the Device Mgr for a red X or yellow ! on the device.

    What firewall are you using? the default XP FW will allow dhcp (port 67), but others could actually deny it.
  11. MTrainor

    MTrainor TS Rookie Topic Starter

    Switching the Alternate Config back to auto merely results in one of the local windows IPA being assigned and loss of all connectivity. I only have the Windows Firewall, which is deactivated. The only other thing might be my AVG Free antivirus Resident Shield, but I deactivated that as well with no result.

    Atheros L2 Fast Ethernet 10/100 Base-T Controller Properties claims the device is working properly

    I updated the driver to the most current for XP from the Atheros Communications website (www.atheros.com v2.6.7.15)

    Under [Advanced] are the following options (current setting first, alternates follow slash)
    Flow Control - on/off
    Interrupt Moderation - on/off
    Max IRQ per Second - set at 5000
    MediaType - Auto / 10 Mbps or 100 Mbps at Full or Half Duplex
    Network Address - Not Present / enter value
    Number of Receive Buffers - set at 256
    Number of Transmit Buffers - set at 64
    Shutdown wake up - off/on
    Wake Up Capabilities - Magic Packet & Pattern Match / All; Link Change; Magic Packet; None; Pattern Match

    Right clicking on the property window gets a "What's This" description. It says "These properties are device dependent. Read the device manufacturer's instruction manual to determine the correct property settings." I don't seem to have an instruction manual and can't find one on the Atheros' website as they seem to be pushing the wireless technology. I can't even guess what any of these do so I'm not going to monkey with them.

    Under [Resouces] I have
    Memory Range DFFC0000 - DFFFFFFF
    IRQ - 17

    There is no value for I/O and I don't see any way of setting one...

    Any suggestions?
  12. jobeard

    jobeard TS Ambassador Posts: 12,485   +1,428

    of course it looses connectivity -- leave it that way and now get DHCP to assign the
    network parms.

    this: Network Address - Not Present / enter value

    is due to ipconfig /all showing IP Address. . . or nothing at all

    you should see:
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...