Network switch faulty?

steeve

Posts: 103   +2
i have a tp-link 5-port switch which has worked without a hitch for about 2 years. now there are issues - sometimes i cannot get a network connection. if i power the switch down then up again, a good connection is restored.

the set up is like this:
dsl router direct to 2 computers and the switch, then two other computers and a printer through the switch.
i have recently done a major hardware upgrade to the two machines connected to the switch, but they are both running xp as before.

can these switches develop faults?
is it on OS problem?
it happens even with only one of the computers on the switch running
 

jobeard

Posts: 13,985   +1,782
yes, a switch can fail just like any other active component. I lost one port on mine but had a vacant slot so I just moved the cable to the vacant position.

fyi: the DSL Router ---> Switch is just fine, but be aware that the DHCP service of the Router is providing all the TCP/IP configuration data, even to the systems attached to the switch.

Your test for correct configuration is to run IPCONFIG /ALL on a working system and
then compare that to the results on a failing system.
Usually, it is obvious on the failing systems that the configuration is not correct.
It is possible however, that the failing system is configured correctly but still fails.

see Basic Networking for descrete testing of connectivity
 

steeve

Posts: 103   +2
  • Thread Starter Thread Starter
  • #3
thanks for that jobeard

i didn't know that the router supplies the config data even past the switch

i will check ipconfig /all from time to time and i'm working through your excellent networking tutorial.

i guess i have always given a wide berth to the whole subject, but i should really get to grips with it now!
 

steeve

Posts: 103   +2
  • Thread Starter Thread Starter
  • #4
it turns out the problem was not with the switch (or the cabling) but some router issue instead. if i take the switch out of the circuit, the problem still occurs from time to time. as a quick fix, i now have a bat file containing
Code:
ipconfig /release
ipconfig /renew
with a quick launch shortcut which i can hit as needed.

works for now, given that the problem only happens say 2-3 times in a working day

of course i can't find any pattern or obvious causes of this problem...
 

jobeard

Posts: 13,985   +1,782
hmm; manually performing the /release /renew success implies that the router automatic function is bum; look for a newer version of the firmware for your router.
 

steeve

Posts: 103   +2
  • Thread Starter Thread Starter
  • #6
ok, will try that

i have noticed that often when my computer is cut off from the network, someone else has just accessed the internet...

i've read some stuff about collisions...would i be better off with fixed ip addresses?
 

jobeard

Posts: 13,985   +1,782
hmm. you describe an issue for conflict in IP addresses, not collisions.

TCP is built to understand and tollerate collisions.

For all systems under your control:
make sure they all use DHCP to get the IP and DNS Addresses​
You need fixed (better said static) ip addresses only when you need to port forward from the
router to one of the systems.

In this case, use Address Reservation to associate the system MAC address with a fixed address . . . OR
assign a fixed address that is outside the DHCP range;
  • in the router, set the DHCP range from 2-50
  • and then assign static addresses beginning at 100--> (but less that 254)
 

steeve

Posts: 103   +2
  • Thread Starter Thread Starter
  • #8
make sure they all use DHCP to get the IP and DNS Addresses
i have checked that this is so

i think i will leave the system as dhcp for now - it has worked perfectly like that for years

i am slowly trying to elimnate possibilities from the mix - trying new cabling, etc

because the problem is intermittent makes it difficult to pin down...
 

jobeard

Posts: 13,985   +1,782
Q1? What ISP access are you using {DSL, Cable, Satellite} ?

Q2? Are any systems connecting to the router/switch using WiFi?
 

jobeard

Posts: 13,985   +1,782
AHHH - - verify that EVERY telephone has the line filter attached between the wall outlet and the phone
 

tipstir

Posts: 2,854   +199
i have a tp-link 5-port switch which has worked without a hitch for about 2 years. now there are issues - sometimes i cannot get a network connection. if i power the switch down then up again, a good connection is restored.

the set up is like this:
dsl router direct to 2 computers and the switch, then two other computers and a printer through the switch.
i have recently done a major hardware upgrade to the two machines connected to the switch, but they are both running xp as before.

can these switches develop faults?
is it on OS problem?
it happens even with only one of the computers on the switch running
Yes and it's call duff ports or ports going bad or are bad. The signs are if you had 10/100/1000 and connect a 1000mbps to the port the switch port on the switch would throttle down to 100mbps only or just send bad packet. The same duff ports can on your PCI Bus card or PCI-E Bus card also. Your suppose to do a trace-tone to check if the ports are bad. The switch or NIC should tell you also. Either the light is out or is not showing activity.

Best to just replace the switch or hub or NIC. Also note sometimes the Ethernet cable can cause issues too. Good to check the those also.
 

steeve

Posts: 103   +2
  • Thread Starter Thread Starter
  • #14
Either the light is out or is not showing activity.

Best to just replace the switch or hub or NIC. Also note sometimes the Ethernet cable can cause issues too. Good to check the those also.
Ok good idea to watch for light activity. The NIC is (integrated) on a brand new motherboard.

I'm thinking cables now - some are in the wall - but with a bit of luck one might be the culprit. or possibly a port on the router itself...

PS the manual /release /renew sequence is not always successful...
 

jobeard

Posts: 13,985   +1,782
/Release and /Renew are serviced by the router, not the switch, so imo the switch can be exonerated.

I've seen many comments accusing cables, but in 37 years, it is a rare event unless they
are exposed to rough handling, pulling, or have environmental exposures.

I still bet on the comment
router automatic function is bum; look for a newer version of the firmware for your router.
Have you downloaded & installed the latest firmware yet.
 

steeve

Posts: 103   +2
  • Thread Starter Thread Starter
  • #16
Have you downloaded & installed the latest firmware yet.
i have been a bit cowardly, having read bad stories about updating router firmware :)

but today i had the courage to download the latest firmware. the procedure looks quite straightforward for this router, so i guess i'll give it a go...

i noticed that ipconfig shows "node type - unknown" for my main computer

i tried the microsoft recommended registry edit to remedy this. could that make any difference?
 

steeve

Posts: 103   +2
  • Thread Starter Thread Starter
  • #18
ok great!

the microsoft fix didn't work for me

they say change HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters\\Enableproxy to 0 or 1

firstly i don't have that key. secondly, when i create it, it has no effect on node type

so currently looking for another solution...
 

steeve

Posts: 103   +2
  • Thread Starter Thread Starter
  • #19
Alright, i set up a new value:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters\\NodeKey = 8

and the node type now proudly shows as Hybrid in the config :)

small victories

"Specifies what methods NetBIOS over TCP/IP (NetBT) uses to register and resolve names"

sounds hopeful - will keep you informed

i might update the firmware as well when i see how it goes
 

jobeard

Posts: 13,985   +1,782
yes - - this is it. if you did the
Parameters\\Enab leproxy to 0 or 1​
then delete it.
 

jobeard

Posts: 13,985   +1,782
the path is HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters

but the key is NodeType Dword = 0x08

best double check ...
 

steeve

Posts: 103   +2
  • Thread Starter Thread Starter
  • #22
ok, have deleted EnableProxy entry and double checked NodeType entry. all good

many thanks - much appreciated