New build first boot no power

By MRichter28
Aug 25, 2011
Post New Reply
  1. I just built my new pc and it wont power up no mobo light,the fan on the PSU wont turn no anything.I am baffled i think its the PSU.I have checked for lose cords and even tried another power switch from my friends case that i know works.I think my PSU came trashed but the box was ok.

    MoBo:ASRock H67M (B3) LGA 1155 Intel H67 HDMI SATA 6Gb/s USB 3.0 Micro ATX Intel Motherboard

    PSU:Antec NEO ECO 520C 520W Continuous Power ATX12V v2.3 / EPS12V 80 PLUS Certified Active PFC Power Supply

    RAM:G.SKILL Ripjaws Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1333

    GPU:XFX HD-677X-ZNFC Radeon HD 6770 1GB 128-bit GDDR5 PCI Express 2.1 x16

    CPU:Intel Core i5-2400 Sandy Bridge 3.1GHz (3.4GHz Turbo Boost) LGA 1155 95W

    Seagate Momentus XT ST95005620AS 500GB 7200 RPM 2.5" SATA 3.0Gb/s with NCQ Solid State Hybrid Drive

    Case:COOLER MASTER HAF 912 RC-912-KKN1 Black SECC

    I also tried booting it with just one stick of RAM the PSU and MoBo.Nothing still
  2. Arris

    Arris TS Evangelist Posts: 4,730   +379

    Check that your system isn't being shorted out by any of the motherboard mounting screws. Try testing outside of the case if in doubt. Other than that it sounds like you could have a DOA component.
  3. MRichter28

    MRichter28 TS Rookie Topic Starter

    OK so the case was shorting it out,but i left the leds hooked up and i have a red on on my case

    ok so i put the MoBo back in it did not work, its not touching the case i think its the screw anchors becasue it wont power up with no screws how would i pad this if it is the cause, also the ring around each hole is rather lacking and a full O its more or less () missing some on each side

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...