New WD external drive not being read on XP

By constantobstacl · 156 replies
Dec 6, 2008
  1. mflynn

    mflynn TS Rookie Posts: 2,655

    This should fix most of that!

    Download Dial-A-Fix (DAF)

    Have XP CD available in case DAF needs a file.

    Check all boxes on the screen (clear any restrictions if it shows any)
    Then click GO!

    When the entire page is finished click the HammerHead at bottom to go to the second DAF page.

    Here 1 at a time do the below

    Reinstall Automatic Updates service
    Reinstall BITS
    Reinstall Help and Support Service
    Reinstall Windows Firewall
    Repair Permissions
    Reset networking

    Watch for any File not found or other errors and make note as this may lead to the fix!

    Reboot retest!

  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Boy, you sure weren't kidding when you posted that above!
  3. constantobstacl

    constantobstacl TS Rookie Topic Starter

    ^ LOL
    ^^ Thank you Mike!
    I got as far as "Reinstall BITS" but it was asking for at least a couple files so I stopped; "gmgr.dll" and "gmgrpxxy.dll"--sorry if mistyped, it was hard to see. I HOPE to get the XP cd today, but what should I continue if I don't?
    I'll update this post with the result of starting windows update:
    H&S: same msg
    WU: gives me a download button after stating "To use this latest version of Windows Update, you will need to upgrade some of its components. This version provides you with the following enhancements to our service:"
  4. mflynn

    mflynn TS Rookie Posts: 2,655

    Ok you made it thu everything on the first page. Right!

    If so you made progress in the stability of this computer.

    If so move on to the other steps after Reinstall BITS. Get all of these you can.

    Then D/L and install BITS 2.5 from Microsoft

    New Windows Installer 4.5

    Then Windows Update agent: to the Desktop:
    then Start-Run
    type CMD
    hit enter or click OK.
    At cmd prompt type or copy paste
    net stop wuauserv

    then copy all in the box below also to the CMD prompt
    "%userprofile%\Desktop\WindowsUpdateAgent30-x86.exe" /wuforce 
    including the quotation marks. Follow the prompts to install the new WU Agent

    Then paste
    net start wuauserv
    into the open cmd prompt.

    Reboot retry the Winupdate.

  5. constantobstacl

    constantobstacl TS Rookie Topic Starter

    Mike, thank you! All this help and all these options after each of my obstacles, is great! :D
    I came to the computer to try your next steps, and I saw the update icon! I am updating but am going to try these steps as well!
  6. mflynn

    mflynn TS Rookie Posts: 2,655

    No this was to help you get the updates!

    I would do no more than get the all the updates and see if you now have what you need to finish LookingArounds restore process and continue that.

    For sure the DAF is a good strightener outer, do that later. But if win update works properly the others are not necessary. Altho they would not hurt!

  7. constantobstacl

    constantobstacl TS Rookie Topic Starter

    It wouldnt allow me to do 'Help & Support' either, but I'm on Permissions now, which is taking a long time (its on 2/2). So I have cancelled the updates (was on 2/2--IE7) to see if that helps
  8. constantobstacl

    constantobstacl TS Rookie Topic Starter

  9. constantobstacl

    constantobstacl TS Rookie Topic Starter

    ^ when I would enter net start wuauserv, it would advise me that it has already been started.
    - I no longer see the windows update icon
    - Help & Support from the start menu still does not work
    - IE would give an error that it needs to close, before it would open, so I am installing IE7 manually..just hope it doesnt take a lifetime like before where I had to cancel*
  10. constantobstacl

    constantobstacl TS Rookie Topic Starter

    I went ahead and tried to mount again with acronis, and this time I got this error:
    "Cannot assign a drive letter to a partition from the backup archive."
    Do not know why....
    & IE7 is still "downloading updates..."?
  11. constantobstacl

    constantobstacl TS Rookie Topic Starter

    ok now the IE7 download has disappeared??? And nothing is happening....
    (sorry for not just editing but that last post took a half hr to finally get done!) :(
  12. mflynn

    mflynn TS Rookie Posts: 2,655

    I use Acronis so rarely that I recommend you wait for Lookingaround!

    When you get back to Malware removal on the other system I will try to help.

  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    hi again!
    As to the Acronis issue : May be result of conflicting drive letter assignments in Windows. Will chek that first (e.g. USB drive is mounted for first time. Windows mounts it on drive letter E: It's then removed from Windows makes drive letter E: available.. Then someone creates a network file share. Windows may re-assign E: to the file share. If USB drive is remounted now is a problem! Mountmanager tries mounting on the its last mount (E:) Don't know why Microsoft can't get this darn bug fixed!)

    1. Download a couple tools (the download files are compressed so you'll need to unzip) Save the unzipped executable in folder C:\Windows\system32 folder
    - Download listdosdevices
    - Download drivecleanup
    2. Open a command window. Start->run->cmd
    3. Enter cls (Clears the command window. Not so much needed now but if you were repeat things in same window and have a bunch of output in that window can be helpful)
    4. Enter mountvol
    5. Enter listdosdevices
    6. Enter drivecleanup -T (Note; that -T option is important. makes the command display only so the command takes no other action)
    7. rt click on command window's title bar across the top of window. Edit->SelectAll, Edit->Copy. Then paste into a .txt file and attach to next post
  14. constantobstacl

    constantobstacl TS Rookie Topic Starter

  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    ==> The files you provided look OK. So don't think it's a drive letter conflict
    ==> Would normally suggest filing the problem with Acronis support to get them involved in parallel but as appears there’s still windows issues maybe best hold off a bit on that (at minimum we’ve seen the error message change after some windows installs)

    So try the following
    1. Start Acronis. Click Help->About. What version / build number is installed?
    2. Go here . Click Get Updates to check if any updates since they created the build you downloaded
    3. See Chapter 11 in User Guide and validate the backup archive
    4. I re-read your posts. U said that Explore and Mount give same error? I checked and Chapter 12 of User Guide says Explore supposedly doesn’t assign a drive letter??? Can you try Mount vs. Explore again (rt click on the backup .tib file, select Explore)
    5. Refer Chapt 12.3 on Mounting an image
    ==> Step 3. Does wizard show just one partition to select or does it show more then one partition in your disk image?
    ==> Step 4. Attempt the mount with the Mount read/write check box selected as well as unselected
    6. Start Acronis then
    ==> Click Start->Run, enter: msinfo32
    ==> Expand Components, click Problem Devices. Anything appear? If yes, click it and copy/paste to next post
    7. From Acronis window, click Tasks and Log (see also Chapter 11.3). Select (or create one) a recent log file when you had tried doing the mount as well as the Explore ("Recent" as in choosing one where you the most error message is now occurring) Save log to disk and attach to next post
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    And some things as to Windows Updates....
    1. Try the Windows Installer 4.5 from this link
    You mean the yellow icon that appears in the Notification Area (with other icons at bottom, lower right of your desktop)?
    ==> First make sure Notifcations not set to hide icons. Rt click on Start, select Properties. Click Taskbar. Uncheck Hide Inactive Icons.
    ==> Also note the windows update icon is a notification that updates are waiting. It will routinely disappear if update agent thinks all updates installed.
    3. Have you completed the updates for IE7? Or still having problems with it?
    4. Click here to check if you can now manually run a Microsoft Update. Click Custom and try geting updates
    ==> Check no high priority updates appear
    ==> You’ll also see Hardware and Software Optional Updates
    ==> Typically, is good to install all Hardware optional updates (review them. If any you’d rather not install or have a question let us know)
    ==> For software optional, some are microsoft apps (like Silverlight,Windows Search and Media Player) are up to you if install or not
    ====> I’d install any Root Certificates
    ====> Forget what else might appear so of course feel free to ask if not sure if you want it
  17. constantobstacl

    constantobstacl TS Rookie Topic Starter

    Sorry for the delay guys, since Friday my furnace was broken-so it was way too cold to be in the room to deal with the computer. What a sudden expense to have right at Christmas! :( I am going to continue this tonight. Thank you so much, Merry Christmas and Happy Holidays!
  18. constantobstacl

    constantobstacl TS Rookie Topic Starter

    1. Start Acronis. Click Help->About. What version / build number is installed? --sorry this option is not possible with the program I have...I tried to search for it as well...but its Acronis True Image Home 2009...
    2. Go here . Click Get Updates to check if any updates since they created the build you downloaded --dont see any recent updates
    3. See Chapter 11 in User Guide and validate the backup archive--I am doing this now but it may take awhile...I will post and continue once complete...

    Thank you!!
  19. constantobstacl

    constantobstacl TS Rookie Topic Starter

    ^ Yes, it was that icon, but it is back now! It's just having problems as it seems to download to my external drive it did with IE7, but I have that now too. SP3 didnt seem to complete or install though.
  20. constantobstacl

    constantobstacl TS Rookie Topic Starter

    Update: I downloaded Windows Installer 4.5 but am unable to restart the computer until Acronis' Validation of the backup is complete. It has been running for 14 hrs with an expected time of 3 days to complete: 18% is complete with 2 days looks like it will be completed late/at the end of Tuesday night.
  21. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Wow. That sounds awfully long time but don't know. Probably best to err on the side of caution and as long as isn't hanging let it run to completion.

    Pure curiousity (if you know)
    - How large is the backup file?
    - Does that older computer have USB 2.0 ports? or only USB 1.x?
    - Rt click My Computer -> Properties.. on the first display does it say what type of Processor?

    And i started on writing up some new instructions. I guess is no hurry now!

    and other passing thought if it comes down to it after trying to get your old computer up and together again: Any friends with a laptop? (just so you needn't try transporting your external). install and run acronis to check backup, then uninstall acronis
  22. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Had to go back to refresh my memory of where we were! (did you ever get those XP install disks?)

    Remains to be seen if open Windows issues may also cause Acronis problem. But you can opt to look at Acronis stuff in parallel if you want while we clean up your Windows environment. I’ll take a quick look thru any Windows issues next. But can suggest search for / install Belarc Advisor as its report includes a list of currently installed Windows Updates (among other useful stuff)

    Acronis Stuff
    1. Acronis Version/Build
    => As no Acronis updates, you probably have latest. But to find this info in future see Acronis.gif attached. (checked to find they do it this way)
    => Note Acronis Window on left. No menu bar (with Help). But has tiny arrow icon on far left of very thin bar you click to display/hide the Menu Bar)

    2. Check Acronis Device Drivers
    Note: You can edit/paste to command windows vs. re-enter. See here and note "clicking" upper left corner = clicking left side of title bar (very top bar)
    => Start->Run, enter cmd
    [B]set devmgr_show_nonpresent_devices=1[/B]
    [B]start devmgmt.msc[/B]
    When device manager starts
    => Click View->Show hidden devices, then expand Acronis Devices.
    => Rt click each device, Properties. Does it say working? Or give an error code?

    3. Referring to User Guide Chpt 12.3
    => Try mounting image set for READ ONLY access (don't if you tried this or you've been doing read/write. Saw problem reports where this sometimes made the difference)
    => Try selecting drive letter Z

    4. Explore vs. Mount
    Rt click to Open the backup file (.tib extension) and try looking at stuff. This will Explore rather then Mount. Explore doesn't perform a drive letter mount. Does Explore give the SAME error or a different result?

    5. If problem remains
    => If file C:\Windows\setupapi.log exists make a copy and keep it. Then delete original.
    ==> Open notepad ( Start->run, notepad.exe) copy code below, save as x.txt the rename to x.reg
    => Double click x.reg to apply registry update
    Windows Registry Editor Version 5.00
    => Re- attempt the Mount and the Explore (for fresh data collection)
    => Open command window, enter/copy code below into it (it;s one long command line)
    cscript "C:\Windows\system32\eventquery.vbs" /fi "Datetime gt 12/28/08,12:00:00AM" /fo list /v /l system /l application > "%USERPROFILE%\DESKTOP\EventData.txt"
    => Attach to your next post C:\Windows\setupapi.log and EventData.txt on your Desktop
  23. constantobstacl

    constantobstacl TS Rookie Topic Starter

    Well it took 6 days instead, because I had to start over :( (power was manually shut off to do some lighting work). My backup is now validated!!

  24. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    YEA! (now, where's parade icon. Surely you;d get one by now!)

    Well, as you have the time... let me know how how the other stuff comes out (not like i know i even needed to say that!)
  25. constantobstacl

    constantobstacl TS Rookie Topic Starter

    finally able to continue to Step 4 for windows update:

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...