Newly built computer won't turn on

By oxeimon ยท 5 replies
Jul 3, 2008
  1. So I've built two computers before, both without any trouble, but this one for some reason is acting up. More specifically, after putting everything together, when I turn on the PSU and hit the power button, nothing happens. When I turn on the PSU, the blue-standby LED on my mobo turns on, but nothing else (no fans, nothing). Hitting the power or reset button(s) does nothing.

    I've cleared the CMOS (moved the jumper, then moved it back), and I've tried connecting the POWERSW connector from the power button both ways (ie, +/- and -/+). Nothing helps. Here are my specs. Help would be *much* appreciated.

    NOTE: The very first time I turned the PSU on, the fans moved a little bit, and then nothing. Fans would not move afterwards.


    Intel Core 2 Quad q9450 2.66ghz
    2GB Corsair DDR2 800 RAM
    EVGA nforce 780i SLI motherboard
    EVGA GTX 260
    coolmax 1200W PSU
    Seagate 640gb SATA hard drive
    some random cd/dvd drive
    Cooler-master cosmos rc-1000 computer case
  2. oxeimon

    oxeimon TS Rookie Topic Starter


    I've got my entire motherboard out of the case (sitting on a couple of books), Everything connected, except a few USB cables and fans...

    the system as it is now is:

    intel core 2 quad q9450
    HIS Radeon x1950 PRO
    EVGA 780i mobo
    2gb DDR2 800 corsair ram
    COOLMAX 1200w PSU
    640gb seagate SATA hard drive...

    Same problem, when I turn on the PSU the blue LED on the mobo goes on, but nothing happens when I hit the power switch.

    Ive also tried manually "shorting" the two pins where the power switch connector goes, nothing happens. Would this be the expected behavior if the CPU is bad? (badly connected, DOA/dead on arrival) ?

    please help.
  3. _FAKE_

    _FAKE_ TS Rookie Posts: 116

    A few things could be the problem as I've had this problem before.
    1. Your motherboard can be defective and may not work properly.
    2. Your PSU might have a slight problem. When I got my Corsair HX620 it would have similar problems as what you've explained. I had to give it a little beating in order for it to work properly again.
    3. You may have tightened the screws on your motherboard to tight or you might have to many screws on it altogether. Its a little odd I know but my first motherboard I owned would only accept 5 screws holding it down. If I put in another screw the motherboard would refuse to work.
    4. Perhaps pulling it apart and rebuilding it could help, there might of been something you did wrong during the building process.

    There are probably other problems too but they are just a few that came to my mind straight away.

    I am curious to know why you picked the GTX260. The HD4870 is a lot cheaper and is faster than the GTX260 in most games and in overall performance. The GTX260 is also a crap release as nVidia is already ditching them along with the GTX280 in replacement of new 55nm revision GTX260 and GTX280s that will support DX10.1.
  4. oxeimon

    oxeimon TS Rookie Topic Starter

    Thanks for your response _FAKE_.

    Can you say if this could be caused by the CPU for any reason? I ask because RMA/refunds on CPU's have a relatively short timeframe.

    As for the motherboard having too many screws, I can say that the motherboard is currently out of the case sitting on a couple of books, so that can't be the problem.

    The PSU is a interesting thought, and I will try replacing it with another PSU I have lying around that I know works.

    As for the GTX 260, I got it from EVGA so I'm just using it for now, and will trade it in for store credit equal to the amount I bought it for when the new cards arrive.
  5. oxeimon

    oxeimon TS Rookie Topic Starter


    I have tried using another power supply. However, this power supply does *not* have an 8-pin CPU power connector, but only has a 4-pin connector. I tried plugging the 4-pin connector into the 8-pin CPU power slot, and when I turned on the PSU and hit the power button, the fans would start, and then stop. Further presses of the power button does nothing, until I restart the PSU.

    Note that before, even after restarting the PSU, the power button doesn't do anything.

    Do you think the PSU is the problem?
  6. _FAKE_

    _FAKE_ TS Rookie Posts: 116

    Yes I had a very similar problem. You hit the power button, the fans spin for a sec than immediately slow down to a stop, you can press the power button as many time as you like and nothing will happen. You turn the PSU off for 5 seconds than back on and the exactly same thing happens.

    Your likely got a hardware failure somewhere and its not always easy to find. I usually just get frustrated and start hitting all the components and stuff (not really caring if I break something, mind you I'm angry when I do this:p ). Sometimes it gets it working sometimes it doesn't. Sometimes the PC just needs a little nudge to get a component working again.

    Have you tried just using one RAM module instead of 2 or more?. And try in different RAM slots, so if you got 2x2 GB than you have to try 8 different configurations.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...