No audio device

By tamalex ยท 8 replies
Oct 24, 2009
  1. Here is the problem. Have a home grown computer bought from a computer store. No name brand associated with this computer other than the old ram, which I replaced today. The computer came with (2) 1 GB 5300 DDR2 (by Samsung) and I replaced both of those today with Kingston (2) 2 GB 5300 DDR2's. When I started it all up there were minor issues which I was able to correct. The main problem, sorry for the long post- just frustrated now, is that there is NO SOUND. I have run diagnostics and they are telling me the sound device is runing fine. WHen I did a DiagnosticX report it tells me: No sound card was found. This puzzles me as my sound is onboard! And, the next issue is that the ram is not showing 4GB, it is only showing 2.98GB. What am I missing?

    Thanks for any and all help that will save my hair! >.<

  2. fw2004

    fw2004 TS Booster Posts: 152

    Are you sure that your board supports the current RAM?
    It is possible that if you installed the wrong RAM, it would mess up other devices.

    Try going back to the old config and see what happens.
    Perhaps it's just something as simple as a loose connection that developed while you were installing the RAM.

  3. tamalex

    tamalex TS Rookie Topic Starter

    No sound Device


    I tried that. I went through a system restore and there was no luck. I have tried all that I know and I am not sure what the problem is. I, too, thought there was an issue with a loose connection and there seems to be no problems there, either. I am sure the RAM is correct as I went from one set of 1GB PC2 5300 DDR2's to a set of 2GB PC2 5300 DDR2's. The only difference is I went from Samsung to Kingston. I only changed the GB. Any other ideas that I might be overlooking?

    Thanks, again,

  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    See if Windows reports any problem devices
    • First make sure all your devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post

    If no devices are reported above check in your BIOS and look for any option to enable/disable onboard sound (you want it enabled, of course)
  5. tamalex

    tamalex TS Rookie Topic Starter

    No Sound Device

    Thanks, Lookin'. That was a no-go as well. BIOS showed onboard as enabled and the msinfo32 showed no problem devices. Not really sure where to go from here.

  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    This just helped me.. maybe will also help you...

    I've been digging into HDAUDIO sound driver issues for the last year. And thought i'd seen 'em all. Oddly enough, i've been working on a similar problem as yours with my nieces computer. Even though it has HDAUDIO onboard sound, the devices aren't detected, none appear in Device Manager and thus none of the audio drivers will install

    Well, i just got past that problem!

    I think (at least one) source of the problem results in the order in which the chipset drivers are installed (which affects the order in which devices are detected by Windows)
    > Does the MS UAA Bus driver appear under your System Devices?
    > Probably yes.
    > Yet you don't see any HDAUDIO devices appear under your Sound Devices? (or be listed as "Other" or Unknown devices - they'd appear with yellow icons if detected but have driver problems)
    > In my case the HDAUDIO devices appeared NO where in Windows

    I decided to try a sudden hunch. I
    > Uninstalled the MS UAA Bus driver and then clicked Action->Scan for New Hardware
    > And! now (since all the chipset and other needed drivers are there and working), when the UAA Bus driver was reinstalled it detected the audio devices connected to it and the HDAUDIO devices appeared!
    > I still haven't tried loading their drivers but getting them to appear is 95% of the battle (i think/hope)

    Hope this helps... let me know if it does or doesn't do anything for ya
  7. fw2004

    fw2004 TS Booster Posts: 152

    What OS are you running?

    Check in Control Panel, Sounds and the Devices tab. Make sure that Windows can find the device.
    If none are listed, try re-installing the drivers for the sound.

    Also, since you changed system RAM, you may need to update or re-install the Chipset drivers.
    Check the Device Manager to see if there are any unrecognized or devices not working properly. If you find any, re-install the drivers.

    Finally, I know this may sound stupid, but I have to ask:
    Are you sure that you plugged the speakers or headphones into the correct jack on your computer?

  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Go to Start > Run > Regedit > OK
    Expand [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum]
    Locate and highlight the folder "HDAUDIO" by clicking on it
    Go to File Export and save the HDAUDIO registry as a backup
    Delete the registry folder "HDAUDIO" (Note: you may need to change 'Permissions' to allow yourself access ie Edit > Permissions > Full access)

    Message will appear on start up that you have a missing driver.
    Install the latest drivers

    Restart again
    Test your sound
  9. tamalex

    tamalex TS Rookie Topic Starter

    Okay. Went through all of the suggestions made by every helpful person who respnded. Nothing worked so I went and bought a soudn card. Bought a Diamond Extreme Sound 5.1 Installed it, after trying the AZALIA as "disabled" and "auto." Problem now is: there is sound but it is full of static. Not sure what to do from here as I have exhausted all that I know. Any further help woudl be GREATLY appreciated. And, thanks again to all who helped out in the beginning. You were all so great and quick to help out! :)

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...