No bootable device found - Intel BLKD975XBXLKR

By DEXether
Apr 3, 2011
Post New Reply
  1. The raid array in one of my machines recently died (two SATA WD2500JS's) so I got a Seagate (ST3160318AS).

    After putting it in the 0 position on the board with a new sata cable, I started getting the "No bootable device found -- insert a bootable disk and press any key to continue." error even with my windows disc in the dvd drive.

    I started swapping around things into other machines and found the drive, the sata cable, and the optical drive to be in working order but I still get the same error. I then put the Seagate in another machine, installed windows on it, threw it back into the computer I wanted it in, and I still get the error. I have tried the drive in all of the sata positions on the board and the bios does recognize it in every position.

    Last night I pulled out the CMOS battery and defaulted the bios to no avail. I just thought it would be worth trying since I am all out of ideas.

    This is such a weird problem. To summarize: Windows will not boot from the hard drive, Windows startup will not boot from a dvd, other operating systems will not boot from usb, and all parts are good (I don't know about the motherboard since I have no way of troubleshooting it, although the bios recognizes the optical and the hard disk).

    Any help will be greatly appreciated.
  2. Airchief

    Airchief TS Rookie

    Intel D975XBX2KR No Bootable Devices

    Same problem here...No Sata HD, No EIDE, No DVD, none of the storage devices are found...Tried a second D975XBX motherboard same problem, updated to latest board bios, no help. I know CPU is good (Pentium 4 #521 2.8 GHZ, LGA 775, the drives are good, the DVD is good, can't get anything recognized by either board...Bios identifies the CPU and Memory (DDR-2 2.0 Gig) all good, but nothing else works...Can't run anything from DVD, HDD or Floppy...USB works that's how BIOS was updated, but without being able to boot, run .exe files. I'm dead in the water...this is a spare PC, just trying to get it running after a power supply failed...research in progress with little success...

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...