No drive attached to fasttrack controller no bios installed?

By RoccoWoodbridge ยท 4 replies
Apr 27, 2009
  1. Hi everyone.......i have this machine from a friend at work and every time i power up his machine.....i get the dos screen and its trying to detect some drives and then after about 5 seconds i receive this error .....

    "No drive attached to fasttrack controller no bios installed"

    After this happens windows xp tries to load (windows xp logo appears) and then it just suddenly reboots and begins over again with the same steps listed above.

    I have gone on the web and tried disabling the onboard promise controller but all that does is not display this message "No drive attached to fasttrack controller no bios installed " on the screen and just skips to windows xp trying to load again but to no veil.........the hard drive is connected to an IDE Controller and not a raid controller on the motherboard........would anyone here be willing to give me a hand please......ive been at this all day with no success.......any help would be greatly appreciated....Thanks guys
  2. davisjaron

    davisjaron TS Member Posts: 82

    Trying booting the recovery disk and see if you can restore and reformat the hard drive. If that doesn't work, it's possible it's a hard drive failure. Take the hard drive out and put it into another computer and see if it is recognized (not as a boot drive of course though).

    You are getting bios beeps right? Does it post at all (show the manufacturers logo)?
  3. RoccoWoodbridge

    RoccoWoodbridge TS Rookie Topic Starter Posts: 16

    Thank you for the reply.......No i do not receive any bios beeps what so shows the asus screen (asus motherboard) and asks me to hit delete or tab key for bios.......from my perspective it is trying to read the hard drives from the sata connectors but my hard drive is connected through an IDE cable/connector.....its been working like this for a very long soon as i turned off the computer one night and tried booting the very next morning i received this error.....very strange
  4. fosseland

    fosseland TS Rookie


    I had this problem with a couple of PC's (it also appeared randomly) it's generally to do with a Raid controller, which has been enable in the BIOS,(Promise is the manufacture of the RAID chip) this is my cases was the SATA controller, (although on one motherboard I had, it was an addition IDE Raid controller.
    If you are not using any SATA drives, and continue to find the message annoying then you can safely disable the onboard SATA (and/or IDE) Controller within the BIOS. If you need anymore info, then post your motherboard model no, and I'll do a bit of digging!

    Hope this info helps!
  5. RoccoWoodbridge

    RoccoWoodbridge TS Rookie Topic Starter Posts: 16

    Ok great !!!! i will post that for u tonight when i get home from work......thank you so much
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...