No Ethernet/Networking Controllers?

By JeffJeff1 ยท 15 replies
Sep 9, 2008
  1. Hello, I`m having a bit of a problem on my laptop (I`m using a different computer to write this). I Completely rebooted the computer so it would be fresh and fast agian, but now I can't seem to connect the internet. I am at a constant 400.0 Mbps, status is connected. I have a router going to both computers so its not the router (or else this comp wouldn't work).
    Here's a list of what I tried so far.

    -uninstall reinstall tcp/ip.
    -winsock fix
    -set up a new connection
    -tried to install drivers to make the "?" go away beside ethernet/network controllers.
    -changed wires from router.
    -ip config /all (just blank after)
    -repair the connection (says, "failed to query TCP/IP settings of the connection")
    -tried a fix in CMD ip reset all etc.

    So as you can see I'm desperate. I tried downloading drivers for the computer off toshibas website but under device manager it still doesn't recognize an ethernet or network controller.

    Under +IEEE 1394 Bus host controllers
    -Texas Instruments OHCI Compliant IEEE 1394 Host Controller
    Under +Network Adapters
    -1394 Net Adapter

    I dont think either of those things will help me connect to the internet. My computer specs are as fallows:

    Toshiba Satellite A100-PSAA8C-0FH00E
    I've installed the Lan driver which is supposed to be for my system from the toshiba site ( (2.31 MB) But still no recognized ethernet/network controllers, please, any help at all would be greatly appreciated. Thank you in advance to any1 who at least took the time to read this.

  2. NetCablesPlus

    NetCablesPlus TS Maniac Posts: 228

    Try re-setting your router and, if that does not help, check to see if there are any updates to the firmware for the router and install them, if available.
  3. JeffJeff1

    JeffJeff1 TS Rookie Topic Starter

    I tried, its not the router its the computer I`m sure of it.
    Any ideas? Thanks for the quick reply btw! Appreciate it!
  4. CCT

    CCT TS Evangelist Posts: 2,653   +6

  5. JeffJeff1

    JeffJeff1 TS Rookie Topic Starter

    I`m not sure if this is what your asking for, please bear with me,
    I`m semi new to this (not a complete newb, but far from a computer programmers specs).

    I have an Intel i945GM/PM "Calistoga" motherboard chipset.
    Does that help? If theres a specific location on EVEREST that says what your looking for I will gladly look it up. thanks for you help!
  6. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Download and run Everest Home (it is free):

    Once you download it, click on it and let it install and then run it from the icon on your desktop.

    Click on the + sign beside 'Computer', then on 'Summary', then go to the VERY Top of the screen and click on 'report'.

    Note: the 'Very Top' isn't one line down, it means what it says.

    Cursor over 'quick report-summary' and then click on 'plain text' and then click on 'save to file' and change the 'save in' folder to 'Desktop' and then click 'Save'.

    Clear all your open windows and on the Desktop click on that 'report.txt' icon - this will open it in a text editor
    (probably Notepad) and then use your mouse to highlight ALL the 'debug' entries and delete them, then use your mouse to hilight all the remaining text then copy and paste it to here.

    For future reference: once you open Everest, click on file, preferences, report and uncheck the 'include debug information in the report' box. People rarely want to see that stuff.
  7. JeffJeff1

    JeffJeff1 TS Rookie Topic Starter

    --------[ EVEREST Home Edition (c) 2003-2005 Lavalys, Inc. ]------------------------------------------------------------

    Version EVEREST v2.20.405
    Report Type Quick Report
    Computer GOSH-90D0720943
    Generator Gosh
    Operating System Microsoft Windows XP Home Edition 5.1.2600 (WinXP Retail)
    Date 2008-09-14
    Time 20:52

    --------[ Summary ]-----------------------------------------------------------------------------------------------------

    Operating System Microsoft Windows XP Home Edition
    OS Service Pack Service Pack 2
    DirectX (DirectX 9.0c)
    Computer Name GOSH-90D0720943
    User Name Gosh

    CPU Type Mobile DualCore Intel Pentium M, 1600 MHz (12 x 133)
    Motherboard Name Unknown
    Motherboard Chipset Intel Calistoga i945GM/PM
    System Memory 1013 MB (DDR2-533 DDR2 SDRAM)
    BIOS Type Phoenix (05/11/06)

    Audio Adapter Intel 82801GBM ICH7-M - High Definition Audio Controller

    IDE Controller Intel(R) 82801GBM/GHM (ICH7-M Family) Serial ATA Storage Controller - 27C4
    Disk Drive HTS541010G9SA00 (100 GB, 5400 RPM, SATA)
    Optical Drive PIONEER DVD-RW DVR-K16A
    SMART Hard Disks Status OK

    C: (NTFS) 95385 MB (92445 MB free)

    Keyboard Standard 101/102-Key or Microsoft Natural PS/2 Keyboard
    Mouse PS/2 Compatible Mouse

    USB1 Controller Intel 82801GBM ICH7-M - USB Universal Host Controller
    USB1 Controller Intel 82801GBM ICH7-M - USB Universal Host Controller
    USB1 Controller Intel 82801GBM ICH7-M - USB Universal Host Controller
    USB1 Controller Intel 82801GBM ICH7-M - USB Universal Host Controller
    USB2 Controller Intel 82801GBM ICH7-M - Enhanced USB2 Controller
    Battery Microsoft AC Adapter
    Battery Microsoft ACPI-Compliant Control Method Battery

    The names of actual companies and products mentioned herein may be the trademarks of their respective owners.

    Once agian thank you very much for taking the time to help me.
  8. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Well, that didn't help - no real ID on the mobo other than chipset - just go to the Toshiba site and download the LAN drivers (both, each to its own NEW folder, and try installing them one at a time.

    Select Notebook, Satellite, A100, PSAA8C-0FH00E and you get 2 choices, Intel Pro 100 and Intel Pro 1000.
  9. JeffJeff1

    JeffJeff1 TS Rookie Topic Starter

    Yea this has to be the most difficult computer in the world to work with. Thanks for your help but I tried both of those alrdy, they are uninstall programs =(. I ran them both just incase to see if anything would happen but unfortunately nothing.
  10. culley

    culley TS Rookie

    Do you mean that in device manager its not being recognised?
  11. Frenzy

    Frenzy TS Rookie Posts: 40

    does the device show in device manager??
    if not have you tried lookin in the bios to see if its enabled?
    if its enabled an not showin in devece manager then thres a possibility thats its screwed.
  12. JeffJeff1

    JeffJeff1 TS Rookie Topic Starter

    I check the BIOS, and theres no option that lets me disable/enable LAN drivers or anything of the such. Yes, the Device manager is showing ? in device manager.
    Any idea's?
  13. CCT

    CCT TS Evangelist Posts: 2,653   +6

    "I had the same message after running a bunch of virus checkers and deleting everything they found.. AVG, SuperAntiSpyware & AVS.
    "failed to query TCP/IP settings of the connection" suddenly became an issue after a reboot from running AVG a final time in Safe Mode.

    Finally I did a file search for tcpip.sys and renamed every instance to "tcpip.sys_old" - essentially disabling it... Windows XP message came up immediately saying it needed to repair itself but I waited and proceeded to rename all instances of tcpip.sys found and then followed the instruction window and inserted my Windows XP disk and let it have its way with my computer... rebooted and wow! CONNECTION RE-ESTABLISHED all on its own. That is all I did.. no expert believe me, I have no clue why it worked, just used my imagination. ;-)"

  14. hittman

    hittman TS Rookie


    I know it's not technically a fix.... but you could always buy a PCI ethernet card or USB ethernet adapter for $15 at your local electronics store. That won't fix your malfunctioning port, but it will get you online. :)

    I noticed you said that you re-formatted the laptop with XP SP2. Did it used to have another OS like Vista before? If so, the drivers may not be compatible with XP... just an thought.

    You seem to have done everything else under the sun, so I'm at a loss.

    Good luck!
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hey JeffJeff1

    Let's try this from a different angle.
    1. First, see link so your device manager shows driver details

      [*]See link so it shows unconnected devices when showing Hidden Devices
    2. Install SysExporter cuz is handy to grab text from Windows
    3. Open Device Manager. Click View->Show Hidden Devices.
    4. You're gonna look under Network Adapters and Unknown Devices (yellow question mark) for any evidence of that network adapter is detected
    5. Devices shown with "ghost" icons are devices with drivers installed but but aren't currently connected (and would not normally be displayed by Device Manager except for our setup steps)
    6. Rt click properties on a device under network adapters or Unknown that might be the adapter to get more info
      • Click on the Details tab and you should see a Device Instance ID
      • The adapter is a PCI device? I'd expect a device id in a string format starting as PCI\VEN_xxxx&DEV_xxxx where xxxx are in hex (0-9, A, B, C, D, E)
      • If you see it, or something else interesting, grab the text string by running SysExporter (cuz you can't just Copy/Paste it via windows)
      • Once SysExporter starts, the name of each windows (look in upper left of window for its title/name) appears listed in sysexporter upper pane. Click Title to sort. So see what the window name is containing the device ID.
      • Find the window name in SysExporter list. click on it to see its contents in lower pane. Probably several instances of the name to check. One of them will be device id (hint: Look at Items column. Probably will be non-zero if it's device id display entry)
      • When u see it displayed in lower pane, click to select it, actually Ctl- A to Select All (if anything with it), Ctrl-C to copy and then paste the content into a
        techSpot post
    Let's at least see if the adapter is detected and if the device ID gives us a clue
  16. JeffJeff1

    JeffJeff1 TS Rookie Topic Starter

    Thank you!

    Thanks everyone for trying to help me out, Towards the end of this thread it looked like we were actually going somewhere! I just wanted to thank everyone for taking the time to help me. After hours of digging through box`s I managed to find the driver CD, and everythings peachy! Once agian, thanks a lot everyone!
    Take care.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...