No POST on Dell Inspiron - Need to Access BIOS

Not open for further replies.
Some time ago, my Dell Inspiron 6000 developed a fault in that, whilst in Windows, the laptop would freeze up completely and required a hard shutdown. I diagnosed the problem to a fault with the onboard Broadcom RJ45 network interface card; I disabled the onboard NIC in the BIOS and all was well.

I recently needed to check a router LAN cable in a remote area, so used my laptop. My intention was to enable the NIC, check the cable and then disable the NIC again. Unfortunately, having saved the information to enable the onboard NIC in the BIOS and rebooted, the laptop will now not POST and I cannot access the BIOS to disable the NIC. The laptop begins the normal start sequence, but then hangs before the POST would start.

I know that if only I could disable the onboard NIC in the BIOS, all would be returned to normal. If anybody could help with information regarding accessing the BIOS in this situation, I'd be very grateful. I've even been to the extreme of dis-assembling the laptop and removing the rear RJ45 port from the motherboard in case it was a hardware problem - but I'm afraid that didn't work.

Thanks in advance,




Posts: 88   +0
Next stop, if you're that way inclined and if it is possible on that laptop, remove the network chip.

Thanks for the reply.

I did look at the network chip whilst removing the RJ45 port, but removing the chip will require a whole higher level of de-soldering and technical skill. It is the next option if there would appear to be no other solutions.

Spurred on to investigate removing the Broadcom network chip from the motherboard, I found that it was much easier to remove than the rear RJ45 port. No de-soldering was required, and the removal of the chip was effected by the use of my son's toy magnifying glass and levering the chip legs off the motherboard with a large pin. In the end, having dis-assembled the laptop (again - but I am now an expert in dis-assembling an Inspiron 6000!) it took less than 2 minutes to remove the network chip.:)

The result, having re-assembled the laptop, was that it WORKED! :):):). The initial Dell POST screen popped up, and then a black screen with cursor and a statement that the configuration was incorrect and that I should re-run the setup. The next screen up was the BIOS, and I was able to disble the (now no longer present) onboard NIC. The reboot after saving the BIOS information was absolutely normal and Windows started and worked correctly. I am sending this post from the resurrected laptop!
It will have to be the wifi...........

I think my investigative time with this particular laptop is over - it will have to be the wifi from now on!
Not open for further replies.